summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-07-26 14:16:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-07-26 14:16:06 +0000
commit97bf0caab4f0d517df5c94cfd12944bed273e18c (patch)
treef8a4985a3c3bc8019c7486e5a6f6a61b60b599fe /dev-haskell/cpphs/cpphs-1.19.ebuild
parentPort to ghc-7.10. (diff)
downloadhistorical-97bf0caab4f0d517df5c94cfd12944bed273e18c.tar.gz
historical-97bf0caab4f0d517df5c94cfd12944bed273e18c.tar.bz2
historical-97bf0caab4f0d517df5c94cfd12944bed273e18c.zip
Disable HCFLAGS='-g', it breaks ghc-7.10.
Package-Manager: portage-2.2.20/cvs/Linux x86_64 Manifest-Sign-Key: 0x611FF3AA
Diffstat (limited to 'dev-haskell/cpphs/cpphs-1.19.ebuild')
-rw-r--r--dev-haskell/cpphs/cpphs-1.19.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-haskell/cpphs/cpphs-1.19.ebuild b/dev-haskell/cpphs/cpphs-1.19.ebuild
index 81a913380543..7ade78783e6e 100644
--- a/dev-haskell/cpphs/cpphs-1.19.ebuild
+++ b/dev-haskell/cpphs/cpphs-1.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cpphs/cpphs-1.19.ebuild,v 1.1 2015/04/04 09:13:53 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cpphs/cpphs-1.19.ebuild,v 1.2 2015/07/26 14:16:05 slyfox Exp $
EAPI=5
@@ -26,3 +26,9 @@ RDEPEND="dev-haskell/old-locale:=[profile?]
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
+
+src_prepare() {
+ # https://ghc.haskell.org/trac/ghc/ticket/10667
+ [[ $(ghc-version) == 7.10.1.20150630 ]] && replace-hcflags -g ''
+ [[ $(ghc-version) == 7.10.2 ]] && replace-hcflags -g ''
+}