summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-14 19:44:31 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-14 19:44:31 +0000
commit14ea4feece8c241931b19a2c11c2b81b58253491 (patch)
tree0dbbd99d19d382647a2e1558a098e104bb33ec5a /dev-java/jacl
parentnew revision (diff)
downloadhistorical-14ea4feece8c241931b19a2c11c2b81b58253491.tar.gz
historical-14ea4feece8c241931b19a2c11c2b81b58253491.tar.bz2
historical-14ea4feece8c241931b19a2c11c2b81b58253491.zip
Initial Release.
Diffstat (limited to 'dev-java/jacl')
-rw-r--r--dev-java/jacl/ChangeLog10
-rw-r--r--dev-java/jacl/Manifest4
-rw-r--r--dev-java/jacl/files/digest-jacl-1.3.11
-rw-r--r--dev-java/jacl/jacl-1.3.1.ebuild35
-rw-r--r--dev-java/jacl/metadata.xml18
5 files changed, 68 insertions, 0 deletions
diff --git a/dev-java/jacl/ChangeLog b/dev-java/jacl/ChangeLog
new file mode 100644
index 000000000000..54acaee25391
--- /dev/null
+++ b/dev-java/jacl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/jacl
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jacl/ChangeLog,v 1.1 2004/02/14 19:44:29 zx Exp $
+
+*jacl-1.3.1 (14 Feb 2004)
+
+ 14 Feb 2004; <zx@gentoo.org> jacl-1.3.1.ebuild:
+ Initial Import. Thanks to Kevin Polalses <kevin.poalses@poalsoft.com> for
+ initial ebuild. Bug #41567
+
diff --git a/dev-java/jacl/Manifest b/dev-java/jacl/Manifest
new file mode 100644
index 000000000000..bb1c5e09b69f
--- /dev/null
+++ b/dev-java/jacl/Manifest
@@ -0,0 +1,4 @@
+MD5 b50a5dacab8e698bb3cd7b70e61b3692 jacl-1.3.1.ebuild 871
+MD5 b81bf6aef681d2c34d220e3a6b061068 ChangeLog 386
+MD5 971ccd4be3eb54aaadc4cd56fa3c5d3d metadata.xml 2052
+MD5 541ab414e62e7478e8e2354797196ea3 files/digest-jacl-1.3.1 61
diff --git a/dev-java/jacl/files/digest-jacl-1.3.1 b/dev-java/jacl/files/digest-jacl-1.3.1
new file mode 100644
index 000000000000..1497e71a1592
--- /dev/null
+++ b/dev-java/jacl/files/digest-jacl-1.3.1
@@ -0,0 +1 @@
+MD5 e65756e49b1e48db73d730069b8a4225 jacl1.3.1.tar.gz 981491
diff --git a/dev-java/jacl/jacl-1.3.1.ebuild b/dev-java/jacl/jacl-1.3.1.ebuild
new file mode 100644
index 000000000000..7f12f46f79c2
--- /dev/null
+++ b/dev-java/jacl/jacl-1.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jacl/jacl-1.3.1.ebuild,v 1.1 2004/02/14 19:44:30 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Jacl is an implementation of Tcl written in Java."
+HOMEPAGE="http://tcljava.sourceforge.net"
+SRC_URI="mirror://sourceforge/tcljava/${P//-}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+IUSE="jikes doc"
+
+DEPEND=">=virtual/jdk-1.1
+ jikes? ( >=dev-java/jikes-1.19 )"
+
+RDEPEND=">=dev-lang/tcl-8.4.5
+ >=virtual/jdk-1.1"
+
+S=${WORKDIR}/${P//-}
+
+src_compile() {
+ econf --enable-jacl `use_with jikes` || die
+ emake DESTDIR="/usr/share/${PN}" || die "emake failed"
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+ dobin jaclsh
+ dodoc README ChangeLog known_issues.txt new_features.txt
+
+ [ `use doc` ] && dohtml -r docs/*
+}
diff --git a/dev-java/jacl/metadata.xml b/dev-java/jacl/metadata.xml
new file mode 100644
index 000000000000..12abf51869ca
--- /dev/null
+++ b/dev-java/jacl/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<maintainer>
+ <email>zx@gentoo.org</email>
+ <name>Chris Aniszczyk</name>
+</maintainer>
+<longdescription>
+ The Tcl/Java project's goal is to make integrating the Java platform and the Tcl scripting language as easy as possible. The project actually consists of two distinct packages, called Tcl Blend and Jacl. It is important to understand what each package provides and in what situations one might choose to use Jacl or Tcl Blend.
+
+ Tcl Blend is a Tcl extension that makes use of JNI to facilitate communication between a Java interpreter and a Tcl interpreter. Tcl Blend is typically used to load a Java interpreter into an existing Tcl process, so that functionality implemented in Java can be accessed via Tcl. One can also load Tcl Blend and Tcl into a Java process, which is a great way to add scripting functionality to an existing Java application. Because Tcl Blend is a normal Tcl extension, one can use it with other popular Tcl extensions like Tk, Expect, and Itcl.
+
+ Jacl is a self-contained implementation of a Tcl interpreter, written entirely in Java. Jacl also includes features that facilitate communication between a Java interpreter and a Tcl interpreter. Jacl is typically used to incorporate scripting functionality into an existing Java application. For users who want to avoid adding any native code to their Java applications, Jacl is the ideal solution.
+
+ Tcl Blend and Jacl define both a Tcl API and a Java API that make it easy to call Java code from Tcl or call Tcl code from Java. For example, one could allocate a Java object in a Tcl script and interactively invoke Java methods on the object. It is also easy to use the supplied API to evaluate a Tcl procedure from a Java method or implement Tcl procudures in Java. The flexible API and wealth of implementation options provided by the Tcl/Java project make integrating Tcl and Java easy.
+</longdescription>
+</pkgmetadata>