summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2012-04-26 21:48:58 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2012-04-26 21:48:58 +0000
commit4bd5f62ea583317cef992e3447f37d9fda706c12 (patch)
tree0779b2fc8e89cfb6146b92a9f7519ddeaeaafa0b /dev-java/netbeans-javafx
parentdev-java/netbeans-javadoc: version bump in 7.1 slot (diff)
downloadhistorical-4bd5f62ea583317cef992e3447f37d9fda706c12.tar.gz
historical-4bd5f62ea583317cef992e3447f37d9fda706c12.tar.bz2
historical-4bd5f62ea583317cef992e3447f37d9fda706c12.zip
dev-java/netbeans-javafx: version bump in 7.1 slot
Package-Manager: portage-2.1.10.57/cvs/Linux x86_64
Diffstat (limited to 'dev-java/netbeans-javafx')
-rw-r--r--dev-java/netbeans-javafx/ChangeLog8
-rw-r--r--dev-java/netbeans-javafx/netbeans-javafx-7.1.2.ebuild112
2 files changed, 119 insertions, 1 deletions
diff --git a/dev-java/netbeans-javafx/ChangeLog b/dev-java/netbeans-javafx/ChangeLog
index fded2fc9151b..dbfe60bf4179 100644
--- a/dev-java/netbeans-javafx/ChangeLog
+++ b/dev-java/netbeans-javafx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/netbeans-javafx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-javafx/ChangeLog,v 1.2 2012/03/05 14:17:42 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-javafx/ChangeLog,v 1.3 2012/04/26 21:48:58 fordfrog Exp $
+
+*netbeans-javafx-7.1.2 (26 Apr 2012)
+
+ 26 Apr 2012; Miroslav Šulc <fordfrog@gentoo.org>
+ +netbeans-javafx-7.1.2.ebuild:
+ Version bump in 7.1 slot
*netbeans-javafx-7.1.1 (05 Mar 2012)
diff --git a/dev-java/netbeans-javafx/netbeans-javafx-7.1.2.ebuild b/dev-java/netbeans-javafx/netbeans-javafx-7.1.2.ebuild
new file mode 100644
index 000000000000..c4b092613e0e
--- /dev/null
+++ b/dev-java/netbeans-javafx/netbeans-javafx-7.1.2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-javafx/netbeans-javafx-7.1.2.ebuild,v 1.1 2012/04/26 21:48:58 fordfrog Exp $
+
+EAPI="4"
+WANT_ANT_TASKS="ant-nodeps"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Netbeans JavaFX Cluster"
+HOMEPAGE="http://netbeans.org/projects/javafx"
+SLOT="7.1"
+SOURCE_URL="http://dlc.sun.com.edgesuite.net/netbeans/7.1.2/final/zip/netbeans-7.1.2-201204101705-src.zip"
+SRC_URI="${SOURCE_URL}
+ http://dev.gentoo.org/~fordfrog/distfiles/netbeans-9999-r1-build.xml.patch.bz2
+ http://hg.netbeans.org/binaries/A806D99716C5E9441BFD8B401176FDDEFC673022-bindex-2.2.jar
+ http://hg.netbeans.org/binaries/418FC62C8A6EF5311987B01FE389B1F88EFDDCA2-jemmy-2.3.0.0.jar"
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}"
+
+CDEPEND="~dev-java/netbeans-ide-${PV}
+ ~dev-java/netbeans-java-${PV}
+ ~dev-java/netbeans-platform-${PV}"
+DEPEND="virtual/jdk:1.6
+ app-arch/unzip
+ ${CDEPEND}
+ dev-java/javahelp:0
+ dev-java/junit:4"
+RDEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+INSTALL_DIR="/usr/share/${PN}-${SLOT}"
+
+EANT_BUILD_XML="nbbuild/build.xml"
+EANT_BUILD_TARGET="rebuild-cluster"
+EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.javafx -Dext.binaries.downloaded=true"
+EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
+JAVA_PKG_BSFIX="off"
+
+src_unpack() {
+ unpack $(basename ${SOURCE_URL})
+
+ einfo "Deleting bundled jars..."
+ find -name "*.jar" -type f -delete
+
+ unpack netbeans-9999-r1-build.xml.patch.bz2
+
+ pushd "${S}" >/dev/null || die
+ ln -s "${DISTDIR}"/A806D99716C5E9441BFD8B401176FDDEFC673022-bindex-2.2.jar apisupport.harness/external/bindex-2.2.jar || die
+ ln -s "${DISTDIR}"/418FC62C8A6EF5311987B01FE389B1F88EFDDCA2-jemmy-2.3.0.0.jar jemmy/external/jemmy-2.3.0.0.jar || die
+ popd >/dev/null || die
+}
+
+src_prepare() {
+ einfo "Deleting bundled class files..."
+ find -name "*.class" -type f | xargs rm -vf
+
+ epatch netbeans-9999-r1-build.xml.patch
+
+ # Support for custom patches
+ if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
+ local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
+
+ if [ -n "${files}" ] ; then
+ einfo "Applying custom patches:"
+
+ for file in ${files} ; do
+ epatch "${file}"
+ done
+ fi
+ fi
+
+ einfo "Symlinking external libraries..."
+ java-pkg_jar-from --build-only --into apisupport.harness/external javahelp jsearch.jar jsearch-2.0_05.jar
+ java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
+ java-pkg_jar-from --build-only --into libs.junit4/external junit-4 junit.jar junit-4.10.jar
+
+ einfo "Linking in other clusters..."
+ mkdir "${S}"/nbbuild/netbeans || die
+ pushd "${S}"/nbbuild/netbeans >/dev/null || die
+
+ ln -s /usr/share/netbeans-ide-${SLOT} ide || die
+ cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.ide.built
+
+ ln -s /usr/share/netbeans-java-${SLOT} java || die
+ cat /usr/share/netbeans-java-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.java.built
+
+ ln -s /usr/share/netbeans-platform-${SLOT} platform || die
+ cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.platform.built
+
+ popd >/dev/null || die
+
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ pushd nbbuild/netbeans/javafx >/dev/null || die
+
+ insinto ${INSTALL_DIR}
+
+ grep -E "/javafx$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
+
+ doins -r *
+
+ popd >/dev/null || die
+
+ dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/javafx
+}