summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2010-01-16 10:38:29 +0000
committerHarald van Dijk <truedfx@gentoo.org>2010-01-16 10:38:29 +0000
commit0066b57af7c1cf2606a8332cf58a441ed6d317b7 (patch)
tree94622f8a6bf24e64b809d164d43688e6732786cb /dev-lang/fpc-ide
parentStable on alpha, bug #255363 (diff)
downloadhistorical-0066b57af7c1cf2606a8332cf58a441ed6d317b7.tar.gz
historical-0066b57af7c1cf2606a8332cf58a441ed6d317b7.tar.bz2
historical-0066b57af7c1cf2606a8332cf58a441ed6d317b7.zip
Version bumps
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/fpc-ide')
-rw-r--r--dev-lang/fpc-ide/ChangeLog9
-rw-r--r--dev-lang/fpc-ide/fpc-ide-2.4.0.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-lang/fpc-ide/ChangeLog b/dev-lang/fpc-ide/ChangeLog
index 85195b73aaf5..240f5cca7f35 100644
--- a/dev-lang/fpc-ide/ChangeLog
+++ b/dev-lang/fpc-ide/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/fpc-ide
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/ChangeLog,v 1.15 2009/06/25 20:37:52 truedfx Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/ChangeLog,v 1.16 2010/01/16 10:38:28 truedfx Exp $
+
+*fpc-ide-2.4.0 (16 Jan 2010)
+
+ 16 Jan 2010; Harald van Dijk <truedfx@gentoo.org> +fpc-ide-2.4.0.ebuild:
+ Version bump
25 Jun 2009; Harald van Dijk <truedfx@gentoo.org> fpc-ide-2.2.4.ebuild:
Don't try to create fp config files in /usr during build (bug #274518 by
diff --git a/dev-lang/fpc-ide/fpc-ide-2.4.0.ebuild b/dev-lang/fpc-ide/fpc-ide-2.4.0.ebuild
new file mode 100644
index 000000000000..35b49e6ee2a2
--- /dev/null
+++ b/dev-lang/fpc-ide/fpc-ide-2.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/fpc-ide-2.4.0.ebuild,v 1.1 2010/01/16 10:38:28 truedfx Exp $
+
+S="${WORKDIR}/fpcbuild-${PV}/fpcsrc/ide"
+
+HOMEPAGE="http://www.freepascal.org/"
+DESCRIPTION="Free Pascal Compiler Integrated Development Environment"
+SRC_URI="mirror://sourceforge/freepascal/fpcbuild-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1 LGPL-2.1-FPC"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="~dev-lang/fpc-${PV}"
+RDEPEND="${DEPEND}"
+
+# test gives compile errors, was not updated with fpc changes
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A} || die "Unpacking ${A} failed!"
+
+ find "${WORKDIR}" -name Makefile -exec sed -i -e 's/ -Xs / /g' {} + || die
+
+ # Use default configuration (minus stripping) unless specifically requested otherwise
+ if ! test ${PPC_CONFIG_PATH+set}; then
+ local FPCVER=$(fpc -iV)
+ export PPC_CONFIG_PATH="${WORKDIR}"
+ sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+ sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+ sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
+ fi
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake -j1 INSTALL_PREFIX="${D}"usr install || die "make install failed"
+}
+
+pkg_postinst() {
+ einfo "To read the documentation, enable the doc USE flag for dev-lang/fpc,"
+ einfo "and add /usr/share/doc/fpc-${PV}/fpctoc.htx to the Help Files list."
+}