summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-16 12:35:57 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-16 12:35:57 +0000
commita3f958f72564c5e1a66e90e672e5e3f22c2cd113 (patch)
tree030a3cb08a505c94f16650f2e0a92753ed6a0785 /dev-libs/libowfat
parentfalse alarm (diff)
downloadhistorical-a3f958f72564c5e1a66e90e672e5e3f22c2cd113.tar.gz
historical-a3f958f72564c5e1a66e90e672e5e3f22c2cd113.tar.bz2
historical-a3f958f72564c5e1a66e90e672e5e3f22c2cd113.zip
libowfat - gpl version of djbernsteins libraries - by felix von leitner.
Diffstat (limited to 'dev-libs/libowfat')
-rw-r--r--dev-libs/libowfat/ChangeLog9
-rw-r--r--dev-libs/libowfat/files/digest-libowfat-0.101
-rw-r--r--dev-libs/libowfat/libowfat-0.10.ebuild41
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libowfat/ChangeLog b/dev-libs/libowfat/ChangeLog
new file mode 100644
index 000000000000..c7c82af9d40c
--- /dev/null
+++ b/dev-libs/libowfat/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-libs/libowfat
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*libowfat-0.10-<PACKAGE_RELEASE> (29 Mar 2002)
+
+ 29 Mar 2002; Thilo Bangert <thilo.bangert@gmx.net> ChangeLog :
+
+ initial release ;-)
diff --git a/dev-libs/libowfat/files/digest-libowfat-0.10 b/dev-libs/libowfat/files/digest-libowfat-0.10
new file mode 100644
index 000000000000..13340e619413
--- /dev/null
+++ b/dev-libs/libowfat/files/digest-libowfat-0.10
@@ -0,0 +1 @@
+MD5 20a7d841114caa50da8ef11167206ada libowfat-0.10.tar.bz2 35741
diff --git a/dev-libs/libowfat/libowfat-0.10.ebuild b/dev-libs/libowfat/libowfat-0.10.ebuild
new file mode 100644
index 000000000000..815050a7ff32
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Author: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein."
+SRC_URI="http://www.fefe.de/libowfat/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+DEPEND=">=dev-libs/dietlibc-0.16"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ Makefile.orig > Makefile
+
+ #patch Makefile to fix a bug in the install section
+ #this has been submitted upstream and is fixed in cvs
+ #ie. it should not be necessary for libowfat-0.11 and later
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+
+ make \
+ LIBDIR=${D}/usr/lib \
+ MAN3DIR=${D}/usr/share/man/man3 \
+ INCLUDEDIR=${D}/usr/include/libowfat \
+ install || die
+}