summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-10-20 10:10:48 +0000
committerEray Aslan <eras@gentoo.org>2012-10-20 10:10:48 +0000
commitd2d04554501a8b4aca10d3c801d3265da11c6fd9 (patch)
tree3d26ceceb7340c5a8f25af16867243363f41a446 /dev-libs/libverto/libverto-0.2.5.ebuild
parentarg, forgot to check testsuite, it's still broken due to upstream ignoring it (diff)
downloadhistorical-d2d04554501a8b4aca10d3c801d3265da11c6fd9.tar.gz
historical-d2d04554501a8b4aca10d3c801d3265da11c6fd9.tar.bz2
historical-d2d04554501a8b4aca10d3c801d3265da11c6fd9.zip
Version bump
Package-Manager: portage-2.2.0_alpha141/cvs/Linux x86_64 Manifest-Sign-Key: 0x77F1F175586A3B1F
Diffstat (limited to 'dev-libs/libverto/libverto-0.2.5.ebuild')
-rw-r--r--dev-libs/libverto/libverto-0.2.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libverto/libverto-0.2.5.ebuild b/dev-libs/libverto/libverto-0.2.5.ebuild
new file mode 100644
index 000000000000..54b727955445
--- /dev/null
+++ b/dev-libs/libverto/libverto-0.2.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libverto/libverto-0.2.5.ebuild,v 1.1 2012/10/20 10:10:37 eras Exp $
+
+EAPI=4
+
+DESCRIPTION="Main event loop abstraction library"
+HOMEPAGE="https://fedorahosted.org/libverto/"
+SRC_URI="https://fedorahosted.org/releases/l/i/libverto/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-fbsd"
+IUSE="glib +libev libevent tevent +threads static-libs"
+
+# file collisions
+DEPEND="!=app-crypt/mit-krb5-1.10.1-r0
+ !=app-crypt/mit-krb5-1.10.1-r1
+ !=app-crypt/mit-krb5-1.10.1-r2
+ glib? ( >=dev-libs/glib-2.29 )
+ libev? ( >=dev-libs/libev-4.11 )
+ libevent? ( >=dev-libs/libevent-2.0 )
+ tevent? ( sys-libs/tevent )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( glib libev libevent tevent ) "
+
+src_prepare() {
+ # known problem uptream with tevent write test. tevent does not fire a
+ # callback on error, but we explicitly test for this behaviour. Do not run
+ # tevent tests for now.
+ sed -i -e 's/def HAVE_TEVENT/ 0/' tests/test.h || die
+}
+
+src_configure() {
+ econf \
+ $(use_with glib) \
+ $(use_with libev) \
+ $(use_with libevent) \
+ $(use_with tevent) \
+ $(use_with threads pthread) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS INSTALL README
+
+ use static-libs || find "${D}" -name '*.la' -delete
+}