summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-11 16:51:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-11 16:51:39 +0000
commit7f2d6e054058ebfd08d5d8ac3f07fe588641cb93 (patch)
tree6d381b9ccd7bf4fdc17a32790a20f9c3d551cd87 /dev-lisp/openmcl
parent- marking 2.1.3 stable for all supporting arches (diff)
downloadhistorical-7f2d6e054058ebfd08d5d8ac3f07fe588641cb93.tar.gz
historical-7f2d6e054058ebfd08d5d8ac3f07fe588641cb93.tar.bz2
historical-7f2d6e054058ebfd08d5d8ac3f07fe588641cb93.zip
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lisp/openmcl')
-rw-r--r--dev-lisp/openmcl/ChangeLog10
-rw-r--r--dev-lisp/openmcl/Manifest2
-rw-r--r--dev-lisp/openmcl/files/digest-openmcl-0.14.2_p11
-rw-r--r--dev-lisp/openmcl/metadata.xml12
-rw-r--r--dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild70
5 files changed, 95 insertions, 0 deletions
diff --git a/dev-lisp/openmcl/ChangeLog b/dev-lisp/openmcl/ChangeLog
new file mode 100644
index 000000000000..7a4f39a27226
--- /dev/null
+++ b/dev-lisp/openmcl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/openmcl
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl/ChangeLog,v 1.1 2005/03/11 16:51:39 mkennedy Exp $
+
+*openmcl-0.14.2_p1 (11 Mar 2005)
+
+ 11 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +openmcl-0.14.2_p1.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/openmcl/Manifest b/dev-lisp/openmcl/Manifest
new file mode 100644
index 000000000000..91dda0b513c6
--- /dev/null
+++ b/dev-lisp/openmcl/Manifest
@@ -0,0 +1,2 @@
+MD5 5ae485bc9ea53f03aca27b2c501332fe openmcl-0.14.2_p1.ebuild 512
+MD5 0b1601a0fba77078c94cba935222f8cd files/digest-openmcl-0.14.2_p1 72
diff --git a/dev-lisp/openmcl/files/digest-openmcl-0.14.2_p1 b/dev-lisp/openmcl/files/digest-openmcl-0.14.2_p1
new file mode 100644
index 000000000000..378573b0b7a1
--- /dev/null
+++ b/dev-lisp/openmcl/files/digest-openmcl-0.14.2_p1
@@ -0,0 +1 @@
+MD5 8d4ef665b2d8cd15f989ed6102657016 openmcl_0.14.2.p1.o.tar.gz 2303796
diff --git a/dev-lisp/openmcl/metadata.xml b/dev-lisp/openmcl/metadata.xml
new file mode 100644
index 000000000000..daf6a52f4173
--- /dev/null
+++ b/dev-lisp/openmcl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+OpenMCL is a Common Lisp implementation. It began as a subset of the commercial
+MCL (Macintosh Common Lisp), and has grown into a full-featured, stable
+implementation. All of OpenMCL is released under the GNU Lesser General Public
+License. Commercial MCL does have a nicely integrated IDE and user interface
+libraries, which were not open-sourced and are not available in OpenMCL.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild b/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild
new file mode 100644
index 000000000000..ae41b7572206
--- /dev/null
+++ b/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild,v 1.1 2005/03/11 16:51:39 mkennedy Exp $
+
+inherit eutils common-lisp-common-2
+
+EXTRA_PV=o
+MY_PV=${PV/_p/.p}
+
+DESCRIPTION="OpenMCL is a Common Lisp implementation, derived from Digitool's MCL product"
+HOMEPAGE="http://openmcl.clozure.com/
+ http://packages.debian.org/unstable/devel/openmcl"
+SRC_URI="http://ftp.debian.org/debian/pool/main/o/${PN}/${PN}_${MY_PV}.${EXTRA_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND="=dev-lisp/common-lisp-controller-4*
+ >=dev-lisp/cl-asdf-1.84
+ dev-lisp/openmcl-build-tools"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+# The following relies heavily on what I read in debian/rules...
+
+src_unpack() {
+ unpack ${A}
+ pushd ${S}
+ sed -e "s,%ver%,${MY_PV}.${EXTRA_PV}," \
+ < debian/run-bootstrap.lisp.template \
+ > debian/run-bootstrap.lisp
+ cp debian/Makefile .
+ cp -a /usr/lib/openmcl/{PPCCL-orig,headers} .
+ popd
+}
+
+src_compile() {
+ OPENMCL=/usr/bin/openmcl make || die
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/bin
+ dodir /usr/lib/common-lisp/bin
+ dodir /usr/lib/openmcl
+ dodir /usr/lib/openmcl/lib
+ dodir /usr/lib/openmcl/library
+ make install DESTDIR=${D} || die
+ insinto /usr/lib/openmcl
+ doins debian/install-clc.lisp
+ exeinto /usr/lib/common-lisp/bin/
+ doexe debian/openmcl.sh
+ dohtml doc/HTML/*.html
+ doman debian/openmcl.1
+ do-debian-credits
+}
+
+pkg_postinst() {
+ standard-impl-postinst openmcl || die
+}
+
+pkg_postrm() {
+ standard-impl-postrm openmcl /usr/bin/openmcl
+ if [ ! -x /usr/bin/openmcl ]; then
+ rm -rf /usr/lib/openmcl/ || die
+ fi
+}