summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-25 20:02:02 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-25 20:02:02 +0000
commit3742ef0a96d1d70f1a873a3b169e35da65176b62 (patch)
tree820e61cd9adfbc7472c198c88d7a8efbdfa6af9a /dev-ml/lablgl
parentHeader updates/cleanups (diff)
downloadhistorical-3742ef0a96d1d70f1a873a3b169e35da65176b62.tar.gz
historical-3742ef0a96d1d70f1a873a3b169e35da65176b62.tar.bz2
historical-3742ef0a96d1d70f1a873a3b169e35da65176b62.zip
updated the labltk/ocaml checkup logic in pkg_setup()
Diffstat (limited to 'dev-ml/lablgl')
-rw-r--r--dev-ml/lablgl/ChangeLog7
-rw-r--r--dev-ml/lablgl/lablgl-0.98.ebuild9
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index ec36b2cc7277..ea10e8b37bc3 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for dev-ml/lablgl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.3 2002/10/25 09:38:36 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.4 2002/10/25 20:02:02 george Exp $
*lablgl-0.98.ebuild (03 Sep 2002)
24 Oct 2002; George Shapovalov <george@gentoo.org> lablgl-0.98.ebuild :
+ made labltk and ocaml check-up logic more smart. Now should work fine in every situation.
+ Thanks to Jeffrey Palmer <jeffrey.palmer.acm.org> for the tip on checking labltk existance.
+
+ 24 Oct 2002; George Shapovalov <george@gentoo.org> lablgl-0.98.ebuild :
+
lablgl requires ocaml compiled with tk support. Ocaml has tk as an optional dependency.
Added some code to pkg_setup to detect if the tcltk USE var is set and abort if not with the message
asking user to emerge ocaml with tk support.
diff --git a/dev-ml/lablgl/lablgl-0.98.ebuild b/dev-ml/lablgl/lablgl-0.98.ebuild
index ed7347e2500a..9aaae0690ae6 100644
--- a/dev-ml/lablgl/lablgl-0.98.ebuild
+++ b/dev-ml/lablgl/lablgl-0.98.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-0.98.ebuild,v 1.4 2002/10/25 09:38:36 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-0.98.ebuild,v 1.5 2002/10/25 20:02:02 george Exp $
IUSE="opengl"
@@ -24,15 +24,18 @@ pkg_setup() {
#lablgl requires ocaml compiled with tk support while ocaml has it as an optional dependency
#need to do some checks and correct situation as if necessary
- if ! use tcltk; then
+ if ( ! which labltk && which ocaml ) || ! ( which labltk && which ocaml || use tcltk ); then
einfo "#######################################################"
einfo ""
- einfo "ebuild detected that tcltk USE flag is not defined"
+ einfo "ebuild detected that you have ocaml compiled without tk support "
+ einfo "or you do not have ocaml installed and tcltk USE flag is not defined"
+ einfo ""
einfo "lablgl requires ocaml built with tk support!!! "
einfo ""
einfo "Please make sure that ocaml is emerged with tk support: "
einfo 'USE="tcltk" emerge ocaml'
einfo "or even better add tcltk to you USE definition in make.conf"
+ einfo "and [re-]build ocaml with new dependency"
einfo ""
einfo "#######################################################"