summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-25 18:56:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-25 18:56:56 +0000
commit5688649faf51712f70b294693f5020c746be07c0 (patch)
tree6db6fabee25fcc2c5cf261726085857f33fa2ed6 /dev-ml/ocaml-data-notation
parentsparc stable wrt #370485 (diff)
downloadhistorical-5688649faf51712f70b294693f5020c746be07c0.tar.gz
historical-5688649faf51712f70b294693f5020c746be07c0.tar.bz2
historical-5688649faf51712f70b294693f5020c746be07c0.zip
version bump
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/ocaml-data-notation')
-rw-r--r--dev-ml/ocaml-data-notation/ChangeLog8
-rw-r--r--dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ml/ocaml-data-notation/ChangeLog b/dev-ml/ocaml-data-notation/ChangeLog
index df755a1c1135..9396e1ff1674 100644
--- a/dev-ml/ocaml-data-notation/ChangeLog
+++ b/dev-ml/ocaml-data-notation/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-data-notation
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ChangeLog,v 1.2 2011/05/24 14:00:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ChangeLog,v 1.3 2011/06/25 18:56:56 aballier Exp $
+
+*ocaml-data-notation-0.0.6 (25 Jun 2011)
+
+ 25 Jun 2011; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-data-notation-0.0.6.ebuild:
+ version bump
*ocaml-data-notation-0.0.4 (24 May 2011)
diff --git a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild
new file mode 100644
index 000000000000..19cc1d174453
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.6.ebuild,v 1.1 2011/06/25 18:56:56 aballier Exp $
+
+EAPI=3
+
+inherit findlib multilib
+
+DESCRIPTION="This project uses type-conv to dump OCaml data structure using OCaml data notation"
+HOMEPAGE="https://forge.ocamlcore.org/projects/odn"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/638/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-ml/type-conv-2.3.0"
+DEPEND="${RDEPEND}
+ dev-ml/ounit[ocamlopt?]
+ dev-ml/ocaml-fileutils[ocamlopt?]"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ chmod +x configure
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.txt || die "doc install failed"
+}