summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-01-16 15:32:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-01-16 15:32:01 +0000
commitc46cdf0491c2ce08c98acbaac5c16c9fef8894c4 (patch)
tree1d4d4137379176dcaf9f24d5d27aca7c4f2f1778 /dev-ml/postgresql-ocaml
parentremove old (diff)
downloadhistorical-c46cdf0491c2ce08c98acbaac5c16c9fef8894c4.tar.gz
historical-c46cdf0491c2ce08c98acbaac5c16c9fef8894c4.tar.bz2
historical-c46cdf0491c2ce08c98acbaac5c16c9fef8894c4.zip
version bump
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/postgresql-ocaml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog10
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.18.0.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index f6d8e72490ce..1afded3842f8 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.25 2011/12/31 11:32:59 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.26 2012/01/16 15:32:01 aballier Exp $
+
+*postgresql-ocaml-1.18.0 (16 Jan 2012)
+
+ 16 Jan 2012; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.18.0.ebuild:
+ version bump
*postgresql-ocaml-1.17.0 (31 Dec 2011)
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.18.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.18.0.ebuild
new file mode 100644
index 000000000000..f884571968ce
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.18.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.18.0.ebuild,v 1.1 2012/01/16 15:32:01 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-db/postgresql-base
+ dev-db/postgresql-server"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}