summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-02-14 19:11:54 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-02-14 19:11:54 +0000
commit07090dff95ed9cc4809e6064c9f0b6d76fe88ad0 (patch)
tree4db8837d81c7e8f197cb29bc7051934bbbd53d44 /dev-ml
parentRemoved sparc64-multilib reference. (diff)
downloadhistorical-07090dff95ed9cc4809e6064c9f0b6d76fe88ad0.tar.gz
historical-07090dff95ed9cc4809e6064c9f0b6d76fe88ad0.tar.bz2
historical-07090dff95ed9cc4809e6064c9f0b6d76fe88ad0.zip
Added eerror when ocaml doesn't support tcltk, but user have enabled tcltk use flag, bug #44057
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgl/ChangeLog7
-rw-r--r--dev-ml/lablgl/Manifest16
-rw-r--r--dev-ml/lablgl/lablgl-1.00.ebuild13
3 files changed, 26 insertions, 10 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index f08e6702a716..0636012a2855 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/lablgl
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.30 2004/12/29 22:46:11 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.31 2005/02/14 19:11:54 sekretarz Exp $
+
+ 14 Feb 2005; Karol Wojtaszek <sekretarz@gentoo.org> lablgl-1.00.ebuild:
+ Added eerror when ocaml doesn't support tcltk, but user have enabled tcltk use flag, bug #44057
29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/dev-ml/lablgl/Manifest b/dev-ml/lablgl/Manifest
index b1b6c2863706..dc800bf9e566 100644
--- a/dev-ml/lablgl/Manifest
+++ b/dev-ml/lablgl/Manifest
@@ -1,5 +1,15 @@
-MD5 a83e9847e0bc68e783dc21ac84cdd2b3 ChangeLog 4703
-MD5 b5a23c657baf5595f062ed597e743e1c lablgl-1.00.ebuild 2160
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 1410f60865a38b190cb76299e379a8fa lablgl-1.00.ebuild 2233
+MD5 4faba65c9f6eca230498c787ccc0e20c ChangeLog 4878
MD5 648a541494aceee26dbcfd76164f37ea metadata.xml 157
-MD5 e3979d1e494a41fb22b8dbd98f82978d files/digest-lablgl-1.00 63
MD5 fe2f6d4854f565091bda3022e0a62b31 files/lablgl-1.00-Makefile.config 371
+MD5 e3979d1e494a41fb22b8dbd98f82978d files/digest-lablgl-1.00 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFCEQYxZ/iYVBmujdURAke3AJ4ijEQsbLce+S6R0PUKVPcQJZzlYQCfWVqB
+oIFuoXF3miv5eCUkVvqfZ3E=
+=77Nt
+-----END PGP SIGNATURE-----
diff --git a/dev-ml/lablgl/lablgl-1.00.ebuild b/dev-ml/lablgl/lablgl-1.00.ebuild
index f7c080ec9cc9..55d8e1a8a103 100644
--- a/dev-ml/lablgl/lablgl-1.00.ebuild
+++ b/dev-ml/lablgl/lablgl-1.00.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.00.ebuild,v 1.15 2004/08/25 21:41:38 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.00.ebuild,v 1.16 2005/02/14 19:11:54 sekretarz Exp $
+
+inherit eutils
IUSE="tcltk glut doc"
@@ -23,14 +25,15 @@ pkg_setup()
if ( use tcltk )
then
#lablgl requires ocaml compiled with tk support while ocaml has it as an optional dependency
- if ( ! which labltk )
+ if ( ! built_with_use dev-lang/ocaml tcltk )
then
- eerror "It seems you don't have ocaml compiled with tk support"
+ eerror "You don't have ocaml compiled with tk support"
eerror ""
eerror "lablgl requires ocaml be built with tk support."
eerror ""
eerror "Please make sure that ocaml is installed with tk support."
- false;
+ sleep 5;
+ die "Ocaml is missing tk support";
fi
fi
}