summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-08 22:17:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-08 22:17:46 +0000
commit2f5196592ea1e7b5c9e50de4cf626d23f255df7e (patch)
treeeaa3c99a06c369e2123e95a5b2d0ed20cbdcd2b1 /dev-ml
parentremove old (diff)
downloadhistorical-2f5196592ea1e7b5c9e50de4cf626d23f255df7e.tar.gz
historical-2f5196592ea1e7b5c9e50de4cf626d23f255df7e.tar.bz2
historical-2f5196592ea1e7b5c9e50de4cf626d23f255df7e.zip
version bump
Package-Manager: portage-2.1.5_rc2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog8
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild57
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild53
4 files changed, 124 insertions, 2 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index cc4afc2bbcb6..de7e863af620 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.4 2008/04/08 22:02:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.5 2008/04/08 22:13:57 aballier Exp $
+
+*ocaml-sqlite3-1.0.2 (08 Apr 2008)
+
+ 08 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-1.0.2.ebuild:
+ version bump
08 Apr 2008; Alexis Ballier <aballier@gentoo.org>
-ocaml-sqlite3-0.22.0.ebuild:
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild
new file mode 100644
index 000000000000..782ad1005c87
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild,v 1.1 2008/04/08 22:13:57 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
+
+DEPEND=">=dev-lang/ocaml-3.09
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+}
+
+src_compile() {
+ econf
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES README TODO
+ use doc && dohtml doc/*
+}
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 9d86d828bd98..26c65cfaa61c 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.4 2008/01/04 02:07:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.5 2008/04/08 22:17:46 aballier Exp $
+
+*postgresql-ocaml-1.8.2 (08 Apr 2008)
+
+ 08 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.8.2.ebuild:
+ version bump
04 Jan 2008; Alexis Ballier <aballier@gentoo.org>
postgresql-ocaml-1.7.0.ebuild:
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild
new file mode 100644
index 000000000000..f7550471675d
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.8.2.ebuild,v 1.1 2008/04/08 22:17:46 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.09
+ >=dev-db/postgresql-7.3"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS VERSION
+
+ if use examples; then
+ for dir in examples/*
+ do
+ docinto $dir
+ dodoc $dir/*
+ done
+ fi
+}