summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-06-25 08:14:20 +0000
committerTorsten Veller <tove@gentoo.org>2011-06-25 08:14:20 +0000
commite44b0d5bb51e7cef9d7487badf487fdc722cfc5f (patch)
tree83d7a97afdbe6c9e8f4d4acf6a9361f7e361647d /dev-perl/XML-LibXML
parentmigrate to git-2 eclass (diff)
downloadhistorical-e44b0d5bb51e7cef9d7487badf487fdc722cfc5f.tar.gz
historical-e44b0d5bb51e7cef9d7487badf487fdc722cfc5f.tar.bz2
historical-e44b0d5bb51e7cef9d7487badf487fdc722cfc5f.zip
[bump] dev-perl/XML-LibXML-1.750.0
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/XML-LibXML')
-rw-r--r--dev-perl/XML-LibXML/ChangeLog7
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-perl/XML-LibXML/ChangeLog b/dev-perl/XML-LibXML/ChangeLog
index 6140b9e29c06..14c35c01acad 100644
--- a/dev-perl/XML-LibXML/ChangeLog
+++ b/dev-perl/XML-LibXML/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/XML-LibXML
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.104 2011/06/20 16:47:14 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.105 2011/06/25 08:14:20 tove Exp $
+
+*XML-LibXML-1.750.0 (25 Jun 2011)
+
+ 25 Jun 2011; Torsten Veller <tove@gentoo.org> +XML-LibXML-1.750.0.ebuild:
+ Version bump
*XML-LibXML-1.730.0 (20 Jun 2011)
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild
new file mode 100644
index 000000000000..2b399df62a2f
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild,v 1.1 2011/06/25 08:14:20 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=1.75
+inherit perl-module
+
+DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=">=dev-perl/XML-SAX-0.12
+ >=dev-libs/libxml2-2.6.21
+ >=dev-perl/XML-NamespaceSupport-1.07"
+RDEPEND="${DEPEND}
+ !dev-perl/XML-LibXML-Common"
+
+SRC_TEST="do"
+
+# rac can't discern any difference between the build with or without
+# this, and if somebody wants to reactivate it, get it out of global
+# scope.
+#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
+mytargets="pure_install doc_install"
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::LibXML::SAX::Parser
+ pkg_update_parser add XML::LibXML::SAX
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::LibXML::SAX::Parser
+ pkg_update_parser remove XML::LibXML::SAX
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}