summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Knight <tomk@gentoo.org>2006-06-17 10:07:38 +0000
committerTom Knight <tomk@gentoo.org>2006-06-17 10:07:38 +0000
commitd300df5e038ebcbb3a28ef1c6a39c51aba8cc869 (patch)
treeada65d1ad01b39f9cd569778f068430db3893fc3 /dev-php/smarty/smarty-2.6.14.ebuild
parentversion bump (diff)
downloadhistorical-d300df5e038ebcbb3a28ef1c6a39c51aba8cc869.tar.gz
historical-d300df5e038ebcbb3a28ef1c6a39c51aba8cc869.tar.bz2
historical-d300df5e038ebcbb3a28ef1c6a39c51aba8cc869.zip
Version bump to 2.6.14, thanks to Dave Liefbroer, fixes bug #135879
Package-Manager: portage-2.0.54
Diffstat (limited to 'dev-php/smarty/smarty-2.6.14.ebuild')
-rw-r--r--dev-php/smarty/smarty-2.6.14.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/smarty/smarty-2.6.14.ebuild b/dev-php/smarty/smarty-2.6.14.ebuild
new file mode 100644
index 000000000000..4377abd7745d
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.14.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.14.ebuild,v 1.1 2006/06/17 10:07:38 tomk Exp $
+
+inherit php-lib-r1
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://smarty.php.net/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/smarty-docs )"
+
+MY_P="Smarty-${PV}"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+ dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+ php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+ einfo "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+ einfo "To use it in your scripts, either"
+ einfo "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+ einfo "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+ einfo "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
+ einfo "cgi-php[45] or cli-php[45])."
+ echo
+ einfo "If you're upgrading from a previous version make sure to clear out your"
+ einfo "templates_c and cache directories as some include paths have changed!"
+ echo
+ einfo "The Smarty include directory has changed in 2.6.12 from /usr/share/php/Smarty/"
+ einfo "to /usr/share/php/${PHP_LIB_NAME}/ you will need to change your SMARTY_DIR or"
+ einfo "include_path accordingly."
+}