summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-26 16:35:53 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-26 16:35:53 +0000
commit748944984fdfaadba9dc9977e82fb75af5d40172 (patch)
tree69893075b2159cf512961d47f12e9de6634aba91 /dev-php/smarty/smarty-2.6.19.ebuild
parentRemove double echangelog. (diff)
downloadhistorical-748944984fdfaadba9dc9977e82fb75af5d40172.tar.gz
historical-748944984fdfaadba9dc9977e82fb75af5d40172.tar.bz2
historical-748944984fdfaadba9dc9977e82fb75af5d40172.zip
Version bump, import from the php overlay
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-php/smarty/smarty-2.6.19.ebuild')
-rw-r--r--dev-php/smarty/smarty-2.6.19.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/smarty/smarty-2.6.19.ebuild b/dev-php/smarty/smarty-2.6.19.ebuild
new file mode 100644
index 000000000000..794dd3fe13c5
--- /dev/null
+++ b/dev-php/smarty/smarty-2.6.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.19.ebuild,v 1.1 2008/02/26 16:35:53 armin76 Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://smarty.php.net/"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+PDEPEND="doc? ( dev-php/smarty-docs )"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+ dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+
+ php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+ elog "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
+ elog "cgi-php[45] or cli-php[45])."
+ elog
+ elog "If you're upgrading from a previous version make sure to clear out your"
+ elog "templates_c and cache directories as some include paths have changed!"
+}