summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-20 15:19:46 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-20 15:19:46 +0000
commit26df79cef2d30ad1a2f5be498f9f981f62d7c267 (patch)
treecba6c491162c02e558533e459df725afd0ccebba /dev-python/apsw
parentVersion bump <http://my.opera.com/desktopteam/blog/2009/11/20/unite-fixes-and... (diff)
downloadhistorical-26df79cef2d30ad1a2f5be498f9f981f62d7c267.tar.gz
historical-26df79cef2d30ad1a2f5be498f9f981f62d7c267.tar.bz2
historical-26df79cef2d30ad1a2f5be498f9f981f62d7c267.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/apsw-3.5.9.2.ebuild37
-rw-r--r--dev-python/apsw/apsw-3.6.17.1.ebuild43
-rw-r--r--dev-python/apsw/files/apsw-3.5.9.2-gentoo.patch12
3 files changed, 0 insertions, 92 deletions
diff --git a/dev-python/apsw/apsw-3.5.9.2.ebuild b/dev-python/apsw/apsw-3.5.9.2.ebuild
deleted file mode 100644
index ffb958f439df..000000000000
--- a/dev-python/apsw/apsw-3.5.9.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.5.9.2.ebuild,v 1.2 2008/11/09 14:38:03 maekke Exp $
-
-inherit eutils distutils versionator
-
-MY_PV=$(replace_version_separator 3 -r)
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-SRC_URI="http://apsw.googlecode.com/files/${PN}-${MY_PV}.zip"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 x86"
-IUSE=""
-
-RDEPEND="dev-lang/python
- >=dev-db/sqlite-3.5.9"
-DEPEND="app-arch/unzip
- ${RDEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_unpack() {
- distutils_src_unpack
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-src_install() {
- distutils_src_install
- dohtml apsw.html
-}
-
-src_test() {
- PYTHONPATH="$(ls -d build/lib.*)" "${python}" tests.py || die "tests failed"
-}
diff --git a/dev-python/apsw/apsw-3.6.17.1.ebuild b/dev-python/apsw/apsw-3.6.17.1.ebuild
deleted file mode 100644
index c50159b41834..000000000000
--- a/dev-python/apsw/apsw-3.6.17.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apsw/apsw-3.6.17.1.ebuild,v 1.2 2009/09/08 02:36:18 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils versionator
-
-MY_PV=$(replace_version_separator 3 -r)
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="http://code.google.com/p/apsw/"
-SRC_URI="http://apsw.googlecode.com/files/${PN}-${MY_PV}.zip"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE=""
-
-RDEPEND="dev-lang/python
- >=dev-db/sqlite-3.6.6.2"
-DEPEND="app-arch/unzip
- ${RDEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_compile() {
- distutils_src_compile --omit=LOAD_EXTENSION
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" tests.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- dodoc doc/_sources/*
- dohtml -r doc/*
-}
diff --git a/dev-python/apsw/files/apsw-3.5.9.2-gentoo.patch b/dev-python/apsw/files/apsw-3.5.9.2-gentoo.patch
deleted file mode 100644
index d1e50964153a..000000000000
--- a/dev-python/apsw/files/apsw-3.5.9.2-gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur apsw-3.5.9-r2.orig/setup.py apsw-3.5.9-r2/setup.py
---- apsw-3.5.9-r2.orig/setup.py 2008-07-07 03:37:42.000000000 +0000
-+++ apsw-3.5.9-r2/setup.py 2008-08-15 17:31:07.000000000 +0000
-@@ -19,7 +19,7 @@
- # If you compiled SQLite omitting functionality then specify the same
- # defines here. For example this exlcudes loadable extensions.
- #
--# define_macros.append( ('SQLITE_OMIT_LOAD_EXTENSION', '1') )
-+define_macros.append( ('SQLITE_OMIT_LOAD_EXTENSION', '1') )
-
- include_dirs=[]
- library_dirs=[]