summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-04-08 06:28:37 +0000
committerJustin Lecher <jlec@gentoo.org>2015-04-08 06:28:37 +0000
commit02fd9997d4d1c0e25b6b5cbb50497386943f98c6 (patch)
tree5ca3bc152706cf40fd692c60ea189b45b4bd7372 /dev-python/pysolr/pysolr-3.3.0.ebuild
parentDrop 'free' from DESCRIPTION to reduce confusion with free software, bug #545396 (diff)
downloadhistorical-02fd9997d4d1c0e25b6b5cbb50497386943f98c6.tar.gz
historical-02fd9997d4d1c0e25b6b5cbb50497386943f98c6.tar.bz2
historical-02fd9997d4d1c0e25b6b5cbb50497386943f98c6.zip
New package written by me
Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0xB9D4F231BD1558AB!
Diffstat (limited to 'dev-python/pysolr/pysolr-3.3.0.ebuild')
-rw-r--r--dev-python/pysolr/pysolr-3.3.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pysolr/pysolr-3.3.0.ebuild b/dev-python/pysolr/pysolr-3.3.0.ebuild
new file mode 100644
index 000000000000..d19db20de425
--- /dev/null
+++ b/dev-python/pysolr/pysolr-3.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysolr/pysolr-3.3.0.ebuild,v 1.1 2015/04/08 06:28:36 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight python wrapper for Apache Solr"
+HOMEPAGE="https://pypi.python.org/pypi/pysolr/ http://github.com/toastdriven/pysolr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"