summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-26 07:06:06 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-26 07:06:06 +0000
commit7c223f0cfb515ab8c0ea647f998b37798c92e807 (patch)
treef9119b92f847d90afa0061a3fbceee3561605c07 /dev-ruby
parentVersion bump. Convert to ruby-fakegem. Dropped ppc64 keyword. (diff)
downloadhistorical-7c223f0cfb515ab8c0ea647f998b37798c92e807.tar.gz
historical-7c223f0cfb515ab8c0ea647f998b37798c92e807.tar.bz2
historical-7c223f0cfb515ab8c0ea647f998b37798c92e807.zip
Convert to ruby-fakegem.
Package-Manager: portage-2.1.7.16/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/oauth/ChangeLog10
-rw-r--r--dev-ruby/oauth/files/oauth-0.3.6-newgem.patch27
-rw-r--r--dev-ruby/oauth/oauth-0.3.6-r1.ebuild34
3 files changed, 69 insertions, 2 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index e905296fdfd0..4138a72ecfd3 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/oauth
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.6 2009/12/09 20:03:20 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.7 2010/02/26 07:06:04 graaff Exp $
+
+*oauth-0.3.6-r1 (25 Feb 2010)
+
+ 25 Feb 2010; Hans de Graaff <graaff@gentoo.org> +oauth-0.3.6-r1.ebuild,
+ +files/oauth-0.3.6-newgem.patch:
+ Convert to ruby-fakegem.
09 Dec 2009; Hans de Graaff <graaff@gentoo.org> -oauth-0.3.5.ebuild:
Remove old version.
diff --git a/dev-ruby/oauth/files/oauth-0.3.6-newgem.patch b/dev-ruby/oauth/files/oauth-0.3.6-newgem.patch
new file mode 100644
index 000000000000..d10136c0bfeb
--- /dev/null
+++ b/dev-ruby/oauth/files/oauth-0.3.6-newgem.patch
@@ -0,0 +1,27 @@
+Patch out newgem since we don't need it to install and it currently
+isn't available in Gentoo.
+
+--- Rakefile.orig 2010-02-25 07:56:59.000000000 +0100
++++ Rakefile 2010-02-25 07:56:28.000000000 +0100
+@@ -1,4 +1,4 @@
+-%w[rubygems rake rake/clean fileutils newgem rubigen hoe].each { |f| require f }
++%w[rubygems rake rake/clean fileutils rubigen hoe].each { |f| require f }
+ $LOAD_PATH << File.dirname(__FILE__) + '/lib'
+ require 'oauth'
+ require 'oauth/version'
+@@ -18,7 +18,6 @@
+ ['ruby-hmac','>= 0.3.1']
+ ]
+ p.extra_dev_deps = [
+- ['newgem', ">= #{::Newgem::VERSION}"],
+ ['actionpack'],
+ ['rack']
+ ]
+@@ -29,7 +28,6 @@
+ p.rsync_args = '-av --delete --ignore-errors'
+ end
+
+-require 'newgem/tasks' # load /tasks/*.rake
+ Dir['tasks/**/*.rake'].each { |t| load t }
+
+ # TODO - want other tests/tasks run by default? Add them to the list
diff --git a/dev-ruby/oauth/oauth-0.3.6-r1.ebuild b/dev-ruby/oauth/oauth-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..7f7ec0199077
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.3.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.3.6-r1.ebuild,v 1.1 2010/02/26 07:06:05 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc TODO"
+
+RUBY_FAKEGEM_EXTRAINSTALL="script"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers."
+HOMEPAGE="http://oauth.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RUBY_PATCHES=( "oauth-0.3.6-newgem.patch" )
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+ruby_add_rdepend ">=dev-ruby/ruby-hmac-0.3.1 dev-ruby/rubigen"
+
+all_ruby_prepare() {
+ # Remove test that requires an insecure version of actionpack
+ # http://github.com/mojodna/oauth/issues/#issue/12
+ rm -f test/test_action_controller_request_proxy.rb || die "Unable to remove failing test."
+}