summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-04-23 11:32:19 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-04-23 11:32:19 +0000
commit051f31630c67771d83adbab47d82440641cae5c5 (patch)
treefe024dabef2315a4be9a94d9bbb65a2993550b1d /dev-scheme/stklos/stklos-0.82.ebuild
parentia64 + x86 stable (diff)
downloadhistorical-051f31630c67771d83adbab47d82440641cae5c5.tar.gz
historical-051f31630c67771d83adbab47d82440641cae5c5.tar.bz2
historical-051f31630c67771d83adbab47d82440641cae5c5.zip
add deps and use flags
Package-Manager: portage-2.1.2.4
Diffstat (limited to 'dev-scheme/stklos/stklos-0.82.ebuild')
-rw-r--r--dev-scheme/stklos/stklos-0.82.ebuild28
1 files changed, 24 insertions, 4 deletions
diff --git a/dev-scheme/stklos/stklos-0.82.ebuild b/dev-scheme/stklos/stklos-0.82.ebuild
index c72a1d560980..2aa25e122e78 100644
--- a/dev-scheme/stklos/stklos-0.82.ebuild
+++ b/dev-scheme/stklos/stklos-0.82.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Technologies, Inc.
+# Copyright 2007 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/stklos-0.82.ebuild,v 1.1 2007/04/19 15:21:19 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/stklos-0.82.ebuild,v 1.2 2007/04/23 11:32:19 hkbst Exp $
DESCRIPTION="fast and light Scheme implementation"
HOMEPAGE="http://www.stklos.org"
@@ -9,8 +9,28 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND=""
+IUSE="threads ldap gtk gnome"
+DEPEND="dev-libs/gmp dev-libs/libpcre dev-libs/boehm-gc
+ ldap? ( net-nds/openldap )
+ gtk? ( x11-libs/gtk+ )"
+# gnome? ( )" # some using gnome should figure out what package will enable gnome support
+#silex and ``The Dominique Boucher LALR Package'' may also be deps, not in tree though
+RDEPEND="${DEPEND}"
+
+
+src_compile() {
+# Inverses of options are treated like the options themselves.
+# Therefore don't use use_enable or use_with or manually invert options.
+
+#anyone interested in lurc threads? not in tree though
+ econf $(use_enable threads threads pthreads) $(use ldap && echo --enable-ldap) $(use !gtk && echo --disable-gtk) $(use !gnome && echo --disable-gnome)
+
+# Thus unfortunately the following doesn't work
+# econf --enable-threads=pthreads $(use_enable ldap) $(use_enable gtk) $(use_enable gnome) \
+# --without-gmp-light --without-provided-gc --without-provided-regexp
+
+ emake || die "emake failed"
+}
src_install() {
emake DESTDIR="${D}" install || die "Install failed"