summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-05-07 19:43:22 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-05-07 19:43:22 +0000
commit1a104e86d5aaddad0ab037e240a63abfdead804f (patch)
treecd0c2b31ff20e5e3695708be97fdfb33f761f3f1 /dev-util/reswrap
parentAdded to ~ppc (diff)
downloadhistorical-1a104e86d5aaddad0ab037e240a63abfdead804f.tar.gz
historical-1a104e86d5aaddad0ab037e240a63abfdead804f.tar.bz2
historical-1a104e86d5aaddad0ab037e240a63abfdead804f.zip
Added Yaakov Selkowitz's eclass based fox ebuilds for testing.
Fixes #88924 Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-util/reswrap')
-rw-r--r--dev-util/reswrap/ChangeLog11
-rw-r--r--dev-util/reswrap/files/digest-reswrap-1.0.41
-rw-r--r--dev-util/reswrap/files/digest-reswrap-3.1.01
-rw-r--r--dev-util/reswrap/files/digest-reswrap-3.2.01
-rw-r--r--dev-util/reswrap/reswrap-1.0.4.ebuild26
-rw-r--r--dev-util/reswrap/reswrap-3.1.0.ebuild29
-rw-r--r--dev-util/reswrap/reswrap-3.2.0.ebuild31
7 files changed, 100 insertions, 0 deletions
diff --git a/dev-util/reswrap/ChangeLog b/dev-util/reswrap/ChangeLog
new file mode 100644
index 000000000000..a5f87c073239
--- /dev/null
+++ b/dev-util/reswrap/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-util/reswrap
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/reswrap/ChangeLog,v 1.1 2005/05/07 19:43:22 rphillips Exp $
+
+*reswrap-1.0.4 (07 May 2005)
+
+ 07 May 2005; <rphillips@gentoo.org> +reswrap-1.0.4.ebuild,
+ +reswrap-3.1.0.ebuild, +reswrap-3.2.0.ebuild:
+ Added Yaakov Selkowitz's eclass based fox ebuilds for testing.
+ Fixes #88924
+
diff --git a/dev-util/reswrap/files/digest-reswrap-1.0.4 b/dev-util/reswrap/files/digest-reswrap-1.0.4
new file mode 100644
index 000000000000..e50a7251241d
--- /dev/null
+++ b/dev-util/reswrap/files/digest-reswrap-1.0.4
@@ -0,0 +1 @@
+MD5 0b0c352154a24629985d9eccbd2e6bc6 fox-1.0.53.tar.gz 2120403
diff --git a/dev-util/reswrap/files/digest-reswrap-3.1.0 b/dev-util/reswrap/files/digest-reswrap-3.1.0
new file mode 100644
index 000000000000..16b67d09d7f3
--- /dev/null
+++ b/dev-util/reswrap/files/digest-reswrap-3.1.0
@@ -0,0 +1 @@
+MD5 6e996254fef94a558bb343daacd3261b fox-1.2.15.tar.gz 3895260
diff --git a/dev-util/reswrap/files/digest-reswrap-3.2.0 b/dev-util/reswrap/files/digest-reswrap-3.2.0
new file mode 100644
index 000000000000..d30a390d4f04
--- /dev/null
+++ b/dev-util/reswrap/files/digest-reswrap-3.2.0
@@ -0,0 +1 @@
+MD5 ecacdaf32d3a9da862de3fbf6788b65c fox-1.4.12.tar.gz 3922769
diff --git a/dev-util/reswrap/reswrap-1.0.4.ebuild b/dev-util/reswrap/reswrap-1.0.4.ebuild
new file mode 100644
index 000000000000..9f471d6af129
--- /dev/null
+++ b/dev-util/reswrap/reswrap-1.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/reswrap/reswrap-1.0.4.ebuild,v 1.1 2005/05/07 19:43:22 rphillips Exp $
+
+FOX_COMPONENT="utils"
+FOX_PV="1.0.53"
+
+inherit fox
+
+DESCRIPTION="Utility to wrap icon resources into C++ code, from the FOX Toolkit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~alpha ~hppa ~ia64 ~ppc ~ppc64 ~sparc"
+IUSE=""
+
+RDEPEND="virtual/libc"
+
+FOXCONF="--disable-cups \
+ --disable-jpeg \
+ --without-opengl \
+ --disable-png \
+ --disable-tiff \
+ --without-shm \
+ --without-x \
+ --disable-zlib"
diff --git a/dev-util/reswrap/reswrap-3.1.0.ebuild b/dev-util/reswrap/reswrap-3.1.0.ebuild
new file mode 100644
index 000000000000..5e451af31b62
--- /dev/null
+++ b/dev-util/reswrap/reswrap-3.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/reswrap/reswrap-3.1.0.ebuild,v 1.1 2005/05/07 19:43:22 rphillips Exp $
+
+FOX_COMPONENT="utils"
+FOX_PV="1.2.15"
+
+inherit fox
+
+DESCRIPTION="Utility to wrap icon resources into C++ code, from the FOX Toolkit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~alpha ~hppa ~ppc ~ppc64 ~sparc"
+IUSE=""
+
+RDEPEND="virtual/libc"
+
+FOXCONF="--disable-bz2lib \
+ --disable-cups \
+ --disable-jpeg \
+ --without-opengl \
+ --disable-png \
+ --disable-tiff \
+ --without-x \
+ --without-xcursor \
+ --without-xft \
+ --without-xshm \
+ --disable-zlib"
diff --git a/dev-util/reswrap/reswrap-3.2.0.ebuild b/dev-util/reswrap/reswrap-3.2.0.ebuild
new file mode 100644
index 000000000000..44194c2f501d
--- /dev/null
+++ b/dev-util/reswrap/reswrap-3.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/reswrap/reswrap-3.2.0.ebuild,v 1.1 2005/05/07 19:43:22 rphillips Exp $
+
+FOX_COMPONENT="utils"
+FOX_PV="1.4.12"
+
+inherit fox
+
+DESCRIPTION="Utility to wrap icon resources into C++ code, from the FOX Toolkit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~alpha ~hppa ~ppc ~ppc64 ~sparc"
+IUSE=""
+
+RDEPEND="virtual/libc"
+
+FOXCONF="--disable-bz2lib \
+ --disable-cups \
+ --disable-jpeg \
+ --without-opengl \
+ --disable-png \
+ --without-shape \
+ --disable-tiff \
+ --without-x \
+ --without-xcursor \
+ --without-xrandr \
+ --without-xshm \
+ --without-xft \
+ --disable-zlib"