summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-11-12 22:09:04 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-11-12 22:09:04 +0000
commite619b76d0145dc044e48f195e32b20f1f410d91a (patch)
tree0d38049e243be7af02e0299789266bc8bddb099c /dev-util
parentFix gcc4 problem (#153270) (diff)
downloadhistorical-e619b76d0145dc044e48f195e32b20f1f410d91a.tar.gz
historical-e619b76d0145dc044e48f195e32b20f1f410d91a.tar.bz2
historical-e619b76d0145dc044e48f195e32b20f1f410d91a.zip
New upstream version, superceeds 1.4.3.4
Package-Manager: portage-2.1.1-r1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog8
-rw-r--r--dev-util/git/files/digest-git-1.4.3.59
-rw-r--r--dev-util/git/git-1.4.3.5.ebuild151
3 files changed, 167 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 473bfe56319f..b4869ff3c371 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.143 2006/11/09 00:25:41 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.144 2006/11/12 22:09:04 ferdy Exp $
+
+*git-1.4.3.5 (12 Nov 2006)
+
+ 12 Nov 2006; Fernando J. Pereda <ferdy@gentoo.org> -git-1.4.3.4.ebuild,
+ +git-1.4.3.5.ebuild:
+ New upstream version, superceeds 1.4.3.4
09 Nov 2006; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
git-1.4.3.4.ebuild:
diff --git a/dev-util/git/files/digest-git-1.4.3.5 b/dev-util/git/files/digest-git-1.4.3.5
new file mode 100644
index 000000000000..b27394ab5f69
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.3.5
@@ -0,0 +1,9 @@
+MD5 db7c8dad84643b9f6744a0eca22521c7 git-1.4.3.5.tar.bz2 859712
+RMD160 076514f909a901f18f01151a1839b6cac03d1e1e git-1.4.3.5.tar.bz2 859712
+SHA256 8ab38be18a8221d2181a09b17dd98d4e29e33d897be7c6d9ee31495dc5756409 git-1.4.3.5.tar.bz2 859712
+MD5 8e1491ccfd838d80510d7836a11a3bbc git-htmldocs-1.4.3.5.tar.bz2 306180
+RMD160 8880c493ed1ff3ae361200dbfba0c7156542b908 git-htmldocs-1.4.3.5.tar.bz2 306180
+SHA256 b4674fe2013dc95b21b94f8b327d0c74017b5075fa991665c2e4cbb736b7fbc9 git-htmldocs-1.4.3.5.tar.bz2 306180
+MD5 e16a53986fb231c6d361ae358c24686e git-manpages-1.4.3.5.tar.bz2 98349
+RMD160 14628c3cd19d717e6544eecefe84989aca6fdd2c git-manpages-1.4.3.5.tar.bz2 98349
+SHA256 43fa90b9bd11723a3750dab74c5960ffb102feb04ceac9c6e74239e7e678a0c9 git-manpages-1.4.3.5.tar.bz2 98349
diff --git a/dev-util/git/git-1.4.3.5.ebuild b/dev-util/git/git-1.4.3.5.ebuild
new file mode 100644
index 000000000000..973319e63148
--- /dev/null
+++ b/dev-util/git/git-1.4.3.5.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.3.5.ebuild,v 1.1 2006/11/12 22:09:04 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common perl-module bash-completion
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc elibc_uclibc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ einfo " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo "These additional scripts need some dependencies:"
+ einfo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+ showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+ showpkgdeps git-svn "dev-util/subversion(USE=perl)" "dev-perl/libwww-perl"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-cvsserver "dev-perl/DBI" "dep-perl/DBD-SQLite"
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}