summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/parsec
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/parsec')
-rw-r--r--games-action/parsec/ChangeLog8
-rw-r--r--games-action/parsec/Manifest4
-rw-r--r--games-action/parsec/files/digest-parsec-01971
-rw-r--r--games-action/parsec/files/parsec3
-rw-r--r--games-action/parsec/parsec-0197.ebuild32
5 files changed, 48 insertions, 0 deletions
diff --git a/games-action/parsec/ChangeLog b/games-action/parsec/ChangeLog
new file mode 100644
index 000000000000..ef9def099dcc
--- /dev/null
+++ b/games-action/parsec/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/parsec
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+*parsec-0197 (12 Jul 2003)
+
+ 12 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Henrik Schöpel <Spock2000@gmx.de> #21760.
diff --git a/games-action/parsec/Manifest b/games-action/parsec/Manifest
new file mode 100644
index 000000000000..4178e510aae0
--- /dev/null
+++ b/games-action/parsec/Manifest
@@ -0,0 +1,4 @@
+MD5 b1474fdd4dba91a127dd4edee3137e96 files/digest-parsec-0197 74
+MD5 dbf54802fadb1edabd6f18885c2fb502 files/parsec 45
+MD5 e00832437a65ed58febe6de3f0c209e6 ChangeLog 375
+MD5 5e99f10bc78135ea24094f7909d41881 parsec-0197.ebuild 900
diff --git a/games-action/parsec/files/digest-parsec-0197 b/games-action/parsec/files/digest-parsec-0197
new file mode 100644
index 000000000000..b9e209b8bc71
--- /dev/null
+++ b/games-action/parsec/files/digest-parsec-0197
@@ -0,0 +1 @@
+MD5 47f442a2f1bf898733ad506f4c59b767 parsec_lan_build0197.tar.gz 85700536
diff --git a/games-action/parsec/files/parsec b/games-action/parsec/files/parsec
new file mode 100644
index 000000000000..ddf33eb11d4d
--- /dev/null
+++ b/games-action/parsec/files/parsec
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+exec ./launcher ${@}
diff --git a/games-action/parsec/parsec-0197.ebuild b/games-action/parsec/parsec-0197.ebuild
new file mode 100644
index 000000000000..d4abe74bc9be
--- /dev/null
+++ b/games-action/parsec/parsec-0197.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/parsec-0197.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Parsec - there is no safe distance"
+HOMEPAGE="http://openparsec.sourceforge.net/"
+SRC_URI="http://public.www.planetmirror.com/pub/parsec/${PV}/parsec_lan_build${PV}.tar.gz
+ ftp://planetmirror.com/pub/parsec/${PV}/parsec_lan_build${PV}.tar.gz
+ http://ftp.webmonster.de/pub/parsec/parsec_lan_build${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ virtual/opengl
+ virtual/glut
+ virtual/glu
+ media-libs/openal"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir}
+ cp -r * ${D}/${dir}/
+ dogamesbin ${FILESDIR}/parsec
+ dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/parsec
+ prepgamesdirs
+}