summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 04:45:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-30 04:45:22 +0000
commit2b555a44183a5a44f1b7cd47801fd9aeedb3c876 (patch)
tree0fee9d35f9f98d2aa1fa8ee114d43ec090456b39 /games-action
parentStable on mips, bug #75143 (diff)
downloadhistorical-2b555a44183a5a44f1b7cd47801fd9aeedb3c876.tar.gz
historical-2b555a44183a5a44f1b7cd47801fd9aeedb3c876.tar.bz2
historical-2b555a44183a5a44f1b7cd47801fd9aeedb3c876.zip
tidy ebuild and add patch for gcc-34 to the gcc-3 patch (bug #76094)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/chromium/ChangeLog6
-rw-r--r--games-action/chromium/Manifest10
-rw-r--r--games-action/chromium/chromium-0.9.12-r5.ebuild22
-rw-r--r--games-action/chromium/files/0.9.12-gcc3-gentoo.patch14
4 files changed, 30 insertions, 22 deletions
diff --git a/games-action/chromium/ChangeLog b/games-action/chromium/ChangeLog
index 0715bbf17cfa..915f1529fea3 100644
--- a/games-action/chromium/ChangeLog
+++ b/games-action/chromium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/chromium
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.11 2004/12/28 22:50:37 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.12 2004/12/30 04:45:22 mr_bones_ Exp $
+
+ 29 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ files/0.9.12-gcc3-gentoo.patch, chromium-0.9.12-r5.ebuild:
+ tidy ebuild and add patch for gcc-34 to the gcc-3 patch (bug #76094)
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/games-action/chromium/Manifest b/games-action/chromium/Manifest
index eee5ae917511..b172573ed3d0 100644
--- a/games-action/chromium/Manifest
+++ b/games-action/chromium/Manifest
@@ -1,7 +1,7 @@
-MD5 d6b41c9002198fe7c6cfa9ee9388475a ChangeLog 2986
-MD5 32acc44693c591b62fabb5deaf6a2cf5 chromium-0.9.12-r5.ebuild 2241
+MD5 08e824e08a89d8b7ff3c882be572889d ChangeLog 3176
+MD5 61c5ae1e23ce73bda832ccb9f19bd68e chromium-0.9.12-r5.ebuild 2198
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 e363d085caa6b62c91264e68a15b0459 files/0.9.12-proper-options.patch 1708
-MD5 031dc9787ccdcb049081dccf31a4a401 files/0.9.12-qt3.patch 979
-MD5 bfa95892a6761ef70d64b31a9fa4f9e2 files/0.9.12-gcc3-gentoo.patch 329
MD5 8efe8d996573ec81e5357e39c046cdd3 files/digest-chromium-0.9.12-r5 144
+MD5 031dc9787ccdcb049081dccf31a4a401 files/0.9.12-qt3.patch 979
+MD5 704ffc456916b1e4953b5292b78f64c2 files/0.9.12-gcc3-gentoo.patch 530
+MD5 e363d085caa6b62c91264e68a15b0459 files/0.9.12-proper-options.patch 1708
diff --git a/games-action/chromium/chromium-0.9.12-r5.ebuild b/games-action/chromium/chromium-0.9.12-r5.ebuild
index 171c74329988..d1c4c1f96981 100644
--- a/games-action/chromium/chromium-0.9.12-r5.ebuild
+++ b/games-action/chromium/chromium-0.9.12-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.8 2004/06/30 02:32:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.9 2004/12/30 04:45:22 mr_bones_ Exp $
inherit flag-o-matic eutils games
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ppc amd64 ~sparc"
IUSE="qt sdl oggvorbis"
-RDEPEND="virtual/libc
+DEPEND="virtual/libc
|| (
sdl? ( media-libs/libsdl
media-libs/smpeg )
@@ -24,17 +24,15 @@ RDEPEND="virtual/libc
qt? ( x11-libs/qt )
media-libs/openal
virtual/x11"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
S="${WORKDIR}/Chromium-0.9"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-gcc3-gentoo.patch
- epatch ${FILESDIR}/${PV}-proper-options.patch
- has_version '=x11-libs/qt-3*' && epatch ${FILESDIR}/${PV}-qt3.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gcc3-gentoo.patch"
+ epatch "${FILESDIR}/${PV}-proper-options.patch"
+ has_version '=x11-libs/qt-3*' && epatch "${FILESDIR}/${PV}-qt3.patch"
append-flags -DPKGDATADIR="'\"${GAMES_DATADIR}/${PN}\"'"
append-flags -DPKGBINDIR="'\"${GAMES_BINDIR}\"'"
sed -i \
@@ -46,6 +44,7 @@ src_unpack() {
sed -i \
-e "s:-O2:${CFLAGS}:" support/glpng/src/Makefile \
|| die "sed support/glpng/src/Makefile failed"
+ find "${S}" -type d -name CVS -exec rm -rf '{}' \; >& /dev/null
}
src_compile() {
@@ -72,13 +71,8 @@ src_compile() {
}
src_install() {
- exeinto "${GAMES_BINDIR}"
- doexe bin/chromium* || die "doexe failed"
-
+ dogamesbin bin/chromium* || die "dogamesbin failed"
dodir "${GAMES_DATADIR}/${PN}"
cp -r data "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
-
- find "${D}" -name CVS -exec rm -rf '{}' \; >& /dev/null
-
prepgamesdirs
}
diff --git a/games-action/chromium/files/0.9.12-gcc3-gentoo.patch b/games-action/chromium/files/0.9.12-gcc3-gentoo.patch
index 3e3e41095983..8eaa91518e86 100644
--- a/games-action/chromium/files/0.9.12-gcc3-gentoo.patch
+++ b/games-action/chromium/files/0.9.12-gcc3-gentoo.patch
@@ -1,6 +1,6 @@
diff -ur Chromium-0.9/src/NCString.cpp Chromium-0.9.m/src/NCString.cpp
---- Chromium-0.9/src/NCString.cpp 2001-05-20 12:04:58.000000000 -0500
-+++ Chromium-0.9.m/src/NCString.cpp 2002-07-25 22:57:03.000000000 -0500
+--- src/NCString.cpp 2001-05-20 12:04:58.000000000 -0500
++++ src/NCString.cpp 2002-07-25 22:57:03.000000000 -0500
@@ -5,6 +5,7 @@
#include <stdlib.h>
#include <string.h>
@@ -9,3 +9,13 @@ diff -ur Chromium-0.9/src/NCString.cpp Chromium-0.9.m/src/NCString.cpp
/**
* ctor
+--- src/MainGLUT.cpp.~1.6.~ 2001-05-21 03:36:55.000000000 +0200
++++ src/MainGLUT.cpp 2004-12-30 01:22:00.734250944 +0100
+@@ -11,6 +11,7 @@
+
+ #include <stdio.h>
+ #include <unistd.h>
++#include <stdlib.h>
+
+ #include <GL/glut.h>
+