summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-11-12 16:11:19 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-11-12 16:11:19 +0000
commit2b55da6e224770f9d92f8ea19d939b4d47361b4f (patch)
tree8a4348b57afff600e7a71d97ac541e9bb48b2fa8 /games-action
parentAdded libsmpeg compiled against older glibc for descent3 compatibility on amd64. (diff)
downloadhistorical-2b55da6e224770f9d92f8ea19d939b4d47361b4f.tar.gz
historical-2b55da6e224770f9d92f8ea19d939b4d47361b4f.tar.bz2
historical-2b55da6e224770f9d92f8ea19d939b4d47361b4f.zip
Added initial support for amd64.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'games-action')
-rw-r--r--games-action/descent3/ChangeLog8
-rw-r--r--games-action/descent3/Manifest4
-rw-r--r--games-action/descent3/descent3-1.4.0b-r1.ebuild110
-rw-r--r--games-action/descent3/files/digest-descent3-1.4.0b-r12
4 files changed, 122 insertions, 2 deletions
diff --git a/games-action/descent3/ChangeLog b/games-action/descent3/ChangeLog
index 999d0b5dacc8..5f6730f73921 100644
--- a/games-action/descent3/ChangeLog
+++ b/games-action/descent3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/descent3
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/ChangeLog,v 1.13 2005/10/21 17:25:18 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/ChangeLog,v 1.14 2005/11/12 16:11:19 wolf31o2 Exp $
+
+*descent3-1.4.0b-r1 (12 Nov 2005)
+
+ 12 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +descent3-1.4.0b-r1.ebuild:
+ Added initial support for amd64.
21 Oct 2005; Chris Gianelloni <wolf31o2@gentoo.org>
descent3-1.4.0b.ebuild:
diff --git a/games-action/descent3/Manifest b/games-action/descent3/Manifest
index b4f79bbad792..37f257efd645 100644
--- a/games-action/descent3/Manifest
+++ b/games-action/descent3/Manifest
@@ -1,4 +1,6 @@
-MD5 789612bd02c2dd596b15ac3fd4b8927e ChangeLog 1684
+MD5 a09f67e4405da2921e9d12370bbfefc4 ChangeLog 1839
+MD5 c83b489fb811ad2921a0a1158cc18cb0 descent3-1.4.0b-r1.ebuild 2953
MD5 c0ec0851c41675a54fa1cec21db8ed43 descent3-1.4.0b.ebuild 2558
MD5 d2af265a871305bb7fa493725388a58d files/digest-descent3-1.4.0b 138
+MD5 d2af265a871305bb7fa493725388a58d files/digest-descent3-1.4.0b-r1 138
MD5 e43b9b7575f9c659feedda43ab915f01 metadata.xml 630
diff --git a/games-action/descent3/descent3-1.4.0b-r1.ebuild b/games-action/descent3/descent3-1.4.0b-r1.ebuild
new file mode 100644
index 000000000000..34acc36c797a
--- /dev/null
+++ b/games-action/descent3/descent3-1.4.0b-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/descent3-1.4.0b-r1.ebuild,v 1.1 2005/11/12 16:11:19 wolf31o2 Exp $
+
+inherit eutils games
+
+IUSE="nocd videos"
+DESCRIPTION="Descent 3 - 3-Dimensional indoor/outdoor spaceship combat"
+HOMEPAGE="http://www.lokigames.com/products/descent3/"
+SRC_URI="mirror://lokigames/${PN}/${PN}-1.4.0a-x86.run
+ mirror://lokigames/${PN}/${P}-x86.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+RESTRICT="nostrip"
+
+DEPEND=""
+RDEPEND="virtual/opengl
+ virtual/x11
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-compat
+ app-emulation/emul-linux-x86-sdl
+ >=sys-libs/lib-compat-loki-0.2 )"
+
+GAMES_CHECK_LICENSE="yes"
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ if use videos ; then
+ ewarn "The installed game takes about 1.2GB of space!"
+ cdrom_get_cds missions/d3.mn3 movies/level1.mve
+ else
+ cdrom_get_cds missions/d3.mn3
+ fi
+ if use nocd ; then
+ ewarn "The installed game takes about 510MB of space!"
+ else
+ ewarn "The installed game takes about 220MB of space!"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ mkdir -p ${S}/{a,b}
+ cd ${S}/a
+ unpack_makeself ${PN}-1.4.0a-x86.run
+ cd ${S}/b
+ unpack_makeself ${P}-x86.run
+}
+
+src_install() {
+ dodir ${dir}
+ einfo "Copying files... this may take a while..."
+ exeinto ${dir}
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{${PN},nettest} \
+ || die "copying executables"
+ insinto ${dir}
+ doins ${CDROM_ROOT}/{FAQ.txt,README{,.mercenary},d3.hog,icon.{bmp,xpm}} \
+ || die "copying files"
+
+ cd ${Ddir}
+ tar xzf ${CDROM_ROOT}/data.tar.gz || die "uncompressing data"
+ tar xzf ${CDROM_ROOT}/shared.tar.gz || die "uncompressing shared"
+
+ if use nocd; then
+ doins -r ${CDROM_ROOT}/missions || die "copying missions"
+ fi
+
+ if use videos ; then
+ cdrom_load_next_cd
+ doins -r ${CDROM_ROOT}/movies || die "copying movies"
+ fi
+
+ cd ${S}/a
+ bin/Linux/x86/loki_patch --verify patch.dat
+ bin/Linux/x86/loki_patch patch.dat ${Ddir} >& /dev/null || die "patching a"
+ cd ${S}/b
+ bin/Linux/x86/loki_patch --verify patch.dat
+ bin/Linux/x86/loki_patch patch.dat ${Ddir} >& /dev/null || die "patching b"
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find ${Ddir} -exec touch '{}' \
+
+ if use amd64
+ then
+ dosym /usr/$(get_libdir)/loki_libsmpeg-0.4.so.0 \
+ ${dir}/libsmpeg-0.4.so.0 || die "failed compatibility symlink"
+ fi
+
+ games_make_wrapper descent3 ./descent3.dynamic "${dir}" "${dir}"
+ newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
+
+ # Fix for 2.6 kernel crash
+ cd ${Ddir}
+ ln -sf ppics.hog PPics.Hog
+
+ prepgamesdirs
+ make_desktop_entry ${PN} "Descent 3" ${PN}
+}
+
+pkg_postinst() {
+ einfo "To play the game run:"
+ einfo " descent3"
+
+ games_pkg_postinst
+}
diff --git a/games-action/descent3/files/digest-descent3-1.4.0b-r1 b/games-action/descent3/files/digest-descent3-1.4.0b-r1
new file mode 100644
index 000000000000..c805eef5873e
--- /dev/null
+++ b/games-action/descent3/files/digest-descent3-1.4.0b-r1
@@ -0,0 +1,2 @@
+MD5 252e242e57e15a9afab7d6fd69f562ae descent3-1.4.0a-x86.run 2736956
+MD5 4cfd46f594fa40b2afd575842a197ba1 descent3-1.4.0b-x86.run 4504631