summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-01-26 01:04:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-01-26 01:04:43 +0000
commit458fae50aa4105aca1fe1354040ea36a87840527 (patch)
treedb531d561b37ec976afb8f925952667bc2018c70 /games-action
parentfixed src_uri as per bug #79510. still working on library issues (diff)
downloadhistorical-458fae50aa4105aca1fe1354040ea36a87840527.tar.gz
historical-458fae50aa4105aca1fe1354040ea36a87840527.tar.bz2
historical-458fae50aa4105aca1fe1354040ea36a87840527.zip
patch to fix mouse drifting (bug #79441) - reported by Yasha Davidov
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'games-action')
-rw-r--r--games-action/trackballs/ChangeLog10
-rw-r--r--games-action/trackballs/Manifest7
-rw-r--r--games-action/trackballs/files/1.0.0-drift.patch10
-rw-r--r--games-action/trackballs/files/digest-trackballs-1.0.0-r12
-rw-r--r--games-action/trackballs/trackballs-1.0.0-r1.ebuild52
-rw-r--r--games-action/trackballs/trackballs-1.0.0.ebuild4
6 files changed, 79 insertions, 6 deletions
diff --git a/games-action/trackballs/ChangeLog b/games-action/trackballs/ChangeLog
index 3545fb0a4435..7acd556d522e 100644
--- a/games-action/trackballs/ChangeLog
+++ b/games-action/trackballs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/trackballs
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/ChangeLog,v 1.9 2004/08/08 11:49:16 mr_bones_ Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/ChangeLog,v 1.10 2005/01/26 01:04:42 mr_bones_ Exp $
+
+*trackballs-1.0.0-r1 (25 Jan 2005)
+
+ 25 Jan 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/1.0.0-drift.patch, +trackballs-1.0.0-r1.ebuild:
+ patch to fix mouse drifting (bug #79441) - reported by Yasha Davidov
08 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org>
-files/0.9.2-destdir-icons.patch, -files/0.9.2-sparkle.patch,
diff --git a/games-action/trackballs/Manifest b/games-action/trackballs/Manifest
index 87b7e9f2f9cc..e1622afc371b 100644
--- a/games-action/trackballs/Manifest
+++ b/games-action/trackballs/Manifest
@@ -1,4 +1,7 @@
-MD5 d1b8101775a36ff60543619e4d240780 ChangeLog 1322
-MD5 70d016505f686a540fd5989bf1b15b61 trackballs-1.0.0.ebuild 1384
+MD5 5aefac9c711207699951c4204bc574cb ChangeLog 1543
+MD5 9cfa09e390f503c2ae85de208d9f90f6 trackballs-1.0.0.ebuild 1384
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 7aae95c8910fc9f9997b3a539f6b3e2e trackballs-1.0.0-r1.ebuild 1388
MD5 0b573a1444721dee7dc128fb20c380e4 files/digest-trackballs-1.0.0 142
+MD5 9ec7bc9f5765e2ae6726f9ccb75d9443 files/1.0.0-drift.patch 292
+MD5 0b573a1444721dee7dc128fb20c380e4 files/digest-trackballs-1.0.0-r1 142
diff --git a/games-action/trackballs/files/1.0.0-drift.patch b/games-action/trackballs/files/1.0.0-drift.patch
new file mode 100644
index 000000000000..d22d208e6937
--- /dev/null
+++ b/games-action/trackballs/files/1.0.0-drift.patch
@@ -0,0 +1,10 @@
+--- src/player.cc.orig 2005-01-25 19:15:11.000000000 -0500
++++ src/player.cc 2005-01-25 19:15:26.000000000 -0500
+@@ -68,6 +68,7 @@
+
+ if(!Game::current) return;
+ if(!playing) return;
++ dx = dy = 0.0;
+ Map *map = Game::current->map;
+ health+=t * 0.4; if(health > 1.0) health = 1.0;
+
diff --git a/games-action/trackballs/files/digest-trackballs-1.0.0-r1 b/games-action/trackballs/files/digest-trackballs-1.0.0-r1
new file mode 100644
index 000000000000..b4f4ba351319
--- /dev/null
+++ b/games-action/trackballs/files/digest-trackballs-1.0.0-r1
@@ -0,0 +1,2 @@
+MD5 0d3ce4903aa60fba18c0e8c02b3cd563 trackballs-1.0.0.tar.gz 4826294
+MD5 e58d1c7d046f4010a2b3c92383522459 trackballs-music-0.9.0.tbz2 7693212
diff --git a/games-action/trackballs/trackballs-1.0.0-r1.ebuild b/games-action/trackballs/trackballs-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..2966a647e541
--- /dev/null
+++ b/games-action/trackballs/trackballs-1.0.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/trackballs-1.0.0-r1.ebuild,v 1.1 2005/01/26 01:04:42 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="simple game similar to the classical game Marble Madness"
+HOMEPAGE="http://trackballs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${PN}-music-0.9.0.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ >=dev-util/guile-1.6*
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/icons//' share/Makefile.in \
+ || die "sed share/Makefile.in failed"
+ epatch "${FILESDIR}/${PV}-drift.patch"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-highscores=${GAMES_STATEDIR}/${PN}-highscores \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ insinto /usr/share/pixmaps
+ doins share/icons/*png || die "doins failed"
+ make_desktop_entry trackballs "Trackballs" trackballs-48x48.png
+ insinto "${GAMES_DATADIR}/${PN}/music"
+ doins "${WORKDIR}"/tb_*.ogg || die "doins failed"
+ dodoc AUTHORS ChangeLog README* NEWS
+ prepgamesdirs
+}
diff --git a/games-action/trackballs/trackballs-1.0.0.ebuild b/games-action/trackballs/trackballs-1.0.0.ebuild
index 702194566604..73b2c6fda30c 100644
--- a/games-action/trackballs/trackballs-1.0.0.ebuild
+++ b/games-action/trackballs/trackballs-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/trackballs-1.0.0.ebuild,v 1.5 2004/08/08 11:49:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/trackballs-1.0.0.ebuild,v 1.6 2005/01/26 01:04:42 mr_bones_ Exp $
inherit eutils games