summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-02 20:07:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-02 20:07:27 +0000
commite55c204c5fd691901e34243671a42bdf767ccf57 (patch)
tree4d4191bfeb59b83e30e01add76d5c3f36a793de6 /games-action
parentswitched to newinitd (diff)
downloadhistorical-e55c204c5fd691901e34243671a42bdf767ccf57.tar.gz
historical-e55c204c5fd691901e34243671a42bdf767ccf57.tar.bz2
historical-e55c204c5fd691901e34243671a42bdf767ccf57.zip
tidy
Package-Manager: portage-2.0.53
Diffstat (limited to 'games-action')
-rw-r--r--games-action/parsec/Manifest12
-rw-r--r--games-action/parsec/parsec-0197.ebuild16
2 files changed, 11 insertions, 17 deletions
diff --git a/games-action/parsec/Manifest b/games-action/parsec/Manifest
index 0fd57ff98a30..3a2952f70c9e 100644
--- a/games-action/parsec/Manifest
+++ b/games-action/parsec/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 afff99d473c9fb53c554401cb939dbf1 ChangeLog 866
MD5 b1474fdd4dba91a127dd4edee3137e96 files/digest-parsec-0197 74
MD5 dbf54802fadb1edabd6f18885c2fb502 files/parsec 45
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 f8cb9fa115168cceb227cc77fc291da9 parsec-0197.ebuild 1052
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDuXY8wUpWvClEHQoRAnCGAJ4tdAA8eRJsi/dSA85Xp2XlYNVWwgCggLce
-VryFEaTkOoEOBH7pu8HyJi8=
-=FjpY
------END PGP SIGNATURE-----
+MD5 26f138f9eb7a63e4dcab9dcfef95eb81 parsec-0197.ebuild 1134
diff --git a/games-action/parsec/parsec-0197.ebuild b/games-action/parsec/parsec-0197.ebuild
index f71f88fab388..03e759bcd6f1 100644
--- a/games-action/parsec/parsec-0197.ebuild
+++ b/games-action/parsec/parsec-0197.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/parsec-0197.ebuild,v 1.7 2006/01/02 18:52:14 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/parsec/parsec-0197.ebuild,v 1.8 2006/01/02 20:07:27 mr_bones_ Exp $
-inherit eutils games
+inherit games
DESCRIPTION="Parsec - there is no safe distance"
HOMEPAGE="http://openparsec.sourceforge.net/"
@@ -29,9 +29,13 @@ S=${WORKDIR}/${PN}
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN}
- dodir ${dir}
- cp -r * ${D}/${dir}/
- dogamesbin ${FILESDIR}/parsec
- dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/parsec
+
+ dogamesbin "${FILESDIR}/parsec" || die "dogamesbin failed"
+ insinto "${dir}"
+ doins -r * || die "doins failed"
+ sed -i \
+ -e "s:GENTOO_DIR:${dir}:" \
+ "${D}${GAMES_BINDIR}/parsec" \
+ || die "sed failed"
prepgamesdirs
}