summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-02-13 15:59:20 +0000
committerDavid Holm <dholm@gentoo.org>2004-02-13 15:59:20 +0000
commitad97d68ac61cc0ed7dd3c36ccbb7ded2227bfa69 (patch)
tree4b166da3a657748d59471aa90eab56e5fcb48c68 /games-emulation/pcsx
parentAdded to ~ppc (diff)
downloadhistorical-ad97d68ac61cc0ed7dd3c36ccbb7ded2227bfa69.tar.gz
historical-ad97d68ac61cc0ed7dd3c36ccbb7ded2227bfa69.tar.bz2
historical-ad97d68ac61cc0ed7dd3c36ccbb7ded2227bfa69.zip
Fixed compilation on ppc and added to ~ppc
Diffstat (limited to 'games-emulation/pcsx')
-rw-r--r--games-emulation/pcsx/ChangeLog7
-rw-r--r--games-emulation/pcsx/pcsx-1.5-r1.ebuild16
2 files changed, 17 insertions, 6 deletions
diff --git a/games-emulation/pcsx/ChangeLog b/games-emulation/pcsx/ChangeLog
index 126b72aa3857..6b9b0a908f7b 100644
--- a/games-emulation/pcsx/ChangeLog
+++ b/games-emulation/pcsx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/pcsx
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/ChangeLog,v 1.2 2003/09/10 15:58:19 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/ChangeLog,v 1.3 2004/02/13 15:59:20 dholm Exp $
+
+ 13 Feb 2004; David Holm <dholm@gentoo.org> pcsx-1.5-r1.ebuild:
+ Made some ppc-specific modifications and added to ~ppc.
*pcsx-1.5-r1 (14 Aug 2003)
diff --git a/games-emulation/pcsx/pcsx-1.5-r1.ebuild b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
index cc8b253a8c8f..5893a4b9401e 100644
--- a/games-emulation/pcsx/pcsx-1.5-r1.ebuild
+++ b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.2 2003/09/09 23:33:23 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.3 2004/02/13 15:59:20 dholm Exp $
inherit games eutils
@@ -11,7 +11,7 @@ SRC_URI="http://www.pcsx.net/downloads/PcsxSrc-${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~ppc"
IUSE="opengl"
DEPEND="sys-libs/zlib
@@ -25,7 +25,7 @@ RDEPEND="games-emulation/psemu-cdr
games-emulation/psemu-padjoy
games-emulation/psemu-peopsspu
|| (
- opengl? ( games-emulation/psemu-gpupetemesagl )
+ opengl? ( x86? games-emulation/psemu-gpupetemesagl )
games-emulation/psemu-peopssoftgpu
)"
@@ -42,6 +42,14 @@ src_unpack() {
-e 's:Pcsx.cfg:~/.pcsx/config:' \
Linux/LnxMain.c \
|| die "sed LnxMain.c failed"
+ if [ "${ARCH}" = "ppc" ]; then
+ sed -i \
+ -e "s:^CPU\ =.*:CPU = powerpc:" Linux/Makefile \
+ || die "sed Linux/Makefile failed"
+ sed -i \
+ -e "s:__LINUX__:__i386__:g" Gte.c \
+ || die "sed Gte.c failed"
+ fi
}
src_compile() {