summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-21 02:22:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-21 02:22:49 +0000
commit50f1e0b79270ce30da87d008dded02cabb6946c0 (patch)
tree4b72c0f8e496f5227c663b218878e0c51d64bdd6 /games-emulation/raine
parentcreate user home in $ROOT rather than $D (diff)
downloadhistorical-50f1e0b79270ce30da87d008dded02cabb6946c0.tar.gz
historical-50f1e0b79270ce30da87d008dded02cabb6946c0.tar.bz2
historical-50f1e0b79270ce30da87d008dded02cabb6946c0.zip
version bump
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-emulation/raine')
-rw-r--r--games-emulation/raine/ChangeLog7
-rw-r--r--games-emulation/raine/Manifest4
-rw-r--r--games-emulation/raine/files/digest-raine-0.42.43
-rw-r--r--games-emulation/raine/raine-0.42.4.ebuild57
4 files changed, 69 insertions, 2 deletions
diff --git a/games-emulation/raine/ChangeLog b/games-emulation/raine/ChangeLog
index 32ae7d38308c..48353a67a83e 100644
--- a/games-emulation/raine/ChangeLog
+++ b/games-emulation/raine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/raine
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.10 2005/06/03 18:37:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.11 2005/07/21 02:22:49 mr_bones_ Exp $
+
+*raine-0.42.4 (21 Jul 2005)
+
+ 21 Jul 2005; Michael Sterrett <mr_bones_@gentoo.org> +raine-0.42.4.ebuild:
+ version bump
*raine-0.42.2 (03 Jun 2005)
diff --git a/games-emulation/raine/Manifest b/games-emulation/raine/Manifest
index a6b7296243ff..ae9ebe8756bf 100644
--- a/games-emulation/raine/Manifest
+++ b/games-emulation/raine/Manifest
@@ -2,9 +2,11 @@ MD5 e00dc4152bf3eaf9c65b96c4e4528f4f raine-0.39.0.ebuild 1378
MD5 79090f34510bb7b70d699d6099db82d3 raine-0.42.2.ebuild 1322
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 1e9fe616d50e52330a12c00c5bedf083 raine-0.42.0.ebuild 1430
-MD5 f4ecac5361fc4613cd4281eaf2fcf17d ChangeLog 1195
+MD5 32a83394cc33f3edf6517a4e5700b86f raine-0.42.4.ebuild 1308
+MD5 6b64a9f990daba1287d0abd38b7a02b5 ChangeLog 1317
MD5 c4660e529000ed1406f1e98358b1b404 files/raine-allegro_4.1.5_fix.patch 569
MD5 67647762ce31a7c21a2a040536f02b29 files/Raine.desktop 236
+MD5 7671c01ba2551dbd18921891d2dad17d files/digest-raine-0.42.4 176
MD5 3c14ba60b08d74df2dc3ac5978293afb files/digest-raine-0.42.0 176
MD5 8dc30ffdc0cf404a06ef6a0ae8fe1722 files/digest-raine-0.39.0 176
MD5 8d4ab85d4d8d35dbea18f19747cbc557 files/digest-raine-0.42.2 176
diff --git a/games-emulation/raine/files/digest-raine-0.42.4 b/games-emulation/raine/files/digest-raine-0.42.4
new file mode 100644
index 000000000000..832ac54bb523
--- /dev/null
+++ b/games-emulation/raine/files/digest-raine-0.42.4
@@ -0,0 +1,3 @@
+MD5 aaf5ce524e6edc968ca5a6b0282b3df2 raines-0.42.4.tar.bz2 1688667
+MD5 cec6e5ba7beeb2ece310c66fd55c7b4d rainedocs.zip 88671
+MD5 3529c30187861c37af8e1ce544746b1e icons.zip 3641
diff --git a/games-emulation/raine/raine-0.42.4.ebuild b/games-emulation/raine/raine-0.42.4.ebuild
new file mode 100644
index 000000000000..93183a664c88
--- /dev/null
+++ b/games-emulation/raine/raine-0.42.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.42.4.ebuild,v 1.1 2005/07/21 02:22:49 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="R A I N E M680x0 Arcade Emulation"
+HOMEPAGE="http://www.rainemu.com/"
+SRC_URI="http://www.rainemu.com/html/archive/raines-${PV}.tar.bz2
+ http://www.rainemu.com/html/archive/rainedocs.zip
+ http://www.rainemu.com/html/archive/icons.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static kde"
+
+RDEPEND="media-libs/allegro
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo > detect-cpu
+ echo > cpuinfo
+ sed -i \
+ -e "/bindir/s:/usr/games:${GAMES_BINDIR}:" \
+ makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myopts=
+ use static \
+ && myopts="${myopts} STATIC=1" \
+ || myopts="${myopts} STATIC="
+ emake \
+ _MARCH="${CFLAGS}" \
+ OSTYPE=linux \
+ ${myopts} || die "emake failed"
+}
+
+src_install() {
+ make prefix="${D}" install || die "make install failed"
+ keepdir "${GAMES_DATADIR}/${PN}/roms"
+ dodoc "${WORKDIR}/raine.txt"
+
+ insinto /usr/share/icons
+ doins "${WORKDIR}/"*.png
+ if use kde ; then
+ insinto /usr/share/applnk/Games
+ doins "${FILESDIR}/Raine.desktop"
+ fi
+ prepgamesdirs
+}