summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-11 01:24:37 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-11 01:24:37 +0000
commit10f8bdea59444b23c4a06b8fc0add8edec23212e (patch)
tree6ecfd65a744545ef0a3ac94dbd76ed22dcb4f38b /games-emulation/xmess
parentUpstream needs to learn the definition of consistency -- use_enable and use_w... (diff)
downloadhistorical-10f8bdea59444b23c4a06b8fc0add8edec23212e.tar.gz
historical-10f8bdea59444b23c4a06b8fc0add8edec23212e.tar.bz2
historical-10f8bdea59444b23c4a06b8fc0add8edec23212e.zip
icc/net fix #37845
Diffstat (limited to 'games-emulation/xmess')
-rw-r--r--games-emulation/xmess/xmess-0.77.1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/games-emulation/xmess/xmess-0.77.1.ebuild b/games-emulation/xmess/xmess-0.77.1.ebuild
index 4e4bbc41d3fe..8a8b7e09d374 100644
--- a/games-emulation/xmess/xmess-0.77.1.ebuild
+++ b/games-emulation/xmess/xmess-0.77.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.77.1.ebuild,v 1.4 2004/01/01 23:41:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.77.1.ebuild,v 1.5 2004/01/11 01:24:37 vapier Exp $
inherit games flag-o-matic gcc eutils
@@ -69,16 +69,21 @@ src_unpack() {
;;
esac
- if [ `use icc` ] ; then
- epatch ${FILESDIR}/${PV}-icc.patch
- sed -i \
- -e '/^CC/s:gcc:icc:' Makefile \
- || die "sed Makefile (icc) failed"
- fi
if [ `use net` ] ; then
sed -i \
-e '/XMAME_NET/s:#::' Makefile \
|| die "sed Makefile (net) failed"
+ if [ `use icc` ] ; then
+ ewarn "Sorry, but net support is not compatible with icc."
+ ewarn "icc support has been ignored in favor of net support."
+ fi
+ else
+ if [ `use icc` ] ; then
+ epatch ${FILESDIR}/${PV}-icc.patch
+ sed -i \
+ -e '/^CC/s:gcc:icc:' Makefile \
+ || die "sed Makefile (icc) failed"
+ fi
fi
if [ `use esd` ] ; then
sed -i \