summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-01 02:30:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-01 02:30:10 +0000
commitaf2a0fd0edcd7e524a918418f8937e85a8f22a09 (patch)
tree056b95fd9b034632960bb26131e11dd4c95ed525 /games-emulation
parentstable on ppc64, bug #61764 (diff)
downloadhistorical-af2a0fd0edcd7e524a918418f8937e85a8f22a09.tar.gz
historical-af2a0fd0edcd7e524a918418f8937e85a8f22a09.tar.bz2
historical-af2a0fd0edcd7e524a918418f8937e85a8f22a09.zip
version bump
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest14
-rw-r--r--games-emulation/advancemame/advancemame-0.86.0.ebuild78
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.86.01
4 files changed, 89 insertions, 12 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 49eb54b378a2..d96ea6b51ed3 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.17 2004/08/25 05:38:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.18 2004/09/01 02:30:10 mr_bones_ Exp $
+
+*advancemame-0.86.0 (31 Aug 2004)
+
+ 31 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +advancemame-0.86.0.ebuild:
+ version bump
*advancemame-0.85.0 (24 Aug 2004)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index cfcd05d941d4..2da0f8f6675b 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 0bf79059dff66d2da024588c422a2e1c ChangeLog 3485
+MD5 04e2cd1194a80c495f69610b10b96feb ChangeLog 3621
+MD5 c7a56ad2d4cb791e613869debc9e18df advancemame-0.86.0.ebuild 1823
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
MD5 a67ea9d0aba6813bf7099ba0533ba44d advancemame-0.85.0.ebuild 1820
+MD5 cfcb101ca859965c03e4c39303d3c481 files/digest-advancemame-0.86.0 72
MD5 0fcd53e6dc55e784545e640310890175 files/digest-advancemame-0.85.0 72
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBMoTDHTu7gpaalycRAgZEAJ0RMiEir+70b7ZQrgF4WjwFRGX4sgCgvrfn
-zdBBYZCf60Afh4r04JE3kYY=
-=ZWJU
------END PGP SIGNATURE-----
diff --git a/games-emulation/advancemame/advancemame-0.86.0.ebuild b/games-emulation/advancemame/advancemame-0.86.0.ebuild
new file mode 100644
index 000000000000..9524b510d896
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.86.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.86.0.ebuild,v 1.1 2004/09/01 02:30:10 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="x86 ppc ~amd64"
+IUSE="static svga truetype fbcon alsa oss slang sdl"
+
+RDEPEND="virtual/libc
+ app-arch/unzip
+ app-arch/zip
+ x86? ( >=dev-lang/nasm-0.98 )
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable truetype freetype) \
+ $(use_enable static) \
+ $(use_enable x86 asm) \
+ $(use_enable svga svgalib) \
+ $(use_enable fbcon fb) \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable slang) \
+ $(use_enable sdl) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd obj/doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.86.0 b/games-emulation/advancemame/files/digest-advancemame-0.86.0
new file mode 100644
index 000000000000..ef56d3ea3c76
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.86.0
@@ -0,0 +1 @@
+MD5 9c52ee3bdb67bd0b161a2b697d8d1f01 advancemame-0.86.0.tar.gz 12989240