summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2008-09-06 15:39:16 +0000
committerTristan Heaven <tristan@gentoo.org>2008-09-06 15:39:16 +0000
commitc072fef6cc4ef7f31da728fbd1105b55ce089c1c (patch)
treebfe147b55ae148d9fad35c922e774d16ad7f2f3d /games-fps
parentInitial commit, bug #198078 (diff)
downloadhistorical-c072fef6cc4ef7f31da728fbd1105b55ce089c1c.tar.gz
historical-c072fef6cc4ef7f31da728fbd1105b55ce089c1c.tar.bz2
historical-c072fef6cc4ef7f31da728fbd1105b55ce089c1c.zip
Initial commit, bug #196452
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.3 x86_64
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/etqw-bin/ChangeLog10
-rw-r--r--games-fps/etqw-bin/etqw-bin-1.5.ebuild75
-rw-r--r--games-fps/etqw-bin/metadata.xml9
3 files changed, 94 insertions, 0 deletions
diff --git a/games-fps/etqw-bin/ChangeLog b/games-fps/etqw-bin/ChangeLog
new file mode 100644
index 000000000000..e218e46855e3
--- /dev/null
+++ b/games-fps/etqw-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/etqw-bin
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/etqw-bin/ChangeLog,v 1.1 2008/09/06 15:39:16 nyhm Exp $
+
+*etqw-bin-1.5 (06 Sep 2008)
+
+ 06 Sep 2008; Tristan Heaven <nyhm@gentoo.org> +metadata.xml,
+ +etqw-bin-1.5.ebuild:
+ Initial commit, bug #196452
+
diff --git a/games-fps/etqw-bin/etqw-bin-1.5.ebuild b/games-fps/etqw-bin/etqw-bin-1.5.ebuild
new file mode 100644
index 000000000000..9e489a4f868b
--- /dev/null
+++ b/games-fps/etqw-bin/etqw-bin-1.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/etqw-bin/etqw-bin-1.5.ebuild,v 1.1 2008/09/06 15:39:16 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="Enemy Territory: Quake Wars"
+HOMEPAGE="http://zerowing.idsoftware.com/linux/etqw/"
+SRC_URI="ETQW-client-${PV}-full.x86.run"
+
+LICENSE="ETQW"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cdinstall"
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ virtual/opengl
+ amd64? ( app-emulation/emul-linux-x86-sdl )
+ x86? (
+ media-libs/libsdl
+ media-libs/alsa-lib
+ )
+ cdinstall? ( games-fps/etqw-data )"
+
+S=${WORKDIR}/data
+dir=${GAMES_PREFIX_OPT}/etqw
+
+QA_TEXTRELS="${dir:1}/pb/*.so"
+QA_EXECSTACK="${dir:1}/*.x86
+ ${dir:1}/*.so*"
+
+GAMES_CHECK_LICENSE="yes"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from"
+ einfo "${HOMEPAGE} (requires a BitTorrent client)"
+ einfo "and copy it to ${DISTDIR}"
+}
+
+src_unpack() {
+ tail -c +194885 "${DISTDIR}"/${A} > ${A}.zip
+ unpack ./${A}.zip
+ rm -f ${A}.zip
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r base pb *.png *.txt || die "doins failed"
+
+ exeinto "${dir}"
+ doexe etqw{,-rthread}.x86 openurl.sh *.so* || die "doexe failed"
+
+ newicon etqw_icon.png etqw.png
+ games_make_wrapper etqw ./etqw.x86 "${dir}" "${dir}"
+ make_desktop_entry etqw "Enemy Territory: Quake Wars" etqw.png
+
+ games_make_wrapper etqw-rthread ./etqw-rthread.x86 "${dir}" "${dir}"
+ make_desktop_entry etqw-rthread "Enemy Territory: Quake Wars (SMP)" etqw.png
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall ; then
+ elog "You need to copy pak00*.pk4, zpak_*.pk4 and the megatextures"
+ elog "directory to ${dir}/base before running the game."
+ fi
+ elog "To change the game language from English, add"
+ elog "seta sys_lang \"your_language\" to your autoexec.cfg file."
+ elog "Menu fonts may not show up until you do so."
+}
diff --git a/games-fps/etqw-bin/metadata.xml b/games-fps/etqw-bin/metadata.xml
new file mode 100644
index 000000000000..2f55aed2d76d
--- /dev/null
+++ b/games-fps/etqw-bin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>nyhm@gentoo.org</email>
+ <name>Tristan Heaven</name>
+ </maintainer>
+</pkgmetadata>