summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-09 07:34:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-09 07:34:41 +0000
commit861569510eec958ca9379e0f0cbe8c3b00a82c0a (patch)
tree637137b047170f13cab4eaccd6f6b3ee5d69ab35 /games-roguelike
parentswitching over to using gnome.org eclass to clean up stale src_uri (diff)
downloadhistorical-861569510eec958ca9379e0f0cbe8c3b00a82c0a.tar.gz
historical-861569510eec958ca9379e0f0cbe8c3b00a82c0a.tar.bz2
historical-861569510eec958ca9379e0f0cbe8c3b00a82c0a.zip
version bump (bug #44102 includes detailed changelog)
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/angband/ChangeLog13
-rw-r--r--games-roguelike/angband/Manifest6
-rw-r--r--games-roguelike/angband/angband-3.0.4.ebuild55
-rw-r--r--games-roguelike/angband/files/digest-angband-3.0.41
4 files changed, 69 insertions, 6 deletions
diff --git a/games-roguelike/angband/ChangeLog b/games-roguelike/angband/ChangeLog
index 3d3740ea6b50..63821bb2a41c 100644
--- a/games-roguelike/angband/ChangeLog
+++ b/games-roguelike/angband/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for games-roguelike/angband
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/ChangeLog,v 1.2 2003/09/10 15:54:53 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/ChangeLog,v 1.3 2004/03/09 07:34:41 mr_bones_ Exp $
- 09 Jun 2003; <msterret@gentoo.org> angband-3.0.3.ebuild:
+*angband-3.0.4 (08 Mar 2004)
+
+ 08 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> angband-3.0.4.ebuild:
+ version bump (bug #44102 includes detailed changelog)
+
+ 09 Jun 2003; <mr_bones_@gentoo.org> angband-3.0.3.ebuild:
don't mangle myconf when USE=-X; removed DOCDIR (unused)
- 09 Jun 2003; <msterret@gentoo.org> angband-3.0.3.ebuild:
+ 09 Jun 2003; <mr_bones_@gentoo.org> angband-3.0.3.ebuild:
DEPEND on sed >= 4; check sed return value
*angband-3.0.3 (19 May 2003)
diff --git a/games-roguelike/angband/Manifest b/games-roguelike/angband/Manifest
index b528fea2afbd..45114d7652ab 100644
--- a/games-roguelike/angband/Manifest
+++ b/games-roguelike/angband/Manifest
@@ -1,4 +1,6 @@
-MD5 f5ebb0577b16352805aac188d8b4afdf ChangeLog 832
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 0aa76f0df1bb67a652429e5c17ee2539 ChangeLog 1001
+MD5 60d90115b884dc3f8a6272efde215577 angband-3.0.4.ebuild 1294
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 a99ee06558354eb31336625d22d8825a angband-3.0.3.ebuild 1105
MD5 166bf6a071476d096a14cc12f5c634f9 files/digest-angband-3.0.3 66
+MD5 ae920fa25b66efac2f0afe50fc92f2fb files/digest-angband-3.0.4 66
diff --git a/games-roguelike/angband/angband-3.0.4.ebuild b/games-roguelike/angband/angband-3.0.4.ebuild
new file mode 100644
index 000000000000..f3c0c703d3b7
--- /dev/null
+++ b/games-roguelike/angband/angband-3.0.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/angband/angband-3.0.4.ebuild,v 1.1 2004/03/09 07:34:41 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R.Tolkien"
+HOMEPAGE="http://thangorodrim.net/"
+SRC_URI="ftp://clockwork.dementia.org/${PN}/Source/${P}.tar.gz"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="X"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5
+ gtk? (
+ =x11-libs/gtk+-1.2*
+ dev-libs/glib
+ virtual/x11
+ )
+ X? ( virtual/x11 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:/games/:/:" configure \
+ || die "sed configure failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --bindir="${GAMES_BINDIR}" \
+ --with-setgid="${GAMES_GROUP}" \
+ `use_enable gtk` \
+ `use_with X x` \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS THANKS TODO changes.txt compile.txt readme.txt
+ find "${D}${GAMES_DATADIR}" -type f -exec chmod a-x \{\} \;
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ chmod -R g+w "${ROOT}"/usr/share/games/angband/lib/{apex,save,user}
+}
diff --git a/games-roguelike/angband/files/digest-angband-3.0.4 b/games-roguelike/angband/files/digest-angband-3.0.4
new file mode 100644
index 000000000000..43ee08d60817
--- /dev/null
+++ b/games-roguelike/angband/files/digest-angband-3.0.4
@@ -0,0 +1 @@
+MD5 e487da1c54dcbdcc96e0abd8c6d03906 angband-3.0.4.tar.gz 1551485