summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2008-07-17 21:10:03 +0000
committerRichard Freeman <rich0@gentoo.org>2008-07-17 21:10:03 +0000
commitd994bded313c8896d28c562d431807e12f49bc7c (patch)
tree24464bcd20a750f1100063f5036e3c0e0dcb84f0 /games-rpg/eternal-lands-data
parentia64/sparc/x86 stable (diff)
downloadhistorical-d994bded313c8896d28c562d431807e12f49bc7c.tar.gz
historical-d994bded313c8896d28c562d431807e12f49bc7c.tar.bz2
historical-d994bded313c8896d28c562d431807e12f49bc7c.zip
Rev bump to 1.7.0
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-rpg/eternal-lands-data')
-rw-r--r--games-rpg/eternal-lands-data/ChangeLog8
-rw-r--r--games-rpg/eternal-lands-data/eternal-lands-data-1.7.0.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/games-rpg/eternal-lands-data/ChangeLog b/games-rpg/eternal-lands-data/ChangeLog
index 2104bccbcb93..0a022e3556ca 100644
--- a/games-rpg/eternal-lands-data/ChangeLog
+++ b/games-rpg/eternal-lands-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/eternal-lands-data
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.16 2008/06/12 19:15:17 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/ChangeLog,v 1.17 2008/07/17 21:07:38 rich0 Exp $
+
+*eternal-lands-data-1.7.0 (17 Jul 2008)
+
+ 17 Jul 2008; Richard Freeman <rich0@gentoo.org>
+ +eternal-lands-data-1.7.0.ebuild:
+ Rev bump to 1.7.0
12 Jun 2008; Richard Freeman <rich0@gentoo.org>
eternal-lands-data-1.6.0.ebuild:
diff --git a/games-rpg/eternal-lands-data/eternal-lands-data-1.7.0.ebuild b/games-rpg/eternal-lands-data/eternal-lands-data-1.7.0.ebuild
new file mode 100644
index 000000000000..29f1056aa76f
--- /dev/null
+++ b/games-rpg/eternal-lands-data/eternal-lands-data-1.7.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands-data/eternal-lands-data-1.7.0.ebuild,v 1.1 2008/07/17 21:07:38 rich0 Exp $
+
+inherit games
+
+MUSIC_DATE="20060803"
+
+MY_PV="${PV//_/}"
+MY_PV="${MY_PV//./}"
+MY_PN="${PN%*-data}"
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="http://www.eternal-lands.com/el_linux_170_install.zip
+ music? ( mirror://gentoo/el_music_full-${MUSIC_DATE}.zip )
+ sound? ( mirror://gentoo/el_sound_150.zip )"
+# WARNING: The music file is held at
+# http://www.eternal-lands.com/page/music.php
+# We only mirror it so that it is versioned by the date we mirrored it
+# AND prefixed with el_ so as not cause any conflicts. Maybe oneday they will
+# version their music, maybe not.
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="music sound"
+
+DEPEND="app-arch/unzip"
+
+# Maybe one day upstream will do things in a consistent way.
+S="${WORKDIR}/el_install"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Move our music files to the correct directory
+ if use music ; then
+ mkdir music
+ mv ../*.ogg ../*.pll music || die
+ fi
+}
+
+src_install() {
+ # These are provided by eternal-lands ebuild
+
+ rm license.txt
+ rm commands.lst
+
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${MY_PN}"
+ doins -r 2dobjects 3dobjects actor_defs animations maps meshes \
+ particles skeletons textures tiles languages \
+ *.lst 3dobjects.txt *.xml \
+ || die "doins failed"
+
+ if use music ; then
+ doins -r music || die "doins music failed"
+ fi
+
+ # Removed sound from above - need to handle sound support
+
+ cd "${WORKDIR}"
+ if use sound ; then
+ doins -r sound || die "doins sound failed"
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${MY_PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${MY_PN}" -type d -exec chmod g+sx {} \;
+}