summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-31 07:07:17 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-31 07:07:17 +0000
commit99677b6a92335f10406d8c19bb5e03ebaa6f2477 (patch)
treedfa42f7666618f4208262df019a369f002ffa048 /games-sports/trigger
parentadded ~ppc64 (bug #100058) (diff)
downloadhistorical-99677b6a92335f10406d8c19bb5e03ebaa6f2477.tar.gz
historical-99677b6a92335f10406d8c19bb5e03ebaa6f2477.tar.bz2
historical-99677b6a92335f10406d8c19bb5e03ebaa6f2477.zip
update patch by Bernard Cafarelli to allow 1.1+ capabilities with 2.x providers
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-sports/trigger')
-rw-r--r--games-sports/trigger/Manifest8
-rw-r--r--games-sports/trigger/files/trigger-0.5.1c-glx-check.patch9
2 files changed, 12 insertions, 5 deletions
diff --git a/games-sports/trigger/Manifest b/games-sports/trigger/Manifest
index 13887c6486bf..e19b5a9bc6d3 100644
--- a/games-sports/trigger/Manifest
+++ b/games-sports/trigger/Manifest
@@ -5,11 +5,11 @@ MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 336c4b59fb55032317d71c5c05f80571 trigger-0.5.1c.ebuild 1389
MD5 22912a8b6736c76adf016c8d33c52bbe ChangeLog 1180
MD5 e39a2359502dafc730380be78246173f files/digest-trigger-0.5.1c 144
-MD5 eab1ac9bfb7efa553ebb42b648701078 files/trigger-0.5.1c-glx-check.patch 439
+MD5 fab012ed7b17d5eeb472e71a6c9c7c06 files/trigger-0.5.1c-glx-check.patch 590
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFC6xS9gIKl8Uu19MoRAkstAJoCLRBRfMlCotEUh540H16Fr0PR7QCfVACp
-bvCLo0TyuCuf3VmIwtGSk28=
-=TIyL
+iD8DBQFC7Hi9gIKl8Uu19MoRAjyuAJ4hpENqUnV0Xt+wIVqJgDbDP83vogCcDl+7
++cQkGVx+NigwItpbB6YzJxw=
+=7nuf
-----END PGP SIGNATURE-----
diff --git a/games-sports/trigger/files/trigger-0.5.1c-glx-check.patch b/games-sports/trigger/files/trigger-0.5.1c-glx-check.patch
index 6eaef541beff..185a407b0fb7 100644
--- a/games-sports/trigger/files/trigger-0.5.1c-glx-check.patch
+++ b/games-sports/trigger/files/trigger-0.5.1c-glx-check.patch
@@ -4,7 +4,7 @@ http://bugs.gentoo.org/100374
--- src/pengine/glew.c
+++ src/pengine/glew.c
-@@ -5737,7 +5737,7 @@
+@@ -5737,13 +5737,13 @@
s = glGetString(GL_VERSION);
if (!s) return GLEW_ERROR_NO_GL_VERSION;
i = _glewStrCLen(s, '.')+1;
@@ -13,3 +13,10 @@ http://bugs.gentoo.org/100374
{
return GLEW_ERROR_GL_VERSION_10_ONLY;
}
+ else
+ {
+- if (s[i] >= '5')
++ if (s[0] >= '2' || s[i] >= '5')
+ {
+ GLEW_VERSION_1_1 = GL_TRUE;
+ GLEW_VERSION_1_2 = GL_TRUE;