summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
commit53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2 (patch)
treee60f463f55aa5aac16ff1a139d0cbf4a2e4d9128 /gnome-extra
parent- bah. forgot digest. (diff)
downloadhistorical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.tar.gz
historical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.tar.bz2
historical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.zip
*** empty log message ***
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/bug-buddy/bug-buddy-2.0.1.ebuild13
-rw-r--r--gnome-extra/gnome-pim/gnome-pim-1.4.0.ebuild16
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.2.91
-rw-r--r--gnome-extra/libgda/libgda-0.2.9.ebuild61
-rw-r--r--gnome-extra/medusa/medusa-0.5.1.ebuild11
-rw-r--r--gnome-extra/users-guide/users-guide-1.2.ebuild12
6 files changed, 91 insertions, 23 deletions
diff --git a/gnome-extra/bug-buddy/bug-buddy-2.0.1.ebuild b/gnome-extra/bug-buddy/bug-buddy-2.0.1.ebuild
index 10e55af57218..ed9201c68c86 100644
--- a/gnome-extra/bug-buddy/bug-buddy-2.0.1.ebuild
+++ b/gnome-extra/bug-buddy/bug-buddy-2.0.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/bug-buddy/bug-buddy-2.0.1.ebuild,v 1.2 2001/06/04 21:57:52 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/bug-buddy/bug-buddy-2.0.1.ebuild,v 1.3 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,8 +9,15 @@ DESCRIPTION="bug-buddy"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
-DEPEND="virtual/glibc nls? ( sys-devel/gettext)
- >=gnome-base/gnome-core"
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )
+ >=gnome-base/gnome-vfs-1.0.1
+ >=gnome-base/libglade-0.15
+ >=gnome-base/gdk-pixbuf-0.11.0"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gnome-vfs-1.0.1
+ >=gnome-base/libglade-0.15
+ >=gnome-base/gdk-pixbuf-0.11.0"
src_compile() {
local myconf
diff --git a/gnome-extra/gnome-pim/gnome-pim-1.4.0.ebuild b/gnome-extra/gnome-pim/gnome-pim-1.4.0.ebuild
index eaa49f31477e..62180750a4a6 100644
--- a/gnome-extra/gnome-pim/gnome-pim-1.4.0.ebuild
+++ b/gnome-extra/gnome-pim/gnome-pim-1.4.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-pim/gnome-pim-1.4.0.ebuild,v 1.1 2001/05/17 00:10:07 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-pim/gnome-pim-1.4.0.ebuild,v 1.2 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,16 +9,20 @@ DESCRIPTION="gnome-pim"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-pim/"${A}
HOMEPGAE="http://www.gnome.org/gnome-office/gnome-pim.shtml"
-DEPEND=">=gnome-base/gnome-core-1.4.0"
+DEPEND=">=gnome-base/gnome-core-1.4.0 nls? ( sys-devel/gettext )"
RDEPEND=">=gnome-base/gnome-libs-1.2.13"
-src_compile() {
- try ./configure --host=${CHOST} --prefix=/opt/gnome
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome $myconf
try make
}
-src_install() {
- try make prefix=${D}/opt/gnome install
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
dodoc AUTHORS COPYING* ChangeLog NEWS
dodoc README*
}
diff --git a/gnome-extra/libgda/files/digest-libgda-0.2.9 b/gnome-extra/libgda/files/digest-libgda-0.2.9
new file mode 100644
index 000000000000..5f45483be561
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.2.9
@@ -0,0 +1 @@
+MD5 572b2b19a2e959aaa150ab490c57fb76 libgda-0.2.9.tar.gz
diff --git a/gnome-extra/libgda/libgda-0.2.9.ebuild b/gnome-extra/libgda/libgda-0.2.9.ebuild
new file mode 100644
index 000000000000..b6ce9e4a5664
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.2.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-db/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+DEPEND="virtual/glibc sys-apps/which
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=gnome-base/gconf-0.11
+ >=dev-perl/CORBA-ORBit-0.4.3
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-0.11
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+
+src_compile() {
+ local myconf
+ if [ "`use mysql`" ] ; then
+ myconf="--with-mysql=/usr"
+ fi
+ if [ "`use ldap`" ] ; then
+ myconf="$myconf --with-ldap=/usr"
+ fi
+ if [ "`use odbc`" ]; then
+ myconf="$myconf --with-odbc"
+ fi
+ if [ "`use postgres`" ]; then
+ myconf="$myconf --with-postgres=/usr"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome $myconf
+ try make LDFLAGS=\"-lncurses\" LIBREADLINE=\"-lreadline -lncurses\"
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=/etc/opt/gnome \
+ PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ GDA_oafinfodir=${D}/opt/gnome/share/oaf install
+ into /usr
+ dobin providers/gda-default-server/build_sqlite/{lemon,sqlite}
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README
+}
+
+
+
+
diff --git a/gnome-extra/medusa/medusa-0.5.1.ebuild b/gnome-extra/medusa/medusa-0.5.1.ebuild
index 5a6657f767f4..3b8afd4d3732 100644
--- a/gnome-extra/medusa/medusa-0.5.1.ebuild
+++ b/gnome-extra/medusa/medusa-0.5.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/medusa-0.5.1.ebuild,v 1.1 2001/05/10 01:50:35 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/medusa/medusa-0.5.1.ebuild,v 1.2 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,19 +10,18 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
-DEPEND=">=gnome-base/gnome-vfs-1.0
- >=sys-libs/db-1.8"
+DEPEND=">=gnome-base/gnome-vfs-1.0"
-src_compile() {
+src_compile() {
try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --sysconfdir=/etc/opt/gnome --mandir=/opt/gnome/share/man \
+ --sysconfdir=/etc/opt/gnome --mandir=/opt/gnome/man \
--sharedstatedir=/var/lib --localstatedir=/var/lib --enable-prefere-db1
try make medusainitdir=/tmp
}
src_install() {
try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome \
- medusainitdir=/tmp mandir=${D}/opt/gnome/share/man install
+ medusainitdir=/tmp mandir=${D}/opt/gnome/man install
dodoc AUTHORS COPYING ChangeLog NEWS README
}
diff --git a/gnome-extra/users-guide/users-guide-1.2.ebuild b/gnome-extra/users-guide/users-guide-1.2.ebuild
index edf4b8cc54c6..b60582ea2439 100644
--- a/gnome-extra/users-guide/users-guide-1.2.ebuild
+++ b/gnome-extra/users-guide/users-guide-1.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/users-guide/users-guide-1.2.ebuild,v 1.4 2000/11/04 16:14:54 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/users-guide/users-guide-1.2.ebuild,v 1.5 2001/06/05 19:43:20 achim Exp $
P=users-guide-1.2
A=${P}.tar.gz
@@ -10,18 +10,14 @@ DESCRIPTION="gnome-users-guide"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/users-guide/"${A}
HOMEPAGE="http://www.gnome.org/"
-DEPEND=">=sys-devel/automake-1.4
- >=sys-devel/autoconf-2.13
- >=sys-apps/texinfo-4.0"
+DEPEND=""
-src_compile() {
- cd ${S}
+src_compile() {
try ./configure --host=${CHOST} --prefix=/opt/gnome
try make
}
-src_install() {
- cd ${S}
+src_install() {
try make prefix=${D}/opt/gnome install
dodoc AUTHORS COPYING* ChangeLog NEWS
dodoc README* TODO