summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-23 01:00:39 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-23 01:00:39 +0000
commit087211d83ab3710855c312dfcaace622e58f9875 (patch)
tree765b87ad37220c9b56bff48fe2f4af897ca6e1b6 /media-libs/libao
parenta fix for automake's package.mask (later revs were getting masked out) (diff)
downloadhistorical-087211d83ab3710855c312dfcaace622e58f9875.tar.gz
historical-087211d83ab3710855c312dfcaace622e58f9875.tar.bz2
historical-087211d83ab3710855c312dfcaace622e58f9875.zip
updates
Diffstat (limited to 'media-libs/libao')
-rw-r--r--media-libs/libao/files/digest-libao-0.6.01
-rw-r--r--media-libs/libao/libao-0.6.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/libao/files/digest-libao-0.6.0 b/media-libs/libao/files/digest-libao-0.6.0
new file mode 100644
index 000000000000..03494a8ac75b
--- /dev/null
+++ b/media-libs/libao/files/digest-libao-0.6.0
@@ -0,0 +1 @@
+MD5 bab8b209a9440c8426d340ee8d4238ec libao-0.6.0.tar.gz
diff --git a/media-libs/libao/libao-0.6.0.ebuild b/media-libs/libao/libao-0.6.0.ebuild
new file mode 100644
index 000000000000..adc2a1e52ee9
--- /dev/null
+++ b/media-libs/libao/libao-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.6.0.ebuild,v 1.1 2001/04/23 01:00:39 pete Exp $
+
+
+A=${PN}-${PV}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="the audio output library"
+SRC_URI="http://www.vorbis.com/files/beta4/unix/${A}"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+DEPEND=">=media-sound/esound-0.2.22"
+
+src_compile() {
+ try ./configure --prefix=/usr --host=${CHOST} --enable-shared --enable-static
+ try make
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+
+ echo "Removing docs installed by make install"
+ rm -rf ${D}/usr/share/doc
+ dodoc AUTHORS CHANGES COPYING README TODO
+ dodoc doc/API doc/DRIVERS doc/USAGE doc/WANTED
+}