summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 11:51:24 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 11:51:24 +0000
commit036683903779a7475802f94d96f0807c2dec5aff (patch)
tree9da6314f5675b61435fab87da754449cd0e639a6 /media-libs/mpeg-lib
parenttypo (diff)
downloadhistorical-036683903779a7475802f94d96f0807c2dec5aff.tar.gz
historical-036683903779a7475802f94d96f0807c2dec5aff.tar.bz2
historical-036683903779a7475802f94d96f0807c2dec5aff.zip
cleanup
Diffstat (limited to 'media-libs/mpeg-lib')
-rw-r--r--media-libs/mpeg-lib/mpeg-lib-1.3.1-r1.ebuild26
1 files changed, 12 insertions, 14 deletions
diff --git a/media-libs/mpeg-lib/mpeg-lib-1.3.1-r1.ebuild b/media-libs/mpeg-lib/mpeg-lib-1.3.1-r1.ebuild
index 27983d59f740..e25a7c4f4cde 100644
--- a/media-libs/mpeg-lib/mpeg-lib-1.3.1-r1.ebuild
+++ b/media-libs/mpeg-lib/mpeg-lib-1.3.1-r1.ebuild
@@ -1,32 +1,30 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mpeg-lib/mpeg-lib-1.3.1-r1.ebuild,v 1.4 2001/08/11 03:44:19 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mpeg-lib/mpeg-lib-1.3.1-r1.ebuild,v 1.5 2002/04/27 11:42:30 seemant Exp $
-P=mpeg_lib-${PV}
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
+MY_P=${P/-/_}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="A lib for MPEG-1 video"
-SRC_URI="ftp://ftp.mni.mcgill.ca/pub/mpeg/${A}"
+SRC_URI="ftp://ftp.mni.mcgill.ca/pub/mpeg/${MY_P}.tar.gz"
HOMEPAGE="http://"
DEPEND="virtual/glibc"
src_compile() {
- try ./configure --prefix=/usr --host=${CHOST} --disable-dither
+ ./configure --prefix=/usr --host=${CHOST} --disable-dither || die
- # Doesn't work with -j 4 (hallski)
- try make OPTIMIZE="$CFLAGS"
+ # Doesn't work with -j 4 (hallski)
+ make OPTIMIZE="$CFLAGS" || die
}
src_install () {
- try make prefix=${D}/usr install
- dodoc CHANGES README
- docinto txt
- dodoc doc/image_format.eps doc/mpeg_lib.*
+ make prefix=${D}/usr install || die
+ dodoc CHANGES README
+ docinto txt
+ dodoc doc/image_format.eps doc/mpeg_lib.*
}
-