summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-07 05:49:36 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-07 05:49:36 +0000
commit8b7a0c49d8e89e7be561b70d6732526f055ea7a8 (patch)
tree36b2bfd8a29fbcf11e85aa911cc7a7cc207f67f2 /media-libs/tunepimp
parentAdded a patch for gcc 4.3 compatibility as kindly provided by Mikko C. on bug... (diff)
downloadhistorical-8b7a0c49d8e89e7be561b70d6732526f055ea7a8.tar.gz
historical-8b7a0c49d8e89e7be561b70d6732526f055ea7a8.tar.bz2
historical-8b7a0c49d8e89e7be561b70d6732526f055ea7a8.zip
Added a patch for gcc 4.3 compatibility as kindly provided by Mikko C. on bug 215579.
Package-Manager: portage-2.1.5_rc2
Diffstat (limited to 'media-libs/tunepimp')
-rw-r--r--media-libs/tunepimp/Manifest5
-rw-r--r--media-libs/tunepimp/files/tunepimp-0.5.3-gcc43.patch145
2 files changed, 148 insertions, 2 deletions
diff --git a/media-libs/tunepimp/Manifest b/media-libs/tunepimp/Manifest
index 63216f017544..cdd3b8aebdea 100644
--- a/media-libs/tunepimp/Manifest
+++ b/media-libs/tunepimp/Manifest
@@ -1,5 +1,6 @@
+AUX tunepimp-0.5.3-gcc43.patch 4787 RMD160 e444039bad0e7fc39eddea1ee4a6d48a4216b353 SHA1 bb555641e48e321137940a6248d5b0ea2acf130f SHA256 ac6b87512c08a89c04d8b9709943f4bdb491be1a56e54e450d4485a9677dc92f
DIST libtunepimp-0.5.3.tar.gz 1097005 RMD160 6bc312591b98a5b74824fc3103137cbf60d4b012 SHA1 1b904cd97ce009588fe57336f40e79b6edf9947e SHA256 341744a0be386387632fc4bb906b97d2b3346137beb2c776a41dedaeeb0f2468
-EBUILD tunepimp-0.5.3-r1.ebuild 1668 RMD160 1b1b016ea3dc75e4a84a2c3676f7c7bb990c3bcc SHA1 e873d7a72f7431fb47db62898d267972dc8063a4 SHA256 fd7c901f495f11a82041c8504db456899b79117316995a02974d900c12b92a4b
+EBUILD tunepimp-0.5.3-r1.ebuild 1709 RMD160 423c5c28e950865b6df2edd44f237ace80436641 SHA1 31c9e0628e2f8af1934585330b834d0a9c4a2184 SHA256 29dfff5a480ddc2a1c0784f2df1aba80923c9efe976dd343b5ec1b19111b3107
EBUILD tunepimp-0.5.3.ebuild 1498 RMD160 bd8cfac6e3be81e22e2c5614d3b101f711d8b738 SHA1 55fad47a5e8b1e468ca4c3de38d762e44a088877 SHA256 ef84483e80e76923a8a9f6832036dde609c6a5fe35982630ff0bf15cffa17cb2
-MISC ChangeLog 7592 RMD160 51de444ebc35b7b6a9abeda936ebb5ad56e2a263 SHA1 50af42a110f9816868911a811e7b1ea54fd78525 SHA256 e8a8602ab01927f91bbffa4d84a8e9fd52e5b41b53f10f0bdceb305d26d97b46
+MISC ChangeLog 7801 RMD160 d358df3acb54cd28cc85645578e02fc92c15fc2d SHA1 63ff4e44685fd77b5d07d451a47f1d4cc6f2e494 SHA256 be0a737a6b4ace978aee44f3fd93a9c07b3a78cef0578063bbce1367779911c9
MISC metadata.xml 156 RMD160 ecce3b981f150c45ae1e84e2d208e678d6124259 SHA1 b64f7c0b4e5db816d82ad19848f72118af129d35 SHA256 2f4da28506b9d4185f320f67a6191d30c7a921217ed4447ed46ea0bc4aefc79a
diff --git a/media-libs/tunepimp/files/tunepimp-0.5.3-gcc43.patch b/media-libs/tunepimp/files/tunepimp-0.5.3-gcc43.patch
new file mode 100644
index 000000000000..e6d2a83e856a
--- /dev/null
+++ b/media-libs/tunepimp/files/tunepimp-0.5.3-gcc43.patch
@@ -0,0 +1,145 @@
+diff -up lib/metadata.cpp.gcc43 lib/metadata.cpp
+--- lib/metadata.cpp.gcc43 2006-11-18 04:52:33.000000000 -0600
++++ lib/metadata.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -26,6 +26,7 @@
+ ----------------------------------------------------------------------------*/
+ #include <math.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "metadata.h"
+ #include "../config.h"
+ using namespace std;
+diff -up lib/protocol.cpp.gcc43 lib/protocol.cpp
+--- lib/protocol.cpp.gcc43 2006-11-28 14:25:04.000000000 -0600
++++ lib/protocol.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -8,6 +8,7 @@
+ -------------------------------------------------------------------*/
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <string>
+ #include <map>
+ #include <expat.h>
+diff -up lib/utf8/utf8util.cpp.gcc43 lib/utf8/utf8util.cpp
+--- lib/utf8/utf8util.cpp.gcc43 2006-11-18 04:52:26.000000000 -0600
++++ lib/utf8/utf8util.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -26,6 +26,7 @@
+ ----------------------------------------------------------------------------*/
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "utf8util.h"
+ #include "utf8.h"
+ #ifdef WIN32
+diff -up lib/tunepimp.cpp.gcc43 lib/tunepimp.cpp
+--- lib/tunepimp.cpp.gcc43 2006-11-18 04:52:33.000000000 -0600
++++ lib/tunepimp.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -30,7 +30,9 @@
+ #endif
+ #endif
+
++#include <string.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <map>
+ using namespace std;
+
+diff -up lib/c_wrapper.cpp.gcc43 lib/c_wrapper.cpp
+--- lib/c_wrapper.cpp.gcc43 2006-11-18 04:52:33.000000000 -0600
++++ lib/c_wrapper.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -24,6 +24,7 @@
+ $Id: tunepimp-0.5.3-gcc43.patch,v 1.1 2008/04/07 05:49:36 philantrop Exp $
+
+ ----------------------------------------------------------------------------*/
++#include <stdlib.h>
+ #include "tunepimp.h"
+ #include "mutex.h"
+ #include "tp_c.h"
+diff -up lib/readmeta.cpp.gcc43 lib/readmeta.cpp
+--- lib/readmeta.cpp.gcc43 2006-11-18 04:52:33.000000000 -0600
++++ lib/readmeta.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -31,6 +31,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #ifndef WIN32
+ #include <unistd.h>
+ #endif
+diff -up lib/fileio.cpp.gcc43 lib/fileio.cpp
+--- lib/fileio.cpp.gcc43 2006-11-18 04:52:33.000000000 -0600
++++ lib/fileio.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -27,6 +27,8 @@
+
+ #include <assert.h>
+ #include <errno.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <string>
+ #ifndef WIN32
+ #include <unistd.h>
+diff -up plugins/mp4/mp4.cpp.gcc43 plugins/mp4/mp4.cpp
+--- plugins/mp4/mp4.cpp.gcc43 2006-11-18 04:51:08.000000000 -0600
++++ plugins/mp4/mp4.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -27,6 +27,7 @@
+
+ #include <string.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <mp4.h>
+ #include "metadata.h"
+ #include "plugin.h"
+diff -up plugins/mp3/id3_meta.cpp.gcc43 plugins/mp3/id3_meta.cpp
+--- plugins/mp3/id3_meta.cpp.gcc43 2006-11-18 04:51:07.000000000 -0600
++++ plugins/mp3/id3_meta.cpp 2008-02-21 20:41:35.000000000 -0600
+@@ -26,6 +26,7 @@
+ ----------------------------------------------------------------------------*/
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <time.h>
+ #include <ctype.h>
+ #include <musicbrainz/mb_c.h>
+diff -up plugins/mp3/id3_2_3_meta.cpp.gcc43 plugins/mp3/id3_2_3_meta.cpp
+--- plugins/mp3/id3_2_3_meta.cpp.gcc43 2006-11-18 04:51:07.000000000 -0600
++++ plugins/mp3/id3_2_3_meta.cpp 2008-02-21 20:41:59.000000000 -0600
+@@ -26,6 +26,7 @@
+ ----------------------------------------------------------------------------*/
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <assert.h>
+ #include <ctype.h>
+ #include <musicbrainz/mb_c.h>
+diff -up plugins/wma/wma.cpp.gcc43 plugins/wma/wma.cpp
+--- plugins/wma/wma.cpp.gcc43 2006-11-18 04:51:28.000000000 -0600
++++ plugins/wma/wma.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -27,6 +27,7 @@
+
+ #include <string.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <wmafile.h>
+ #include "metadata.h"
+ #include "plugin.h"
+diff -up plugins/wma/wmafile.cpp.gcc43 plugins/wma/wmafile.cpp
+--- plugins/wma/wmafile.cpp.gcc43 2006-11-18 04:51:28.000000000 -0600
++++ plugins/wma/wmafile.cpp 2008-02-21 20:39:10.000000000 -0600
+@@ -19,6 +19,7 @@
+ * USA *
+ ***************************************************************************/
+
++#include <string.h>
+ #include <tstring.h>
+ #include <wmafile.h>
+ #include <wmatag.h>
+diff -up include/tunepimp-0.5/metadata.h.gcc43 include/tunepimp-0.5/metadata.h
+--- include/tunepimp-0.5/metadata.h.gcc43 2006-11-18 04:52:08.000000000 -0600
++++ include/tunepimp-0.5/metadata.h 2008-02-21 20:39:10.000000000 -0600
+@@ -27,6 +27,7 @@
+ #ifndef __METADATA_H__
+ #define __METADATA_H__
+
++#include <string.h>
+ #include <string>
+ #include <cstdio> \ No newline at end of file