summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-02 14:43:22 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-02 14:43:22 +0000
commit056d86a2d15059ca05e23afbd210b07b283a1c08 (patch)
tree976b9efbe1a35eb432b72fe6da9f8f9b6224563c /media-libs/xvid
parentfixed security bug. (diff)
downloadhistorical-056d86a2d15059ca05e23afbd210b07b283a1c08.tar.gz
historical-056d86a2d15059ca05e23afbd210b07b283a1c08.tar.bz2
historical-056d86a2d15059ca05e23afbd210b07b283a1c08.zip
xvid codec
Diffstat (limited to 'media-libs/xvid')
-rw-r--r--media-libs/xvid/ChangeLog13
-rw-r--r--media-libs/xvid/files/digest-xvid-0.9.01
-rw-r--r--media-libs/xvid/xvid-0.9.0.ebuild67
3 files changed, 81 insertions, 0 deletions
diff --git a/media-libs/xvid/ChangeLog b/media-libs/xvid/ChangeLog
new file mode 100644
index 000000000000..1c724612b577
--- /dev/null
+++ b/media-libs/xvid/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-libs/xvid
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/ChangeLog,v 1.1 2002/12/02 14:43:22 azarah Exp $
+
+*xvid-0.9.0 (02 Dec 2002)
+
+ 02 Dec 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Initial release, thanks to good work by Jacob Perkins <source@pipeline.com>.
+ Fixed the DEPEND .. we cannot depend on nasm for other archs than x86.
+ Also do not install if media-libs/divx4linux is installed. Fixed examples
+ to install into doc dir.
+
diff --git a/media-libs/xvid/files/digest-xvid-0.9.0 b/media-libs/xvid/files/digest-xvid-0.9.0
new file mode 100644
index 000000000000..e6cdedb45434
--- /dev/null
+++ b/media-libs/xvid/files/digest-xvid-0.9.0
@@ -0,0 +1 @@
+MD5 ecdb7f95eb2a0111d076f3dde4c61b1d xvidcore-0.9.0.tar.bz2 422690
diff --git a/media-libs/xvid/xvid-0.9.0.ebuild b/media-libs/xvid/xvid-0.9.0.ebuild
new file mode 100644
index 000000000000..38108b41a5d0
--- /dev/null
+++ b/media-libs/xvid/xvid-0.9.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Georgi Georgiev <chutz@chubaka.net>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-0.9.0.ebuild,v 1.1 2002/12/02 14:43:22 azarah Exp $
+
+S="${WORKDIR}/${PN}core-${PV}"
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution."
+SRC_URI="http://cvs.xvid.org/downloads/${PN}core-${PV}/${PN}core-${PV}.tar.bz2"
+HOMEPAGE="http://www.xvid.org/"
+
+DEPEND="virtual/glibc
+ x86? ( >=dev-lang/nasm-0.98.30 )
+ !media-libs/divx4linux"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/build/generic || die
+ if use ppc; then
+ sed -e "s:^CC:#CC:" \
+ -e "s:^LIBDIR:#LIBDIR:" \
+ -e "s:^CFLAGS +=:#CFLAGS +=:" \
+ -e "s:^CFLAGS =:CFLAGS +=:" \
+ Makefile.linuxppc > Makefile
+ elif use x86; then
+ sed -e "s:^LIBDIR:#LIBDIR:" \
+ -e "s:^CFLAGS +=:#CFLAGS +=:" \
+ -e "s:^#CFLAGS += -D:CFLAGS += -D:" \
+ Makefile.linuxx86 > Makefile
+ elif use sparc; then
+ sed -e "s:^CC:#CC:" \
+ -e "s:^CFLAGS = -fPIC -Wall -D:CFLAGS = -D:" \
+ Makefile.sparc > Makefile
+ fi
+}
+
+src_compile() {
+ [ -z "${CC}" ] && export CC="gcc"
+
+ cd ${S}/build/generic
+ emake || die
+}
+
+src_install() {
+ dolib.so ${S}/build/generic/libxvidcore.so
+ dolib.a ${S}/build/generic/libxvidcore.a
+
+ insinto /usr/include
+ doins src/xvid.h src/divx4.h src/encoder.h src/decoder.h
+
+ dodoc authors.txt changelog.txt LICENSE README.txt todo.txt
+
+ if [ "`use doc`" ]
+ then
+ dodoc CodingStyle doc/README doc/xvid-decoding.txt doc/xvid-encoder.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+# Empty for this release ...
+# insinto /usr/share/doc/${PF}/examples/ex1
+# doins examples/ex1/*
+ fi
+}
+