summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-10 12:57:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-10 12:57:50 +0000
commit2cfab010fc9b65bfe640c4abb3386a73797b2e62 (patch)
tree9f7241e01ac58f52dba326541cbf1f69bf1c6743 /media-sound/rezound
parentAmarok needs sqlite[threadsafe], adding it. (diff)
downloadhistorical-2cfab010fc9b65bfe640c4abb3386a73797b2e62.tar.gz
historical-2cfab010fc9b65bfe640c4abb3386a73797b2e62.tar.bz2
historical-2cfab010fc9b65bfe640c4abb3386a73797b2e62.zip
Update to EAPI=2 and USE deps.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 x86_64
Diffstat (limited to 'media-sound/rezound')
-rw-r--r--media-sound/rezound/ChangeLog8
-rw-r--r--media-sound/rezound/rezound-0.12.3_beta-r2.ebuild91
2 files changed, 98 insertions, 1 deletions
diff --git a/media-sound/rezound/ChangeLog b/media-sound/rezound/ChangeLog
index ccd1402fc8fc..82572086cb8e 100644
--- a/media-sound/rezound/ChangeLog
+++ b/media-sound/rezound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/rezound
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.54 2008/06/01 23:19:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/ChangeLog,v 1.55 2008/10/10 12:57:50 flameeyes Exp $
+
+*rezound-0.12.3_beta-r2 (10 Oct 2008)
+
+ 10 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +rezound-0.12.3_beta-r2.ebuild:
+ Update to EAPI=2 and USE deps.
01 Jun 2008; Alexis Ballier <aballier@gentoo.org>
rezound-0.12.3_beta-r1.ebuild:
diff --git a/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild b/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
new file mode 100644
index 000000000000..d86d4671d357
--- /dev/null
+++ b/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rezound/rezound-0.12.3_beta-r2.ebuild,v 1.1 2008/10/10 12:57:50 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils autotools
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+PATCHLEVEL="5"
+DESCRIPTION="Sound editor and recorder"
+HOMEPAGE="http://rezound.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="16bittmp alsa flac jack nls oss portaudio soundtouch vorbis"
+
+RDEPEND="=sci-libs/fftw-2*
+ >=x11-libs/fox-1.6.19
+ >=media-libs/audiofile-0.2.3
+ >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15
+ alsa? ( >=media-libs/alsa-lib-1.0 )
+ flac? ( >=media-libs/flac-1.1.2[cxx] )
+ jack? ( media-sound/jack-audio-connection-kit )
+ portaudio? ( >=media-libs/portaudio-18 )
+ soundtouch? ( >=media-libs/libsoundtouch-1.2.1 )
+ vorbis? ( media-libs/libvorbis media-libs/libogg )"
+
+# optional packages (don't need to be installed during emerge):
+#
+# >=media-sound/lame-3.92
+# app-cdr/cdrdao
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ dev-util/pkgconfig
+ sys-devel/flex
+ dev-util/reswrap"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+
+ AT_M4DIR="config/m4" eautoreconf
+}
+
+src_configure() {
+ # fix compilation errors on ppc, where some
+ # of the required functions aren't defined
+ use ppc && epatch "${FILESDIR}/undefined-functions.patch"
+
+ # following features can't be disabled if already installed:
+ # -> flac, oggvorbis, soundtouch
+ local sampletype="--enable-internal-sample-type=float"
+ use 16bittmp && sampletype="--enable-internal-sample-type=int16"
+
+ econf \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable nls) \
+ $(use_enable oss) \
+ $(use_enable portaudio) \
+ $(use_enable flac) \
+ $(use_enable vorbis) \
+ $(use_enable soundtouch) \
+ ${sampletype} \
+ --enable-ladspa \
+ --enable-largefile \
+ || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # remove wrong doc directory
+ rm -rf "${D}/usr/doc"
+
+ dodoc docs/{AUTHORS,NEWS,README*}
+ dodoc docs/{TODO_FOR_USERS_TO_READ,*.txt}
+ newdoc README README.rezound
+
+ docinto code
+ dodoc docs/code/*
+ newicon src/images/icon_logo_32.gif rezound.gif
+ make_desktop_entry rezound Rezound rezound.gif AudioVideo
+}