summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-03-22 14:47:41 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-03-22 14:47:41 +0000
commitc41caa132dd9a32e1d808e6728c25045adc11771 (patch)
tree432bf091a5e676f32777a0844790e7956cb2a74e /media-sound/timidity-eawpatches
parentqt 3.1.2 (diff)
downloadhistorical-c41caa132dd9a32e1d808e6728c25045adc11771.tar.gz
historical-c41caa132dd9a32e1d808e6728c25045adc11771.tar.bz2
historical-c41caa132dd9a32e1d808e6728c25045adc11771.zip
New ebuild that removes dep on rar and cleans up config (~x86 masked) closes #17895.
Diffstat (limited to 'media-sound/timidity-eawpatches')
-rw-r--r--media-sound/timidity-eawpatches/ChangeLog9
-rw-r--r--media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12-r21
-rw-r--r--media-sound/timidity-eawpatches/timidity-eawpatches-12-r2.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/media-sound/timidity-eawpatches/ChangeLog b/media-sound/timidity-eawpatches/ChangeLog
index 818384cfe6e6..762c6c7cfa6c 100644
--- a/media-sound/timidity-eawpatches/ChangeLog
+++ b/media-sound/timidity-eawpatches/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/timidity-eawpatches
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-eawpatches/ChangeLog,v 1.3 2003/02/12 07:34:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-eawpatches/ChangeLog,v 1.4 2003/03/22 14:47:41 jje Exp $
+
+*timidity-eawpatches-12-r2 (22 Mar 2003)
+
+ 22 Mar 2003; jje <jje@gentoo.org> timidity-eawpatches-12-r2.ebuild:
+ Updated ebuild that removes dep on rar and simplifies config.
+
+ Submitted by: Jordan <lx_xero@zapo.net>
*timidity-eawpatches-12-r1 (03 Dec 2002)
diff --git a/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12-r2 b/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12-r2
new file mode 100644
index 000000000000..a45653bba691
--- /dev/null
+++ b/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12-r2
@@ -0,0 +1 @@
+MD5 8ebcf0583f3077346ebace93c8ea166f eawpats12_full.tar.gz 32047230
diff --git a/media-sound/timidity-eawpatches/timidity-eawpatches-12-r2.ebuild b/media-sound/timidity-eawpatches/timidity-eawpatches-12-r2.ebuild
new file mode 100644
index 000000000000..098cea7fb5f0
--- /dev/null
+++ b/media-sound/timidity-eawpatches/timidity-eawpatches-12-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+S=${WORKDIR}/eawpats
+DESCRIPTION="Eric Welsh's GUS patches for TiMidity"
+SRC_URI="http://5hdumat.samizdat.net/music/eawpats${PV}_full.tar.gz"
+HOMEPAGE="http://www.stardate.bc.ca/eawpatches/html/default.htm"
+
+DEPEND="media-sound/timidity++"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+src_unpack() {
+unpack ${A}
+cd ${S}/linuxconfig
+cp timidity.cfg timidity.cfg.orig
+sed -e "s:dir /home/user/eawpats/:dir /usr/share/timidity/eawpatches:" timidity.cfg.orig > timidity.cfg
+rm -f timidity.cfg.orig
+}
+
+src_install () {
+ local instdir=/usr/share/timidity
+
+ # Install base timidity configuration
+ insinto ${instdir}
+ doins linuxconfig/timidity.cfg
+ rm -rf linuxconfig/ winconfig/
+
+ # Install base eawpatches
+ insinto ${instdir}/eawpatches
+ doins *.cfg *.pat
+ rm *.cfg *.pat
+
+ # Install patches from subdirectories
+ for d in `find . -type f -name \*.pat | sed 's,/[^/]*$,,' | sort -u`; do
+ insinto ${instdir}/eawpatches/${d}
+ doins ${d}/*.pat
+ done
+
+ # Install documentation, including subdirs
+ find . -name \*.txt | xargs dodoc
+}