summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-06-18 00:01:41 +0000
committerDean Bailey <alron@gentoo.org>2003-06-18 00:01:41 +0000
commit6071ef990b6b9b414dfd462e4179e64b8e6b7272 (patch)
tree40644d63a9790bc1ecbe3b8f52869df2ec673d3b /net-analyzer/nagios-nrpe
parentbug fixes and sample config file update for nagios-nrpe-1.8 (diff)
downloadhistorical-6071ef990b6b9b414dfd462e4179e64b8e6b7272.tar.gz
historical-6071ef990b6b9b414dfd462e4179e64b8e6b7272.tar.bz2
historical-6071ef990b6b9b414dfd462e4179e64b8e6b7272.zip
bug fixes and sample config file update for nagios-nrpe-1.8
Diffstat (limited to 'net-analyzer/nagios-nrpe')
-rw-r--r--net-analyzer/nagios-nrpe/Manifest6
-rw-r--r--net-analyzer/nagios-nrpe/files/digest-nagios-nrpe-1.8-r11
-rw-r--r--net-analyzer/nagios-nrpe/files/nrpe-1.828
-rw-r--r--net-analyzer/nagios-nrpe/files/nrpe-1.8.cfg109
-rw-r--r--net-analyzer/nagios-nrpe/nagios-nrpe-1.8-r1.ebuild45
5 files changed, 186 insertions, 3 deletions
diff --git a/net-analyzer/nagios-nrpe/Manifest b/net-analyzer/nagios-nrpe/Manifest
index 046e58beaaa4..ec9247021745 100644
--- a/net-analyzer/nagios-nrpe/Manifest
+++ b/net-analyzer/nagios-nrpe/Manifest
@@ -1,8 +1,8 @@
-MD5 2101f36ca06979901022c20577ae175f ChangeLog 820
+MD5 3c36b4261999e95efa8578c98aedeea1 ChangeLog 979
MD5 f5a92b15efd03c4450240c3dab592c71 nagios-nrpe-1.5.ebuild 1303
MD5 d4663abffa74b59ddc03092fe980a3cc nagios-nrpe-1.7.ebuild 1293
MD5 1007323cc5e9e0b92fb8bad06ac8324f nagios-nrpe-1.8.ebuild 1292
-MD5 f734a2d44a510fa9a9a5fcded7a218b5 nagios-nrpe-1.8-r1.ebuild 1310
+MD5 770a2252acf55b025a3550be85a75b54 nagios-nrpe-1.8-r1.ebuild 1313
MD5 1ea034ce9ade9210fa8c4ade4d51d132 files/nrpe-1.8 462
MD5 62a8fab21b530ee8851102e4e4d1f849 files/digest-nagios-nrpe-1.5 59
MD5 5ae9122f91dd3885d576d8be150275c7 files/digest-nagios-nrpe-1.7 59
@@ -10,4 +10,4 @@ MD5 a9506069b34b36a580c78efa20b05cc9 files/digest-nagios-nrpe-1.8 59
MD5 77b7ce60fefcec082219a891d56a5d85 files/nrpe 449
MD5 7436efd047d6ef909de4f68ed97badca files/nrpe.cfg 3130
MD5 a9506069b34b36a580c78efa20b05cc9 files/digest-nagios-nrpe-1.8-r1 59
-MD5 69ee92bf6b462d289c8c3fd7bd7b8844 files/nrpe-1.8.cfg 3507
+MD5 3c91382446609ec78fa98d94509539dd files/nrpe-1.8.cfg 3501
diff --git a/net-analyzer/nagios-nrpe/files/digest-nagios-nrpe-1.8-r1 b/net-analyzer/nagios-nrpe/files/digest-nagios-nrpe-1.8-r1
new file mode 100644
index 000000000000..9c03c28c4b38
--- /dev/null
+++ b/net-analyzer/nagios-nrpe/files/digest-nagios-nrpe-1.8-r1
@@ -0,0 +1 @@
+MD5 b285e2838685508ab85395f480018373 nrpe-1.8.tar.gz 41347
diff --git a/net-analyzer/nagios-nrpe/files/nrpe-1.8 b/net-analyzer/nagios-nrpe/files/nrpe-1.8
new file mode 100644
index 000000000000..dfb4f832138e
--- /dev/null
+++ b/net-analyzer/nagios-nrpe/files/nrpe-1.8
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting nrpe"
+ start-stop-daemon --start --quiet --name nrpe \
+ --startas /usr/nagios/bin/nrpe \
+ -c nagios:nagios \
+ -- -c /etc/nagios/nrpe.cfg \
+ --daemon
+ eend $? "Failed to Start nrpe"
+}
+
+stop() {
+ ebegin "Stopping nrpe"
+ start-stop-daemon --stop --quiet -n nrpe
+ eend $? "Failed to Stop nrpe"
+}
+
+restart() {
+ ebegin "Restarting nrpe"
+ svc_stop
+ svc_start
+ eend $? "Failed to Restart nrpe"
+}
diff --git a/net-analyzer/nagios-nrpe/files/nrpe-1.8.cfg b/net-analyzer/nagios-nrpe/files/nrpe-1.8.cfg
new file mode 100644
index 000000000000..3f35b7e46964
--- /dev/null
+++ b/net-analyzer/nagios-nrpe/files/nrpe-1.8.cfg
@@ -0,0 +1,109 @@
+#############################################################################
+# Sample NRPE Config File
+# Written by: Ethan Galstad (nagios@nagios.org)
+#
+# Last Modified: 12-30-2002
+#
+# NOTES:
+# This is a sample configuration file for the NRPE daemon. It needs to be
+# located on the remote host that is running the NRPE daemon, not the host
+# from which the check_nrpe client is being executed.
+#############################################################################
+
+
+
+# PORT NUMBER
+# Port number we should wait for connections on.
+# NOTE: This must be a non-priviledged port (i.e. > 1024).
+# NOTE: This option is ignored if NRPE is running under either inetd or xinetd
+
+server_port=5666
+
+
+
+# SERVER ADDRESS
+# Address that nrpe should bind to in case there are more than one interface
+# and you do not want nrpe to bind on all interfaces.
+# NOTE: This option is ignored if NRPE is running under either inetd or xinetd
+
+#server_address=192.168.1.1
+
+
+
+# ALLOWED HOST ADDRESSES
+# This is a comma-delimited list of IP address of hosts that are allowed
+# to talk to the NRPE daemon.
+#
+# NOTE: The daemon only does rudimentary checking of the client's IP
+# address. I would highly recommend adding entries in your
+# /etc/hosts.allow file to allow only the specified host to connect
+# to the port you are running this daemon on.
+#
+# NOTE: This option is ignored if NRPE is running under either inetd or xinetd
+
+allowed_hosts=127.0.0.1
+
+
+
+# NRPE USER
+# This determines the effective user that the NRPE daemon should run as.
+# You can either supply a username or a UID.
+#
+# NOTE: This option is ignored if NRPE is running under either inetd or xinetd
+
+nrpe_user=nagios
+
+
+
+# NRPE GROUP
+# This determines the effective group that the NRPE daemon should run as.
+# You can either supply a group name or a GID.
+#
+# NOTE: This option is ignored if NRPE is running under either inetd or xinetd
+
+nrpe_group=nagios
+
+
+
+# DEBUGGING OPTION
+# This option determines whether or not debugging messages are logged to the
+# syslog facility.
+# Values: 0=debugging off, 1=debugging on
+
+debug=0
+
+
+
+# COMMAND TIMEOUT
+# This specifies the maximum number of seconds that the NRPE daemon will
+# allow plugins to finish executing before killing them off.
+
+command_timeout=60
+
+
+
+# COMMAND DEFINITIONS
+# Command definitions that this daemon will run. Definitions
+# are in the following format:
+#
+# command[<command_name>]=<command_line>
+#
+# When the daemon receives a request to return the results of <command_name>
+# it will execute the command specified by the <command_line> argument.
+#
+# Unlike Nagios, the command line cannot contain macros - it must be
+# typed exactly as it should be executed.
+#
+# Note: Any plugins that are used in the command lines must reside
+# on the machine that this daemon is running on! The examples below
+# assume that you have plugins installed in a /usr/nagios/libexec
+# directory. Also note that you will have to modify the definitions below
+# to match the argument format the plugins expect. Remember, these are
+# examples only!
+
+command[check_users]=/usr/nagios/libexec/check_users -w 5 -c 10
+command[check_load]=/usr/nagios/libexec/check_load -w 15,10,5 -c 30,25,20
+command[check_disk1]=/usr/nagios/libexec/check_disk -w 20 -c 10 -p /dev/hda1
+command[check_disk2]=/usr/nagios/libexec/check_disk -w 20 -c 10 -p /dev/hdb1
+command[check_zombie_procs]=/usr/nagios/libexec/check_procs -w 5 -c 10 -s Z
+command[check_total_procs]=/usr/nagios/libexec/check_procs -w 150 -c 200
diff --git a/net-analyzer/nagios-nrpe/nagios-nrpe-1.8-r1.ebuild b/net-analyzer/nagios-nrpe/nagios-nrpe-1.8-r1.ebuild
new file mode 100644
index 000000000000..2ebe431e6b53
--- /dev/null
+++ b/net-analyzer/nagios-nrpe/nagios-nrpe-1.8-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-nrpe/nagios-nrpe-1.8-r1.ebuild,v 1.1 2003/06/18 00:01:38 alron Exp $
+DESCRIPTION="Nagios $PV NRPE - Nagios Remote Plugin Executor"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagios/nrpe-1.8.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc"
+IUSE=""
+DEPEND=">=net-analyzer/nagios-plugins-1.3.0"
+S="${WORKDIR}/nrpe-1.8"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --localstatedir=/var/nagios \
+ --sysconfdir=/etc/nagios \
+ --with-nrpe-user=nagios \
+ --with-nrpe-grp=nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake all || die
+}
+
+src_install() {
+ dodoc LEGAL Changelog README
+ insinto /etc/nagios
+ newins ${FILESDIR}/nrpe-1.8.cfg nrpe.cfg
+ exeinto /usr/nagios/bin
+ doexe src/nrpe
+ fowners nagios:nagios /usr/nagios/bin/nrpe
+ exeinto /usr/nagios/libexec
+ doexe src/check_nrpe
+ fowners nagios:nagios /usr/nagios/libexec/check_nrpe
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nrpe-1.8 nrpe
+}
+pkg_postinst() {
+ einfo
+ einfo "If you are using the nrpe daemon, remember to edit"
+ einfo "the config file /etc/nagios/nrpe.cfg"
+ einfo
+}