summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-31 05:39:44 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-31 05:39:44 +0000
commitcbfa0d0e4093e8e4f2ea6b2f5767e2fb1d00538e (patch)
treeea1f068fa92ff4be7f847c9b29e5b62ec8c0367b /net-analyzer/ttcp
parentver bump (diff)
downloadhistorical-cbfa0d0e4093e8e4f2ea6b2f5767e2fb1d00538e.tar.gz
historical-cbfa0d0e4093e8e4f2ea6b2f5767e2fb1d00538e.tar.bz2
historical-cbfa0d0e4093e8e4f2ea6b2f5767e2fb1d00538e.zip
initial ebuild #36087
Diffstat (limited to 'net-analyzer/ttcp')
-rw-r--r--net-analyzer/ttcp/ChangeLog8
-rw-r--r--net-analyzer/ttcp/files/digest-ttcp-1.121
-rw-r--r--net-analyzer/ttcp/ttcp-1.12.ebuild24
3 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/ttcp/ChangeLog b/net-analyzer/ttcp/ChangeLog
new file mode 100644
index 000000000000..798774e561e1
--- /dev/null
+++ b/net-analyzer/ttcp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-analyzer/ttcp
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttcp/ChangeLog,v 1.1 2003/12/31 05:39:44 vapier Exp $
+
+*ttcp-1.12 (31 Dec 2003)
+
+ 31 Dec 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Sam Stephenson <sam@conio.net> #36087.
diff --git a/net-analyzer/ttcp/files/digest-ttcp-1.12 b/net-analyzer/ttcp/files/digest-ttcp-1.12
new file mode 100644
index 000000000000..6209d99976aa
--- /dev/null
+++ b/net-analyzer/ttcp/files/digest-ttcp-1.12
@@ -0,0 +1 @@
+MD5 ee7cee9f35e0c496675e84545ef4c290 ttcp-1.12.tar.bz2 8086
diff --git a/net-analyzer/ttcp/ttcp-1.12.ebuild b/net-analyzer/ttcp/ttcp-1.12.ebuild
new file mode 100644
index 000000000000..11c71ef0e334
--- /dev/null
+++ b/net-analyzer/ttcp/ttcp-1.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttcp/ttcp-1.12.ebuild,v 1.1 2003/12/31 05:39:44 vapier Exp $
+
+inherit gcc
+
+DESCRIPTION="Tool to test TCP and UDP throughput"
+HOMEPAGE="http://ftp.arl.mil/~mike/ttcp.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ $(gcc-getCC) ${CFLAGS} -o ttcp sgi-ttcp.c || die "compile failed"
+}
+
+src_install() {
+ dobin ttcp
+ newman sgi-ttcp.1 ttcp.1
+}