summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-09-17 21:20:26 +0000
committerNed Ludd <solar@gentoo.org>2003-09-17 21:20:26 +0000
commitcaf9c2c7dc9bb573405fb373566ca823ac79be4b (patch)
tree494893ce053576c755acf8005a9b913a30b20e51 /net-dns
parentRecently verisign added a wildcard A record to the .COM and .NET TLD DNS zone... (diff)
downloadhistorical-caf9c2c7dc9bb573405fb373566ca823ac79be4b.tar.gz
historical-caf9c2c7dc9bb573405fb373566ca823ac79be4b.tar.bz2
historical-caf9c2c7dc9bb573405fb373566ca823ac79be4b.zip
Recently verisign added a wildcard A record to the .COM and .NET TLD DNS zones making all .com and .net domains appear to be registered.
Adding ISC bind patch. Updated ebuild submission by Bryan Stine. Added a few comments from Danny and Corporate Gadfly to pkg_postinst.
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind/Manifest4
-rw-r--r--net-dns/bind/bind-9.2.2-r3.ebuild169
-rw-r--r--net-dns/bind/files/digest-bind-9.2.2-r32
3 files changed, 173 insertions, 2 deletions
diff --git a/net-dns/bind/Manifest b/net-dns/bind/Manifest
index f9c176e7dbde..9a1ff56752a3 100644
--- a/net-dns/bind/Manifest
+++ b/net-dns/bind/Manifest
@@ -1,9 +1,9 @@
-MD5 f25e9c609b35482fb6a6c0a280580cd8 ChangeLog 5761
+MD5 8d34ddcc2a6737caa70f11ed359b9c5c ChangeLog 6127
MD5 7c5d3f4bad0445e7676b3a204b8deed2 bind-9.2.2-r1.ebuild 4809
MD5 225916d21a5023684fb0ed5c00653b3c bind-9.2.2-r2.ebuild 4817
MD5 9926e763424186f29b7c14554c53c024 bind-9.2.2.ebuild 4599
MD5 dd6e3cefff04ee6141a57ec7b0ec04af bind-9.2.2_rc1-r2.ebuild 4485
-MD5 626a8bf1caf8b0d84681de79ff91921a bind-9.2.2-r3.ebuild 5487
+MD5 451001436c55689a8423ed11d222e1b4 bind-9.2.2-r3.ebuild 5582
MD5 42b5ed5adcee33cf40531d7955412b21 files/10bind.env 27
MD5 51197afe8da37b1b453456de90ca4f25 files/127 227
MD5 51197afe8da37b1b453456de90ca4f25 files/127.zone 227
diff --git a/net-dns/bind/bind-9.2.2-r3.ebuild b/net-dns/bind/bind-9.2.2-r3.ebuild
new file mode 100644
index 000000000000..2cb9a1e78329
--- /dev/null
+++ b/net-dns/bind/bind-9.2.2-r3.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.2.2-r3.ebuild,v 1.1 2003/09/17 21:20:23 solar Exp $
+
+IUSE="ssl ipv6 doc"
+
+DESCRIPTION="BIND - Berkeley Internet Name Domain - Name Server"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz ftp://ftp.isc.org/isc/bind9/${PV}/patch.${PV}-P1"
+HOMEPAGE="http://www.isc.org/products/BIND/bind9.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="sys-apps/groff
+ >=sys-apps/sed-4
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+
+ epatch ${DISTDIR}/patch.${PV}-P1
+
+ # Adjusting PATHs in manpages
+ for i in `echo bin/{named/named.8,check/named-checkconf.8,nsupdate/nsupdate.8,rndc/rndc.8}`; do
+ sed -i -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
+ -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
+ -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
+ ${i}
+ done
+}
+
+src_compile() {
+ local myconf=""
+
+ use ssl && myconf="${myconf} --with-openssl"
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --enable-ipv6=no"
+
+ econf --sysconfdir=/etc/bind \
+ --localstatedir=/var \
+ --enable-threads \
+ --with-libtool \
+ ${myconf}
+
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "failed to compile bind"
+}
+
+src_install() {
+ einstall || die "failed to install bind"
+
+ dodoc CHANGES COPYRIGHT FAQ README
+
+ use doc && {
+ docinto misc ; dodoc doc/misc/*
+ docinto html ; dodoc doc/arm/*
+ docinto draft ; dodoc doc/draft/*
+ docinto rfc ; dodoc doc/rfc/*
+ docinto contrib ; dodoc contrib/named-bootconf/named-bootconf.sh \
+ contrib/nanny/nanny.pl
+ }
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/10bind.env 10bind
+
+ # some handy-dandy dynamic dns examples
+ cd ${D}/usr/share/doc/${PF}
+ tar pjxf ${FILESDIR}/dyndns-samples.tbz2
+
+ dodir /etc/bind /var/bind/{pri,sec}
+ keepdir /var/bind/sec
+
+ insinto /etc/bind ; newins ${FILESDIR}/named.conf-r2 named.conf
+ # ftp://ftp.rs.internic.net/domain/named.ca:
+ insinto /var/bind ; doins ${FILESDIR}/named.ca
+ insinto /var/bind/pri ; doins ${FILESDIR}/{127,localhost}.zone
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/named.rc6 named
+ insinto /etc/conf.d ; newins ${FILESDIR}/named.confd named
+
+ dosym ../../var/bind/named.ca /var/bind/root.cache
+ dosym ../../var/bind/pri /etc/bind/pri
+ dosym ../../var/bind/sec /etc/bind/sec
+}
+
+pkg_preinst() {
+ # Let's get rid of those tools and their manpages since they're provided by bind-tools
+ rm -f ${D}/usr/share/man/man1/{dig.1.gz,host.1.gz}
+ rm -f ${D}/usr/bin/{dig,host,nslookup}
+}
+
+pkg_postinst() {
+ if [ ! -f '/etc/bind/rndc.key' ]; then
+ /usr/sbin/rndc-confgen -a -u named
+ fi
+
+ install -d -o named -g named ${ROOT}/var/run/named \
+ ${ROOT}/var/bind/pri ${ROOT}/var/bind/sec
+ chown -R named:named ${ROOT}/var/bind
+
+ einfo "The default zone files are now installed as *.zone,"
+ einfo "be careful merging config files if you have modified"
+ einfo "/var/bind/pri/127 or /var/bind/pri/localhost"
+ einfo
+ einfo "You can edit /etc/conf.d/named to customize named settings"
+ einfo
+ einfo "The BIND ebuild now includes chroot support."
+ einfo "If you like to run bind in chroot AND this is a new install OR"
+ einfo "your bind doesn't already run in chroot, simply run:"
+ einfo "\`ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\`"
+ einfo "Before running the above command you might want to change the chroot"
+ einfo "dir in /etc/conf.d/named. Otherwise /chroot/dns will be used."
+ echo
+ einfo "Recently verisign added a wildcard A record to the .COM and .NET TLD"
+ einfo "zones making all .com and .net domains appear to be registered"
+ einfo "This causes many problems such as breaking important anti-spam checks"
+ einfo "which verify source domains exist. ISC released a patch for BIND which"
+ einfo "adds 'delegation-only' zones to allow admins to return the .com and .net"
+ einfo "domain resolution to their normal function."
+ echo
+ einfo "There is no need to create a com or net data file. Just the"
+ einfo "entries to the named.conf file is enough."
+ echo
+ einfo " zone "com" IN { type delegation-only; };"
+ einfo " zone "net" IN { type delegation-only; };"
+}
+
+pkg_config() {
+
+ CHROOT=`sed -n 's/^[[:blank:]]\?CHROOT="\([^"]\+\)"/\1/p' /etc/conf.d/named 2>/dev/null`
+ EXISTS="no"
+
+ if [ -z "${CHROOT}" -a ! -d "/chroot/dns" ]; then
+ CHROOT="/chroot/dns"
+ elif [ -d ${CHROOT} ]; then
+ eerror; eerror "${CHROOT:-/chroot/dns} already exists. Quitting."; eerror; EXISTS="yes"
+ fi
+
+ if [ ! "$EXISTS" = yes ]; then
+ einfo ; einfon "Setting up the chroot directory..."
+ mkdir -m 700 -p ${CHROOT}
+ mkdir -p ${CHROOT}/{dev,etc,var/run/named}
+ chown -R named:named ${CHROOT}/var/run/named
+ cp -R /etc/bind ${CHROOT}/etc/
+ cp /etc/localtime ${CHROOT}/etc/localtime
+ chown named:named ${CHROOT}/etc/bind/rndc.key
+ cp -R /var/bind ${CHROOT}/var/
+ chown -R named:named ${CHROOT}/var/
+ mknod ${CHROOT}/dev/zero c 1 5
+ mknod ${CHROOT}/dev/random c 1 8
+ chmod 666 ${CHROOT}/dev/{random,zero}
+ chown named:named ${CHROOT}
+
+ grep -q "^#[[:blank:]]\?CHROOT" /etc/conf.d/named ; RETVAL=$?
+ if [ $RETVAL = 0 ]; then
+ sed 's/^# \?\(CHROOT.*\)$/\1/' /etc/conf.d/named > /etc/conf.d/named.orig 2>/dev/null
+ mv --force /etc/conf.d/named.orig /etc/conf.d/named
+ fi
+
+ sleep 1; echo " Done."; sleep 1
+ einfo
+ einfo "Add the following to your root .bashrc or .bash_profile: "
+ einfo " alias rndc='rndc -k ${CHROOT}/etc/bind/rndc.key'"
+ einfo "Then do the following: "
+ einfo " source /root/.bashrc or .bash_profile"
+ einfo
+ fi
+}
+
diff --git a/net-dns/bind/files/digest-bind-9.2.2-r3 b/net-dns/bind/files/digest-bind-9.2.2-r3
new file mode 100644
index 000000000000..95fe6b80e521
--- /dev/null
+++ b/net-dns/bind/files/digest-bind-9.2.2-r3
@@ -0,0 +1,2 @@
+MD5 6ea7d64a0856893ab3eb541ab7bbc725 bind-9.2.2.tar.gz 5054652
+MD5 063edc41c756ffc6a1051d5f1937fa2c patch.9.2.2-P1 40087