summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrakash Shetty <crux@gentoo.org>2001-06-25 10:24:23 +0000
committerPrakash Shetty <crux@gentoo.org>2001-06-25 10:24:23 +0000
commitdcfcd29c6a3bb4fe9c8cf9ac83526cf5b3530317 (patch)
treea35c40b9625a6386167189913dcdff7af02015a5 /net-ftp
parent*** empty log message *** (diff)
downloadhistorical-dcfcd29c6a3bb4fe9c8cf9ac83526cf5b3530317.tar.gz
historical-dcfcd29c6a3bb4fe9c8cf9ac83526cf5b3530317.tar.bz2
historical-dcfcd29c6a3bb4fe9c8cf9ac83526cf5b3530317.zip
A Fully Featured FTP Server
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.71
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-0.98.7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7 b/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7
new file mode 100644
index 000000000000..f6c4a53075df
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7
@@ -0,0 +1 @@
+MD5 381169cc31fdebfa2d414cd264d8485b pure-ftpd-0.98.7.tar.gz
diff --git a/net-ftp/pure-ftpd/pure-ftpd-0.98.7.ebuild b/net-ftp/pure-ftpd/pure-ftpd-0.98.7.ebuild
new file mode 100644
index 000000000000..f59e59152a6a
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-0.98.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty (Crux) <ps@gnuos.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Fast Production Quality FTP Server"
+SRC_URI="http://prdownloads.sourceforge.net/pureftpd/${A}"
+HOMEPAGE="http://pureftpd.sourceforge.net"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.75"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --with-throttling --with-virtualhosts\
+ --with-ratios --with-largefile
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc COPYING ChangeLog README README.Configuration-File
+ dodoc README.Contrib README.LDAP README.Netfilter
+}
+
+pkg_config() {
+ echo "This config script will add pftpd lines to your /etc/xinetd.conf."
+ echo "Press control-C to abort, hit Enter to continue."
+ echo
+ read
+ cat ${FILESDIR}/pftpd.xinetd >> ${ROOT}etc/xinetd.conf
+ echo "Modifications applied."
+}
+
+
+