summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-07-02 00:56:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-07-02 00:56:59 +0000
commit6de54b85cb3ab4fe1ba71a0f3b23073c287e3120 (patch)
treeeca41859266a9b09d02fe3f2ac32c0985000247d /net-im/gyach
parent(no commit message) (diff)
downloadhistorical-6de54b85cb3ab4fe1ba71a0f3b23073c287e3120.tar.gz
historical-6de54b85cb3ab4fe1ba71a0f3b23073c287e3120.tar.bz2
historical-6de54b85cb3ab4fe1ba71a0f3b23073c287e3120.zip
*** empty log message ***
Diffstat (limited to 'net-im/gyach')
-rw-r--r--net-im/gyach/ChangeLog8
-rw-r--r--net-im/gyach/files/digest-gyach-0.9.7-r11
-rw-r--r--net-im/gyach/files/gyach-0.9.7-yahoo-auth-2004-06-24.diff95
-rw-r--r--net-im/gyach/gyach-0.9.7-r1.ebuild38
4 files changed, 141 insertions, 1 deletions
diff --git a/net-im/gyach/ChangeLog b/net-im/gyach/ChangeLog
index 2d97c99cb2c9..7442d9e5ce54 100644
--- a/net-im/gyach/ChangeLog
+++ b/net-im/gyach/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gyach
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gyach/ChangeLog,v 1.7 2004/07/01 22:18:43 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gyach/ChangeLog,v 1.8 2004/07/02 00:56:59 mkennedy Exp $
+
+*gyach-0.9.7-r1 (01 Jul 2004)
+
+ 01 Jul 2004; <mkennedy@gentoo.org>
+ +files/gyach-0.9.7-yahoo-auth-2004-06-24.diff, +gyach-0.9.7-r1.ebuild:
+ Incorporate patch for post 2004-06-24 Yahoo protocol changes.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> gyach-0.9.6.ebuild,
gyach-0.9.7.ebuild:
diff --git a/net-im/gyach/files/digest-gyach-0.9.7-r1 b/net-im/gyach/files/digest-gyach-0.9.7-r1
new file mode 100644
index 000000000000..147ba6626842
--- /dev/null
+++ b/net-im/gyach/files/digest-gyach-0.9.7-r1
@@ -0,0 +1 @@
+MD5 ee473860f48ecdaed837dc1a6204574b gyach-0.9.7.tar.gz 323904
diff --git a/net-im/gyach/files/gyach-0.9.7-yahoo-auth-2004-06-24.diff b/net-im/gyach/files/gyach-0.9.7-yahoo-auth-2004-06-24.diff
new file mode 100644
index 000000000000..7fdda83b0ea8
--- /dev/null
+++ b/net-im/gyach/files/gyach-0.9.7-yahoo-auth-2004-06-24.diff
@@ -0,0 +1,95 @@
+diff --exclude='*~' -ur gyach-0.9.7.orig/src/yahoo_fn.c gyach-0.9.7/src/yahoo_fn.c
+--- gyach-0.9.7.orig/src/yahoo_fn.c 2004-01-22 23:12:36.000000000 -0600
++++ gyach-0.9.7/src/yahoo_fn.c 2004-07-01 09:38:10.989741680 -0500
+@@ -4388,7 +4388,7 @@
+ { XOR, 0x77D64B90, 0 },
+ { BITFLD, (int)table_103, 0 },
+ { LOOKUP, (int)table_104, 0 },
+- { MULADD, 0x7D1428CB, 0x89F6853D },
++ { MULADD, 0x7D1428CB, 0x3D },
+ { XOR, 0x6F872C49, 0 },
+ { XOR, 0x2E484655, 0 },
+ { MULADD, 0x1E3349F7, 0x41F5 },
+diff --exclude='*~' -ur gyach-0.9.7.orig/src/yahoo_md5.c gyach-0.9.7/src/yahoo_md5.c
+--- gyach-0.9.7.orig/src/yahoo_md5.c 2004-01-22 23:18:11.000000000 -0600
++++ gyach-0.9.7/src/yahoo_md5.c 2004-07-01 09:35:11.632008200 -0500
+@@ -175,7 +175,7 @@
+
+ }
+
+-static void yahoo_process_auth_new(char *username, char *password, char *seed)
++static void yahoo_process_auth(char *username, char *password, char *seed)
+ {
+ char *name = username;
+ char *pass = password;
+@@ -424,6 +424,8 @@
+ * challenge. */
+
+ shaUpdate(&ctx1, pass_hash_xor1, 64);
++ if (j >= 3)
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);
+
+@@ -513,6 +515,8 @@
+ * challenge. */
+
+ shaUpdate(&ctx1, crypt_hash_xor1, 64);
++ if (j >= 3)
++ ctx1.sizeLo = 0x1ff;
+ shaUpdate(&ctx1, magic_key_char, 4);
+ shaFinal(&ctx1, digest1);
+
+@@ -585,22 +589,12 @@
+ }
+
+ char *getstr1(char *username, char *password, char *key) {
+- yahoo_process_auth_old(username, password, key);
+- return result6;
+-}
+-
+-char *getstr2(char *username, char *password, char *key) {
+- yahoo_process_auth_old(username, password, key);
+- return result96;
+-}
+-
+-char *getstr1_new(char *username, char *password, char *key) {
+- yahoo_process_auth_new(username, password, key);
++ yahoo_process_auth(username, password, key);
+ return resp_6;
+ }
+
+-char *getstr2_new(char *username, char *password, char *key) {
+- yahoo_process_auth_new(username, password, key);
++char *getstr2(char *username, char *password, char *key) {
++ yahoo_process_auth(username, password, key);
+ return resp_96;
+ }
+
+diff --exclude='*~' -ur gyach-0.9.7.orig/src/yahoo_md5.h gyach-0.9.7/src/yahoo_md5.h
+--- gyach-0.9.7.orig/src/yahoo_md5.h 2003-09-28 09:26:28.000000000 -0500
++++ gyach-0.9.7/src/yahoo_md5.h 2004-07-01 09:36:30.858963872 -0500
+@@ -2,8 +2,5 @@
+ char *getstr1(char *username, char *password, char *key);
+ char *getstr2(char *username, char *password, char *key);
+
+-char *getstr1_new(char *username, char *password, char *key);
+-char *getstr2_new(char *username, char *password, char *key);
+-
+ char *yahoo_crypt(char *key, char *salt);
+
+diff --exclude='*~' -ur gyach-0.9.7.orig/src/yahoochat.c gyach-0.9.7/src/yahoochat.c
+--- gyach-0.9.7.orig/src/yahoochat.c 2003-09-28 17:55:02.000000000 -0500
++++ gyach-0.9.7/src/yahoochat.c 2004-07-01 09:36:44.625870984 -0500
+@@ -380,9 +380,9 @@
+
+ sprintf( ptr, "%s%s%s%s%s%s%s%s%s%s%s%s%s%s%s%s%s%s%s%s",
+ "0", YMSG9_SEP, session->user, YMSG9_SEP,
+- "6", YMSG9_SEP, getstr1_new( session->user, session->password, key ),
++ "6", YMSG9_SEP, getstr1( session->user, session->password, key ),
+ YMSG9_SEP,
+- "96", YMSG9_SEP, getstr2_new( session->user, session->password, key ),
++ "96", YMSG9_SEP, getstr2( session->user, session->password, key ),
+ YMSG9_SEP,
+ "2", YMSG9_SEP, session->user, YMSG9_SEP,
+ "1", YMSG9_SEP, session->user, YMSG9_SEP
diff --git a/net-im/gyach/gyach-0.9.7-r1.ebuild b/net-im/gyach/gyach-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..c77ea045d118
--- /dev/null
+++ b/net-im/gyach/gyach-0.9.7-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gyach/gyach-0.9.7-r1.ebuild,v 1.1 2004/07/02 00:56:59 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ =x11-libs/gtk+-2*"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/gyach-${PV}-yahoo-auth-2004-06-24.diff
+}
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL README* TODO
+ dodoc sample.*
+
+ # install icon and desktop entry for gnome
+ if use gnome ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+}