summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-01-13 00:45:58 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-01-13 00:45:58 +0000
commit89f168c56ac4aa1336b82aba11ead3f8659107d6 (patch)
tree3b10d94f1f6babc0f32b28d8edd9a48644d5a17b /net-im/magnesium/magnesium-1.0_pre32.ebuild
parent*** empty log message *** (diff)
downloadhistorical-89f168c56ac4aa1336b82aba11ead3f8659107d6.tar.gz
historical-89f168c56ac4aa1336b82aba11ead3f8659107d6.tar.bz2
historical-89f168c56ac4aa1336b82aba11ead3f8659107d6.zip
*** empty log message ***
Diffstat (limited to 'net-im/magnesium/magnesium-1.0_pre32.ebuild')
-rw-r--r--net-im/magnesium/magnesium-1.0_pre32.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-im/magnesium/magnesium-1.0_pre32.ebuild b/net-im/magnesium/magnesium-1.0_pre32.ebuild
new file mode 100644
index 000000000000..f19500e074e0
--- /dev/null
+++ b/net-im/magnesium/magnesium-1.0_pre32.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/magnesium/magnesium-1.0_pre32.ebuild,v 1.1 2004/01/13 00:45:51 mkennedy Exp $
+
+MY_P=${PN}-${PV/1.0_/}
+DESCRIPTION="Curphoo X (Magnesium) is a Yahoo chat client."
+HOMEPAGE="http://members.iinet.net.au/~texascm/mg/"
+SRC_URI="http://members.iinet.net.au/~texascm/mg/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="=gnome-base/libglade-2*
+ =dev-python/pygtk-2*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv ui.py ui.py.in && sed "s,curphoo.glade,/usr/lib/${P}/curphoo.glade,g" <ui.py.in >ui.py
+}
+
+src_compile() {
+ einfo "Skipping compilation"
+}
+
+src_install() {
+ insinto /usr/lib/${P}
+ doins *.py curphoo.glade
+ chmod +x ${D}/usr/lib/${P}/mg.py
+ sed "s,@MAGNESIUMPATH@,${P},g" <${FILESDIR}/magnesium >magnesium || die
+ dobin magnesium
+ dodoc gpl.txt README CREDITS AUTHORS CHANGELOG COPYING ChangeLog NEWS
+}