summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2006-04-14 16:45:43 +0000
committerMartin Holzer <mholzer@gentoo.org>2006-04-14 16:45:43 +0000
commit78fbf5b7c7e2097b824afa93ed50ec91c86e63a8 (patch)
tree3f8fbf8eefd2e96d9978a25f2802a2a8c56dd48c /net-mail/mailman
parentAdded code to remove files provided by ut2004 and closing bug #129932. (diff)
downloadhistorical-78fbf5b7c7e2097b824afa93ed50ec91c86e63a8.tar.gz
historical-78fbf5b7c7e2097b824afa93ed50ec91c86e63a8.tar.bz2
historical-78fbf5b7c7e2097b824afa93ed50ec91c86e63a8.zip
Security bump. see bug #129136
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-mail/mailman')
-rw-r--r--net-mail/mailman/ChangeLog18
-rw-r--r--net-mail/mailman/files/digest-mailman-2.1.8_rc11
-rw-r--r--net-mail/mailman/files/mailman-2.1.8_rc1-directory-check.patch30
-rw-r--r--net-mail/mailman/mailman-2.1.8_rc1.ebuild147
4 files changed, 190 insertions, 6 deletions
diff --git a/net-mail/mailman/ChangeLog b/net-mail/mailman/ChangeLog
index 6b1948977ac6..928aa59dddb6 100644
--- a/net-mail/mailman/ChangeLog
+++ b/net-mail/mailman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mailman
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/ChangeLog,v 1.71 2006/02/13 04:12:08 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/ChangeLog,v 1.72 2006/04/14 16:42:12 mholzer Exp $
+
+*mailman-2.1.8_rc1 (14 Apr 2006)
+
+ 14 Apr 2006; Martin Holzer <mholzer@gentoo.org>
+ +files/mailman-2.1.8_rc1-directory-check.patch, +mailman-2.1.8_rc1.ebuild:
+ Security bump. see bug #129136
13 Feb 2006; Jason Wever <weeve@gentoo.org> mailman-2.1.7.ebuild:
Stable on SPARC wrt security bug #119313.
@@ -52,7 +58,7 @@
*mailman-2.1.6_beta1 (12 Feb 2005)
- 12 Feb 2005; Tuấn Văn <langthang@gentoo.org>
+ 12 Feb 2005; Tuấn Văn <langthang@gentoo.org>
+files/mailman-2.1.6_beta1-directory-check.patch,
+mailman-2.1.6_beta1.ebuild:
New version. New directory-check.patch, thanks to Brian Harring <ferringb@gentoo.org>
@@ -63,10 +69,10 @@
09 Feb 2005; Gustavo Zacarias <gustavoz@gentoo.org> mailman-2.1.5-r4.ebuild:
Stable on sparc wrt #81109
- 09 Feb 2005; Olivier Crête <tester@gentoo.org> mailman-2.1.5-r4.ebuild:
+ 09 Feb 2005; Olivier Crête <tester@gentoo.org> mailman-2.1.5-r4.ebuild:
Stable on x86, bug #81109
- 09 Feb 2005; Tuấn Văn <langthang@gentoo.org>
+ 09 Feb 2005; Tuấn Văn <langthang@gentoo.org>
+files/mailman-2.1.5-true_path.patch:
revision bump with true_path patch.
@@ -74,7 +80,7 @@
mailman-2.1.5-r3.ebuild:
Stable on amd64, bug #77524
- 16 Jan 2005; Tuấn Văn <langthang@gentoo.org> mailman-2.1.5-r3.ebuild:
+ 16 Jan 2005; Tuấn Văn <langthang@gentoo.org> mailman-2.1.5-r3.ebuild:
stable on x86.
16 Jan 2005; Jason Wever <weeve@gentoo.org> mailman-2.1.5-r3.ebuild:
@@ -82,7 +88,7 @@
*mailman-2.1.5-r3 (15 Jan 2005)
- 15 Jan 2005; Tuấn Văn <langthang@gentoo.org>
+ 15 Jan 2005; Tuấn Văn <langthang@gentoo.org>
+files/mailman-2.1.5-driver.cvs.patch, +mailman-2.1.5-r3.ebuild:
revision bump to resolve bug #77524.
diff --git a/net-mail/mailman/files/digest-mailman-2.1.8_rc1 b/net-mail/mailman/files/digest-mailman-2.1.8_rc1
new file mode 100644
index 000000000000..4bd883272e2d
--- /dev/null
+++ b/net-mail/mailman/files/digest-mailman-2.1.8_rc1
@@ -0,0 +1 @@
+MD5 7d56c45ded47c62d642a6e8b016ee8ee mailman-2.1.8rc1.tgz 6856298
diff --git a/net-mail/mailman/files/mailman-2.1.8_rc1-directory-check.patch b/net-mail/mailman/files/mailman-2.1.8_rc1-directory-check.patch
new file mode 100644
index 000000000000..d8542fcf6a88
--- /dev/null
+++ b/net-mail/mailman/files/mailman-2.1.8_rc1-directory-check.patch
@@ -0,0 +1,30 @@
+--- bin/check_perms.org 2005-05-25 00:04:15.000000000 +0200
++++ bin/check_perms 2005-05-25 00:04:35.000000000 +0200
+@@ -331,6 +331,8 @@
+ print _('checking permissions on list data')
+ # BAW: This needs to be converted to the Site module abstraction
+ for dir in os.listdir(mm_cfg.LIST_DATA_DIR):
++ if not S_ISDIR(statmode(os.path.join(mm_cfg.LIST_DATA_DIR,dir))):
++ continue
+ for file in checkfiles:
+ path = os.path.join(mm_cfg.LIST_DATA_DIR, dir, file)
+ if STATE.VERBOSE:
+--- bin/update.org 2005-05-25 00:04:30.000000000 +0200
++++ bin/update 2005-05-25 00:04:35.000000000 +0200
+@@ -34,6 +34,7 @@
+ """
+
+ import os
++import stat
+ import md5
+ import sys
+ import time
+@@ -425,7 +426,7 @@
+ # Now update for the Mailman 2.1.5 qfile format. For every filebase in
+ # the qfiles/* directories that has both a .pck and a .db file, pull the
+ # data out and re-queue them.
+- for dirname in os.listdir(mm_cfg.QUEUE_DIR):
++ for dirname in [x for x in os.listdir(mm_cfg.QUEUE_DIR) if stat.S_ISDIR(os.stat(os.path.join(mm_cfg.QUEUE_DIR,x)).st_mode)]:
+ dirpath = os.path.join(mm_cfg.QUEUE_DIR, dirname)
+ if dirpath == mm_cfg.BADQUEUE_DIR:
+ # The files in qfiles/bad can't possibly be pickles
diff --git a/net-mail/mailman/mailman-2.1.8_rc1.ebuild b/net-mail/mailman/mailman-2.1.8_rc1.ebuild
new file mode 100644
index 000000000000..753685a8bb2b
--- /dev/null
+++ b/net-mail/mailman/mailman-2.1.8_rc1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.8_rc1.ebuild,v 1.1 2006/04/14 16:42:12 mholzer Exp $
+
+inherit eutils depend.apache
+IUSE="apache2 postfix sendmail qmail courier exim xmail"
+
+MY_PV=${PV/_rc/rc}
+
+DESCRIPTION="A python-based mailing list server with an extensive web interface"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tgz"
+HOMEPAGE="http://www.list.org/"
+
+SLOT="O"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3
+ virtual/mta
+ net-www/apache"
+
+INSTALLDIR="/usr/local/mailman"
+APACHEGID="81"
+
+if use postfix; then
+ MAILGID="280"
+elif use sendmail; then
+ MAILGID=daemon
+elif use qmail; then
+ MAILGID=qmail
+elif use courier; then
+ MAILGID=mail
+elif use exim; then
+ MAILGID=mail
+elif use xmail; then
+ MAILGID=xmail
+else
+ MAILGID="280"
+fi
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ # Bug #58526: switch to enew{group,user}.
+ # need to add mailman here for compile process.
+ # Duplicated at pkg_postinst() for binary install.
+ enewgroup mailman 280
+ enewuser mailman 280 /bin/bash ${INSTALLDIR} mailman -G cron -c mailman
+ mkdir -p ${INSTALLDIR}
+ chown mailman:mailman ${INSTALLDIR}
+ chmod 2775 ${INSTALLDIR}
+}
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ epatch ${FILESDIR}/${P}-directory-check.patch || die "patch failed."
+}
+
+src_compile() {
+
+ econf \
+ --prefix=${INSTALLDIR} \
+ --with-mail-gid=${MAILGID} \
+ --with-cgi-gid=${APACHEGID} \
+ || die "configure failed"
+
+ make || die "make failed"
+}
+
+src_install () {
+ ID=${D}${INSTALLDIR}
+
+ make prefix=${ID} var_prefix=${ID} doinstall || die
+
+ keepdir ${INSTALLDIR}/logs
+ keepdir ${INSTALLDIR}/locks
+ keepdir ${INSTALLDIR}/spam
+ keepdir ${INSTALLDIR}/archives/public
+ keepdir ${INSTALLDIR}/archives/private
+ keepdir ${INSTALLDIR}/lists
+ keepdir ${INSTALLDIR}/qfiles
+
+ if use apache2; then
+ insinto ${APACHE2_MODULES_CONFDIR}
+ else
+ insinto ${APACHE1_MODULES_CONFDIR}
+ fi
+ newins ${FILESDIR}/mailman.conf 50_mailman.conf
+
+ dodoc ${FILESDIR}/README.gentoo
+ dodoc ACK* BUGS FAQ NEWS README* TODO UPGRADING INSTALL
+ dodoc contrib/README.check_perms_grsecurity contrib/mm-handler.readme
+ dodoc contrib/virtusertable contrib/mailman.mc
+
+ cp build/contrib/*.py contrib/majordomo2mailman.pl contrib/auto \
+ contrib/mm-handler* ${D}/usr/local/mailman/bin
+
+ # Save the old config into the new package as CONFIG_PROTECT
+ # doesn't work for this package.
+ if [ -f ${ROOT}/var/mailman/Mailman/mm_cfg.py ]; then
+ cp ${ROOT}/var/mailman/Mailman/mm_cfg.py \
+ ${D}/usr/local/mailman/Mailman/mm_cfg.py
+ einfo "Your old config has been saved as mm_cfg.py"
+ einfo "A new config has been installed as mm_cfg.dist"
+ fi
+ if [ -f ${ROOT}/home/mailman/Mailman/mm_cfg.py ]; then
+ cp ${ROOT}/home/mailman/Mailman/mm_cfg.py \
+ ${D}/usr/local/mailman/Mailman/mm_cfg.py
+ einfo "Your old config has been saved as mm_cfg.py"
+ einfo "A new config has been installed as mm_cfg.py.dist"
+ fi
+ if [ -f ${ROOT}/usr/local/mailman/Mailman/mm_cfg.py ]; then
+ cp ${ROOT}/usr/local/mailman/Mailman/mm_cfg.py \
+ ${D}/usr/local/mailman/Mailman/mm_cfg.py
+ einfo "Your old config has been saved as mm_cfg.py"
+ einfo "A new config has been installed as mm_cfg.py.dist"
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mailman.rc mailman
+
+ chown -R mailman:mailman ${ID}
+ chmod 2775 ${ID}
+}
+
+pkg_postinst() {
+ enewgroup mailman 280
+ enewuser mailman 280 -1 ${INSTALLDIR} mailman -G cron -c "mailman"
+ cd ${INSTALLDIR}
+ bin/update
+ einfo "Running \`${INSTALLDIR}/bin/check_perms -f\` *"
+ bin/check_perms -f
+ einfo ""
+ einfo "Please read /usr/share/doc/${PF}/README.gentoo.gz for additional"
+ einfo "Setup information, mailman will NOT run unless you follow"
+ einfo "those instructions!"
+ einfo ""
+
+ einfo "An example Mailman configuration file for Apache has been installed into:"
+ use apache2 && einfo " ${APACHE2_MODULES_CONFDIR}/50_mailman.conf"
+ use apache2 || einfo " ${APACHE1_MODULES_CONFDIR}/50_mailman.conf"
+ einfo ""
+ einfo "To enable, you will need to add \"-D MAILMAN\" to"
+ use apache2 && einfo "/etc/conf.d/apache2."
+ use apache2 || einfo "/etc/conf.d/apache."
+ einfo ""
+}