summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-10-03 16:16:41 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-10-03 16:16:41 +0000
commit7007c163838d2a79168bc7ec30205d052e84decd (patch)
tree19782875052fed64d2fb057c89fa12983a7920ff /net-misc
parentSRC_URI typo fix (diff)
downloadhistorical-7007c163838d2a79168bc7ec30205d052e84decd.tar.gz
historical-7007c163838d2a79168bc7ec30205d052e84decd.tar.bz2
historical-7007c163838d2a79168bc7ec30205d052e84decd.zip
New versions to fix recent exploits.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/files/digest-openssh-2.9.9_p21
-rw-r--r--net-misc/openssh/files/digest-openssh-2.9.9_p2-r61
-rw-r--r--net-misc/openssh/openssh-2.9.9_p2-r6.ebuild48
-rw-r--r--net-misc/openssh/openssh-2.9.9_p2.ebuild48
-rw-r--r--net-misc/openssh/openssh-2.9_p2.ebuild2
5 files changed, 99 insertions, 1 deletions
diff --git a/net-misc/openssh/files/digest-openssh-2.9.9_p2 b/net-misc/openssh/files/digest-openssh-2.9.9_p2
new file mode 100644
index 000000000000..f6a36bd8264d
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-2.9.9_p2
@@ -0,0 +1 @@
+MD5 5061e6e0748713bca1b40fc8b13ff5ce openssh-2.9.9p2.tar.gz
diff --git a/net-misc/openssh/files/digest-openssh-2.9.9_p2-r6 b/net-misc/openssh/files/digest-openssh-2.9.9_p2-r6
new file mode 100644
index 000000000000..f6a36bd8264d
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-2.9.9_p2-r6
@@ -0,0 +1 @@
+MD5 5061e6e0748713bca1b40fc8b13ff5ce openssh-2.9.9p2.tar.gz
diff --git a/net-misc/openssh/openssh-2.9.9_p2-r6.ebuild b/net-misc/openssh/openssh-2.9.9_p2-r6.ebuild
new file mode 100644
index 000000000000..f5c7d58c7f16
--- /dev/null
+++ b/net-misc/openssh/openssh-2.9.9_p2-r6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# /home/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2-r6.ebuild,v 1.1 2001/09/07 09:07:37 woodchip Exp
+
+P=openssh-2.9.9p2
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Port of OpenBSD's free SSH release"
+SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${A}"
+HOMEPAGE="http://www.openssh.com/"
+
+DEPEND="virtual/glibc sys-devel/perl sys-apps/groff
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ pam? ( >=sys-libs/pam-0.73 )
+ >=dev-libs/openssl-0.9.6
+ sys-libs/zlib"
+
+RDEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.73 )
+ >=dev-libs/openssl-0.9.6
+ sys-libs/zlib"
+
+src_compile() {
+
+ local myconf
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use pam && myconf="${myconf} --with-pam"
+ use pam || myconf="${myconf} --without-pam"
+
+ ./configure --prefix=/usr --sysconfdir=/etc/ssh --host=${CHOST} \
+ --libexecdir=/usr/lib/misc --mandir=/usr/share/man \
+ --with-ipv4-default --disable-suid-ssh ${myconf}
+ assert
+ make || die
+}
+
+src_install() {
+
+ make install-files DESTDIR=${D} || die
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/sshd.pam.rc6 sshd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/sshd.rc6 sshd
+}
diff --git a/net-misc/openssh/openssh-2.9.9_p2.ebuild b/net-misc/openssh/openssh-2.9.9_p2.ebuild
new file mode 100644
index 000000000000..dbc9141c098a
--- /dev/null
+++ b/net-misc/openssh/openssh-2.9.9_p2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# /home/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2.ebuild,v 1.3 2001/09/07 09:07:37 woodchip Exp
+
+P=openssh-2.9.9p2
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Port of OpenBSD's free SSH release"
+SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${A}"
+HOMEPAGE="http://www.openssh.com/"
+
+DEPEND="virtual/glibc sys-devel/perl sys-apps/groff
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ pam? ( >=sys-libs/pam-0.73 )
+ >=dev-libs/openssl-0.9.6
+ sys-libs/zlib"
+
+RDEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.73 )
+ >=dev-libs/openssl-0.9.6
+ sys-libs/zlib"
+
+src_compile() {
+
+ local myconf
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use pam && myconf="${myconf} --with-pam"
+ use pam || myconf="${myconf} --without-pam"
+
+ ./configure --prefix=/usr --sysconfdir=/etc/ssh --host=${CHOST} \
+ --libexecdir=/usr/lib/misc --mandir=/usr/share/man \
+ --with-ipv4-default --disable-suid-ssh ${myconf}
+ assert
+ make || die
+}
+
+src_install() {
+
+ make install-files DESTDIR=${D} || die
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/sshd.pam.rc5 sshd
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/sshd.rc5 sshd
+}
diff --git a/net-misc/openssh/openssh-2.9_p2.ebuild b/net-misc/openssh/openssh-2.9_p2.ebuild
index 16d5fddd9ba6..bb607886d881 100644
--- a/net-misc/openssh/openssh-2.9_p2.ebuild
+++ b/net-misc/openssh/openssh-2.9_p2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2.ebuild,v 1.3 2001/09/07 09:07:37 woodchip Exp $
+# /home/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2.ebuild,v 1.3 2001/09/07 09:07:37 woodchip Exp
P=openssh-2.9p2
A=${P}.tar.gz