summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-07-19 22:21:01 +0000
committerJon Hood <squinky86@gentoo.org>2004-07-19 22:21:01 +0000
commit1dea22f9ceb7da202ff415081a59986cbd35db58 (patch)
tree66b3f783314c73aa0b97d57139927205074309ae /net-p2p
parentmake live-cvs support simple (diff)
downloadhistorical-1dea22f9ceb7da202ff415081a59986cbd35db58.tar.gz
historical-1dea22f9ceb7da202ff415081a59986cbd35db58.tar.bz2
historical-1dea22f9ceb7da202ff415081a59986cbd35db58.zip
slightly updated ebuild
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/ChangeLog4
-rw-r--r--net-p2p/amule/Manifest4
-rw-r--r--net-p2p/amule/amule-2.0.0_rc5.ebuild66
3 files changed, 30 insertions, 44 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index 85307b61298c..19f9ffa5ea21 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,12 +1,12 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.26 2004/07/19 14:20:39 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.27 2004/07/19 22:21:01 squinky86 Exp $
*amule-2.0.0_rc5 (19 Jul 2004)
19 Jul 2004; Jon Hood <squinky86@gentoo.org> +amule-2.0.0_rc5.ebuild:
version bump, closes #57528, thanks to Giacomo Perale <ghepeu@virgilio.it> for
- the update
+ the updated ebuild
*amule-1.2.8 (14 Jul 2004)
diff --git a/net-p2p/amule/Manifest b/net-p2p/amule/Manifest
index 49a58f533820..baf21291b389 100644
--- a/net-p2p/amule/Manifest
+++ b/net-p2p/amule/Manifest
@@ -1,8 +1,8 @@
MD5 4d782261e1774291ce965fc6e560c4ba amule-2.0.0_rc3.ebuild 2206
MD5 44203597f71957b61d479e8dff75af9d amule-1.2.7.ebuild 1087
-MD5 7d3dbbbdb61c7fad2b8b71db676014e5 amule-2.0.0_rc5.ebuild 2206
+MD5 cc34bc881cf3635603ff837a2478dbb8 amule-2.0.0_rc5.ebuild 1815
MD5 83a5322edb2d852d6bb032f9ee59ff7d amule-1.2.6.ebuild 1028
-MD5 6043989152e29ec4b353a3b2ac912dbc ChangeLog 3770
+MD5 5b4e27d7a6e76e3af625c5ca4f68f1b3 ChangeLog 3778
MD5 ae2f0c7a2c494c412921813d8f047f92 amule-1.2.8.ebuild 1086
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
MD5 2fb2652f4ff91f2244ff07cccd31d5d2 files/digest-amule-2.0.0_rc3 68
diff --git a/net-p2p/amule/amule-2.0.0_rc5.ebuild b/net-p2p/amule/amule-2.0.0_rc5.ebuild
index 1951f6cb9618..3606bf1676e9 100644
--- a/net-p2p/amule/amule-2.0.0_rc5.ebuild
+++ b/net-p2p/amule/amule-2.0.0_rc5.ebuild
@@ -1,70 +1,56 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.0_rc5.ebuild,v 1.1 2004/07/19 14:20:39 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.0_rc5.ebuild,v 1.2 2004/07/19 22:21:01 squinky86 Exp $
MY_P=${P/m/M}
MY_P=${MY_P/_/}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="aNOTHER wxWindows based eMule P2P Client"
+DESCRIPTION="aMule, the all-platform eMule p2p client"
HOMEPAGE="http://www.amule.org"
SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-# this is a release candidate- do not put in the stable tree yet
KEYWORDS="~x86 ~amd64"
-IUSE="debug nls stats remote"
-RESTRICT="nomirror"
-
+IUSE="debug nls remote stats"
EXTRA_ECONF="--disable-optimise"
-# optimizations disabled for better stability
-# new USE "noamulestats" disables aMule GUI statistics (wxCas) (require gd)
-# new USE "noamuleremote" disables remote control utilities: webserver,
-# web client, amulecmd text client
+# USE "stats" enables external utilities (statistics and other)
+# USE "remote" enables remote controlling utilities (webserver, text client)
-
-DEPEND=">=x11-libs/wxGTK-2.4.2
+DEPEND="remote? ( =x11-libs/wxGTK-2.4* ) : ( >=x11-libs/wxGTK-2.4.2-r1 )
>=net-misc/curl-7.11.0
- >=dev-libs/crypto++-5.1
+ >=dev-libs/crypto++-5.1-r1
>=sys-libs/zlib-1.2.1
- stats? ( >=media-libs/gd-2.0.22 )"
+ stats? ( >=media-libs/gd-2.0.23 )"
pkg_setup() {
- # GTK2 is unstable and not supported by aMule developers
- if wx-config --cppflags | grep gtk2 >& /dev/null; then
- einfo "Compiling ${PN} against wxGTK2 is not supported."
- die "wxGTK must be re-emerged with USE=-gtk2."
- fi
-
- # aMule doesn't compile against unicoded wxGTK at all.
- if wx-config --cppflags | grep gtk2u >& /dev/null; then
- einfo "${PN} will not build if wxGTK was compiled"
- einfo "with unicode support. If you are using a version of"
- einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
- einfo "you must set USE=-unicode."
- die "wxGTK must be re-emerged without unicode suport"
+ # GTK2 is unstable on wxGTK 2.4 and not supported by aMule developers
+ if wx-config --version | grep 2.4 >& /dev/null \
+ && wx-config --cppflags | grep gtk2 >& /dev/null; then
+ einfo "Compiling ${PN} against wxGTK2 2.4.x is not supported."
+ einfo "wxGTK must be re-emerged with USE=\"-gtk2\" or you can upgrade"
+ einfo "to development snapshots 2.5.1, but this will break other"
+ einfo "applications and the webserver. Please note that gtk2 support"
+ einfo "is still experimental."
+ die "wxGTK 2.4 must be re-emerged with USE=\"-gtk2\"."
fi
}
src_compile() {
-
- use remote || EXTRA_ECONF="${EXTRA_ECONF} --disable-amulecmd \
- --disable-amulecmdgui \
- --disable-webserver \
- --disable-webservergui" \
- || EXTRA_ECONF="${EXTRA_ECONF} --enable-amulecmd \
- --enable-amulecmdgui \
- --enable-webserver \
- --enable-webservergui"
-
- #workaround for broken configure (doesn't recognize --enable-wxcas)
- use stats || EXTRA_ECONF="${EXTRA_ECONF} --disable-wxcas"
-
econf `use_enable nls` \
+ `use_enable remote amulecmd` \
+ `use_enable remote amulecmdgui` \
+ `use_enable remote webserver` \
+ `use_enable remote webservergui` \
+ `use_enable stats cas` \
+ `use_enable stats wxcas` \
+ `use_enable stats alc` \
+ `use_enable stats alcc` \
`use_enable debug` || die
emake -j1 || die